Mouse Usb, comportamento anomalo

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Webbino
Linux 2.x
Linux 2.x
Messaggi: 227
Iscritto il: ven 14 ott 2005, 18:05

Mouse Usb, comportamento anomalo

Messaggio da Webbino »

'Salve

Ho fatto una breve ricerca nel forum ma non ho trovato nulla.


Vi espongo il problema, ho un notebook (con touchpad annesso) e come molti di voi non voglio rinunciare alla comodità del mouse.. ho configurato Xorg in maniera tale che touchpad e mouse convivano serenamente.


La configurazione del mouse è quella tipica, ovvero:
Identifier "Mouse2"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/input/mouse0"
Option "Emulate3Buttons" "no"
Ed i driver vengono caricati come: InputDevice "Mouse2" "AlwaysCore" in maniera tale che se il mouse non è presente il server X parte senza problemi.

Ora il problema è che se il mouse è attaccato prima che il server X si avvii la rotellina funziona correttamente, al contrario quando attacco il mouse dopo aver avviato il server X la rotellina non risponde.


Che impostazione devo correggere o aggiungere ?


Vi ringrazio

Avatar utente
dnegroni
Linux 0.x
Linux 0.x
Messaggi: 27
Iscritto il: lun 8 gen 2007, 10:30
Slackware: 12.2
Località: Genova

Re: Mouse Usb, comportamento anomalo

Messaggio da dnegroni »

Ciao

qui di seguito trovi la mia configurazione per il mouse in xorg.conf
Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection
L'unica differenza che vedo rispetto al tuo è l' Emulate3Buttons.

Spero possa esserti di aiuto

ciao

Avatar utente
tigerwalk
Linux 3.x
Linux 3.x
Messaggi: 890
Iscritto il: lun 25 feb 2008, 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.37-14.2
Kernel: 3.10.17-tiger / 4.4.88-smp
Desktop: kde4/xfce4
Località: Napoli

Re: Mouse Usb, comportamento anomalo

Messaggio da tigerwalk »

Codice: Seleziona tutto

Option "Emulate3Buttons" "true"
credo sia proprio questo il problema, a te è settato a "no", prova a metterlo a "true".

Avatar utente
sardylan
Linux 3.x
Linux 3.x
Messaggi: 993
Iscritto il: mar 24 apr 2007, 9:21
Nome Cognome: Luca Cireddu
Slackware: current 64bits
Kernel: 3.16
Desktop: KDE 4.14
Distribuzione: Debian - CLFS
Località: Cagliari
Contatta:

Re: Mouse Usb, comportamento anomalo

Messaggio da sardylan »

Io non ho avuto bisogno di nessuna modifica... Ho dato xorgconfig la prima volta e basta... Tutto va a meraviglia... Un'unica voce per il mouse che fa funzionare contemporaneamente touchpad e mouse USB con scroll e tutto il resto...
Vi posto la parte dello xorg...

Codice: Seleziona tutto

Section "InputDevice"
        Identifier      "Mouse"
        Driver          "mouse"
        Option          "Protocol" "IMPS/2"
        Option          "Device" "/dev/input/mice"
        Option          "ZAxisMapping" "4 5 6 7"
        Option          "Emulate3Buttons"
EndSection

Rispondi