Pagina 1 di 1

[RISOLTO] Dopo aggiornamento CUPS non riesco più a stampare

Inviato: dom 27 apr 2008, 9:50
da syaochan
Ciao, stamattina dovevo stampare una cosa, ma CUPS non ne vuole sapere.
Mettendo il livello di log a "debug" il risultato è questo:

Codice: Seleziona tutto

E [27/Apr/2008:09:39:34 +0200] [Job 4] /invalidfont in findfont
D [27/Apr/2008:09:39:34 +0200] [Job 4] Operand stack:
D [27/Apr/2008:09:39:34 +0200] Discarding unused printer-state-changed event...
D [27/Apr/2008:09:39:34 +0200] [Job 4] bigFont   Helvetica-Bold   Font   Helvetica-Bold   691534   Helvetica-Bold   --nostri
ngval--   Helvetica-Bold   NimbusSanL-Bold
D [27/Apr/2008:09:39:34 +0200] [Job 4] Execution stack:
D [27/Apr/2008:09:39:34 +0200] [Job 4] %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2
%stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1
 3   %oparray_pop   1   3   %oparray_pop   1   3   %oparray_pop   .runexec2   --nostringval--   --nostringval--   --nostring
val--   2   %stopped_push   --nostringval--   2   3   %oparray_pop   3   3   %oparray_pop   --nostringval--   --nostringval-
-   --nostringval--   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   6   4   %oparray_pop
   --nostringval--   --nostringval--   --nostringval--   1   -1   1   --nostringval--   %for_neg_int_continue
D [27/Apr/2008:09:39:34 +0200] [Job 4] Dictionary stack:
D [27/Apr/2008:09:39:34 +0200] [Job 4] --dict:1121/1686(ro)(G)--   --dict:0/20(G)--   --dict:123/200(L)--   --dict:47/65(ro)
(G)--   --dict:1121/1686(ro)(G)--
D [27/Apr/2008:09:39:34 +0200] [Job 4] Current allocation mode is local
D [27/Apr/2008:09:39:34 +0200] [Job 4] Last OS error: 2
D [27/Apr/2008:09:39:34 +0200] [Job 4] ESP Ghostscript 815.04: Unrecoverable error, exit code 1
E [27/Apr/2008:09:39:34 +0200] [Job 4] No pages found!
D [27/Apr/2008:09:39:34 +0200] Discarding unused printer-state-changed event...
E [27/Apr/2008:09:39:34 +0200] PID 16511 (/usr/lib/cups/filter/rastertoepson) stopped with status 1!
E [27/Apr/2008:09:39:34 +0200] PID 16510 (/usr/lib/cups/filter/pstoraster) stopped with status 1!
E [27/Apr/2008:09:39:34 +0200] [Job 4] Back-channel read error - Input/output error!
D [27/Apr/2008:09:39:34 +0200] Discarding unused printer-state-changed event...
D [27/Apr/2008:09:39:34 +0200] PID 16512 (/usr/lib/cups/backend/epson) exited with no errors.
D [27/Apr/2008:09:39:34 +0200] [Job 4] File 0 is complete.
D [27/Apr/2008:09:39:34 +0200] Discarding unused printer-state-changed event...
D [27/Apr/2008:09:39:34 +0200] Discarding unused job-stopped event...
Temo di aver aggiornato, qualche giorno fa, il pacchetto di CUPS (l'update di sicurezza uscito da poco) senza prima fermare il servizio. Ho una Slackware 12.0.
Ho provato a togliere cups, gimp-print e espgs, rimuovere /etc/cups, /var/spool/cups e /var/cache/cups, quindi a reinstallare il tutto, ma ho sempre lo stesso errore.
Cosa posso fare? Grazie

Re: Dopo aggiornamento CUPS non riesco più a stampare

Inviato: dom 27 apr 2008, 10:54
da syaochan
Risolto. Non si sa come, erano spariti dei font da /usr/share/ghostscript/fonts :shock:
Ho seguito il consiglio riportato qui:
the solution was provided by:

http://www.linuxpackages.net/forum/v...66d26c00bc0098

a simple upgradepkg --reinstall ap/ghostscript-fonts-std-8.11-noarch-1.tgz did the trick
e con un

Codice: Seleziona tutto

slapt-get -i --reinstall ghostscript-fonts-std
è andato tutto a posto.