Pagina 1 di 1

problemi con MYSQL slack 12.1

Inviato: mar 6 mag 2008, 21:58
da ermes
apro un altro argomento perchè il precedente è stato chiuso come risolto.
Come da titolo non riesco a utilizzare mysql.
seguendo (credo alla lettera) la procedura non riesco ad ottenere nulla. Se lancio "rc.mysld" Sembra che il server venga avviato ma poi non riesco ad accedere con nessun utente, nemmeno come root.
Ho provato a togliere ri-installare il pacchetto e rifare la procedura di configurazione.
Dopo aver creato il file /etc/my.cnf lancio "mysql_install_db" e la risposta negativa del sistema la riporto sotto:

idee
grazie :cry:

________________________
root@localhost:/root# mysql_install_db --user=mysql
Installing MySQL system tables...
ERROR: 1062 Duplicate entry 'localhost-' for key 1
080506 21:51:23 [ERROR] Aborting

080506 21:51:23 [Note] /usr/libexec/mysqld: Shutdown complete

Installation of system tables failed!

Examine the logs in /var/lib/mysql for more information.
You can try to start the mysqld daemon with:
/usr/libexec/mysqld --skip-grant &
and use the command line tool
/usr/bin/mysql to connect to the mysql
database and look at the grant tables:

shell> /usr/bin/mysql -u root mysql
mysql> show tables

Try 'mysqld --help' if you have problems with paths. Using --log
gives you a log in /var/lib/mysql that may be helpful.

The latest information about MySQL is available on the web at
http://www.mysql.com
Please consult the MySQL manual section: 'Problems running mysql_install_db',
and the manual section that describes problems on your OS.
Another information source is the MySQL email archive.
Please check all of the above before mailing us!
And if you do mail us, you MUST use the /usr/bin/mysqlbug script!

Re: problemi con MYSQL slack 12.1

Inviato: mar 6 mag 2008, 22:15
da aschenaz
Ma quel comando lo hai lanciato proprio così:
su mysql -c mysql_install_db ?

Re: problemi con MYSQL slack 12.1

Inviato: mar 6 mag 2008, 22:17
da conraid
cancella tutta /var/lib/mysql
e dopo lancia, da root

Codice: Seleziona tutto

mysql_install_db --user=mysql
E dopo setta password e tutto il resto e guarda come si comporta

Re: problemi con MYSQL slack 12.1

Inviato: mar 6 mag 2008, 22:30
da ermes
aschenaz ha scritto:Ma quel comando lo hai lanciato proprio così:
su mysql -c mysql_install_db ?
l'ho dato da root e non mi da nessun output
conraid ha scritto:cancella tutta /var/lib/mysql
e dopo lancia, da root

Codice: Seleziona tutto

mysql_install_db --user=mysql
E dopo setta password e tutto il resto e guarda come si comporta
ho fatto ma il risultato è sempre quello. quando lancio

Codice: Seleziona tutto

mysql_install_db --user=mysql
l'output del sistema è identico a quello riportato sopra

???

Re: problemi con MYSQL slack 12.1

Inviato: mar 6 mag 2008, 22:32
da ermes
ho provato a guardare anche il manuale di mysql e non sono nemmeno riuscito a trovare l'errore 1062
:cry:

Re: problemi con MYSQL slack 12.1

Inviato: mar 6 mag 2008, 22:41
da conraid
Ma hai cancellato tutto prima?
Quel problema sembra che trovi già voci nel sistema.
Naturalmente fatti un backup se hai dati, ma io se fossi in te eliminerei qualsiasi cosa di mysql e dopo riproverei.

Re: problemi con MYSQL slack 12.1

Inviato: mar 6 mag 2008, 23:01
da ermes
si...
ho fatto tutto... cancellato, disinstallato, ri-installato e rifatto tutto da capo.
sono l'unico ad avere questo problema ?

forse voi non avete formattato ma siete passati da current a 12.1.

...
mentre scrivevo mi è venuta un'idea:
installo la versine della slack 12, la attivo (non ho mai avuto problemi prima) e poi face l'aggiornamento...
so che è una cosa da troll però non ho più molto tempo e ho delle consegne urgenti per alcuni clienti.

grazie e vi faccio sapere

Re: problemi con MYSQL slack 12.1

Inviato: mer 7 mag 2008, 7:39
da ermes
ok...
come previsto, ho installato la versione Mysql presente nella slack 12.0 e l'ho configurata senza problemi e poi ho fatto l'aggiornamento... ora tutto fila liscio.
Mi rimane il dubbio rispetto a quello che non riuscivo a fare... con calma, tra un po' di tempo riproverò a metterci mano.

grazie per l'aiuto
;)

Re: problemi con MYSQL slack 12.1

Inviato: mer 7 mag 2008, 8:26
da aschenaz
Hai trovato una soluzione un tantino tortuosa...! :D

Rileggendo bene il tuo post di prima, sembrerebbe che il problema
fosse sorto da un precedente tentativo andato a male di installare le tabelle.

Quando hai cancellato tutto, hai anche cancellato /var/lib/mysql/mysql?

Re: problemi con MYSQL slack 12.1

Inviato: mer 7 mag 2008, 13:31
da ermes
si, si... ho cancellato proprio tutto.

mi è venuta, nel frattempo, una nuova idea.
Ho notato che in fase di boot il server apache mi dava un errore/warning perchè la configurazione di default di slack 12.1 del file httpd.conf non definisce il parametro NameServer.
A memoria non ricordo con precisione il testo ma, in buona sostanza mi invitava a definire un nameserver per "localhost".
Il messaggio di errore del server mysql mi dava un errore che in qualche modo richiamava "localhost".

che sia non tanto un problema di mysql quanto di apache mal configurato ?

appena posso ritento... al limite posso sempre ricorrere nuovamente alla soluzione troll trovata !

:doubt:

Re: problemi con MYSQL slack 12.1

Inviato: mer 7 mag 2008, 14:15
da aschenaz
ermes ha scritto:Ho notato che in fase di boot il server apache mi dava un errore/warning perchè la configurazione di default di slack 12.1 del file httpd.conf non definisce il parametro NameServer.
A memoria non ricordo con precisione il testo ma, in buona sostanza mi invitava a definire un nameserver per "localhost".
Il messaggio di errore del server mysql mi dava un errore che in qualche modo richiamava "localhost".

che sia non tanto un problema di mysql quanto di apache mal configurato ?

appena posso ritento... al limite posso sempre ricorrere nuovamente alla soluzione troll trovata !

:doubt:
Forse era
Could not determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
:?:
No, questo non influisce sul funzionamento di MySQL e,
se apache ti serve solo per testare in locale, puoi anche lasciare così...

Re: problemi con MYSQL slack 12.1

Inviato: mer 7 mag 2008, 22:29
da ermes
era quello !
... vedremo cosa riuscirò a fare.

ciao e grazie ancora