problemi con MYSQL slack 12.1
Inviato: mar 6 mag 2008, 21:58
apro un altro argomento perchè il precedente è stato chiuso come risolto.
Come da titolo non riesco a utilizzare mysql.
seguendo (credo alla lettera) la procedura non riesco ad ottenere nulla. Se lancio "rc.mysld" Sembra che il server venga avviato ma poi non riesco ad accedere con nessun utente, nemmeno come root.
Ho provato a togliere ri-installare il pacchetto e rifare la procedura di configurazione.
Dopo aver creato il file /etc/my.cnf lancio "mysql_install_db" e la risposta negativa del sistema la riporto sotto:
idee
grazie
________________________
root@localhost:/root# mysql_install_db --user=mysql
Installing MySQL system tables...
ERROR: 1062 Duplicate entry 'localhost-' for key 1
080506 21:51:23 [ERROR] Aborting
080506 21:51:23 [Note] /usr/libexec/mysqld: Shutdown complete
Installation of system tables failed!
Examine the logs in /var/lib/mysql for more information.
You can try to start the mysqld daemon with:
/usr/libexec/mysqld --skip-grant &
and use the command line tool
/usr/bin/mysql to connect to the mysql
database and look at the grant tables:
shell> /usr/bin/mysql -u root mysql
mysql> show tables
Try 'mysqld --help' if you have problems with paths. Using --log
gives you a log in /var/lib/mysql that may be helpful.
The latest information about MySQL is available on the web at
http://www.mysql.com
Please consult the MySQL manual section: 'Problems running mysql_install_db',
and the manual section that describes problems on your OS.
Another information source is the MySQL email archive.
Please check all of the above before mailing us!
And if you do mail us, you MUST use the /usr/bin/mysqlbug script!
Come da titolo non riesco a utilizzare mysql.
seguendo (credo alla lettera) la procedura non riesco ad ottenere nulla. Se lancio "rc.mysld" Sembra che il server venga avviato ma poi non riesco ad accedere con nessun utente, nemmeno come root.
Ho provato a togliere ri-installare il pacchetto e rifare la procedura di configurazione.
Dopo aver creato il file /etc/my.cnf lancio "mysql_install_db" e la risposta negativa del sistema la riporto sotto:
idee
grazie
________________________
root@localhost:/root# mysql_install_db --user=mysql
Installing MySQL system tables...
ERROR: 1062 Duplicate entry 'localhost-' for key 1
080506 21:51:23 [ERROR] Aborting
080506 21:51:23 [Note] /usr/libexec/mysqld: Shutdown complete
Installation of system tables failed!
Examine the logs in /var/lib/mysql for more information.
You can try to start the mysqld daemon with:
/usr/libexec/mysqld --skip-grant &
and use the command line tool
/usr/bin/mysql to connect to the mysql
database and look at the grant tables:
shell> /usr/bin/mysql -u root mysql
mysql> show tables
Try 'mysqld --help' if you have problems with paths. Using --log
gives you a log in /var/lib/mysql that may be helpful.
The latest information about MySQL is available on the web at
http://www.mysql.com
Please consult the MySQL manual section: 'Problems running mysql_install_db',
and the manual section that describes problems on your OS.
Another information source is the MySQL email archive.
Please check all of the above before mailing us!
And if you do mail us, you MUST use the /usr/bin/mysqlbug script!