Pagina 1 di 3

[RISOLTO] SLACK 11 apache ko dopo aggiornamento php

Inviato: gio 8 mag 2008, 13:29
da Cacciatorino
ho una slack11 con apache2 e php5.
Dopo aver eseguito l'aggiornamento a php 5.2.6 (l'ultima patch uscita oggi per php), al successivo riavvio di apache ho il seguente errore:

httpd: Syntax error on line 111 of /etc/apache2/httpd.conf: Cannot load /usr/lib/apache2/libphp5.so into server: /usr/lib/apache2/libphp5.so: undefined symbol: ap_user_id

Usavo gia' php5 e apache2 su questa macchina, e per eseguire l'aggiornamento ho fatto come spiegato nella nota di aggiornamento:

apachectl stop
upgradpkg bla-bla-bla
apachectl start --> errore

La cosa avrebbe una certa urgenza, qualcuno puo' aiutarmi?

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:31
da Cacciatorino
Dimenticavo:
kernel 2.4.33.3

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:32
da Vito
posta l'errore :)...ma che ci fai ancora con slackware 11.0 .. perchè non fare l'aggiornamento? :p

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:34
da Cacciatorino
Vito ha scritto:posta l'errore :)...ma che ci fai ancora con slackware 11.0 .. perchè non fare l'aggiornamento? :p

L'errore l'ho postato nel primo messaggio. Per aggiornare alla prossima versione devo aspettare le prossime ferie essendo una macchina in produzione.

Ciao ciao

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:38
da ponce
posta i tuoi /etc/apache2/httpd.conf e /etc/apache2/mod_php.conf

edit: stavo per chiederti anche la stessa cosa di conraid, per quel che riguarda apache2.

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:40
da conraid
I paccheti li hai creati da solo? O dove li hai trovati?

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:42
da Vito
non sono un esperto di apache ... ma non dovrebbe trovarsi tutto sotto la directory /etc/apache ?

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:44
da Cacciatorino
ponce ha scritto:posta i tuoi /etc/apache2/httpd.conf e /etc/apache/mod_php.conf

httpd.conf (una parte, se serve altro fammi sapere):

LoadModule cgi_module lib/apache2/mod_cgi.so
LoadModule dav_fs_module lib/apache2/mod_dav_fs.so
LoadModule vhost_alias_module lib/apache2/mod_vhost_alias.so
LoadModule negotiation_module lib/apache2/mod_negotiation.so
LoadModule dir_module lib/apache2/mod_dir.so
LoadModule imagemap_module lib/apache2/mod_imagemap.so
LoadModule actions_module lib/apache2/mod_actions.so
LoadModule speling_module lib/apache2/mod_speling.so
LoadModule userdir_module lib/apache2/mod_userdir.so
LoadModule alias_module lib/apache2/mod_alias.so
LoadModule rewrite_module lib/apache2/mod_rewrite.so
LoadModule php5_module lib/apache2/libphp5.so


php.conf:

#
# mod_php - PHP Hypertext Preprocessor module
#

# Load the PHP module:
LoadModule php4_module libexec/apache/libphp4.so
AddModule mod_php4.c

# Tell Apache to feed all *.php files through the PHP module:
AddType application/x-httpd-php .php

# This will display PHP files in colored syntax form. Use with caution.
#AddType application/x-httpd-php-source .phps


Conraid:
i pacchetti scaricati dal sito ftp di slackware.

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:45
da conraid
Vito ha scritto:non sono un esperto di apache ... ma non dovrebbe trovarsi tutto sotto la directory /etc/apache ?
Lui si sarà o compilato da solo o preso altrove apache, quindi ha le cose "dove vuole lui".
Sicuramente apache era la posizione giusta nella 11 per apache1, poi Pat l'ha messo in /etec/httpd per apache2
Ma niente toglie che uno fa un po' come vuole :-)
Quell'errore sembra dovuto ad una errata compilazione di php che non è linkato bene ad apache.
Scusate il gergo poco professionale. Per questo domandavo come aveva fatto i pacchetti

Leggo adesso.
Scaricati da dove??? Per la 11 non ci sono i pacchetti, attento

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:46
da Cacciatorino
Scusate ho sbagliato il mod_pho.conf e' questo:

# mod_php - PHP Hypertext Preprocessor module
#

# Load the PHP module:
LoadModule php5_module lib/apache2/libphp5.so

# Tell Apache to feed all *.php files through the PHP module:
AddType application/x-httpd-php .php .phtml

# This will display PHP files in colored syntax form. Use with caution.
#AddType application/x-httpd-php-source .phps

# If you want an index.php file to be used automatically when the URL does
# not include the full path to a file (similar to index.html), modify the
# "DirectoryIndex" directive:
# DirectoryIndex index.php index.html index.html.var


da /etc/apache2/

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:48
da Cacciatorino
conraid ha scritto: Leggo adesso.
Scaricati da dove??? Per la 11 non ci sono i pacchetti, attento

forse non ho capito a cosa ti riferisci, questa e' parte della mail ricevuta oggi da slackware-security:

Updated package for Slackware 10.2:
ftp://ftp.slackware.com/pub/slackware/s ... ck10.2.tgz

Updated package for Slackware 11.0:
ftp://ftp.slackware.com/pub/slackware/s ... ck11.0.tgz

Updated package for Slackware 12.0:
ftp://ftp.slackware.com/pub/slackware/s ... ck12.0.tgz

Updated package for Slackware 12.1:
ftp://ftp.slackware.com/pub/slackware/s ... ck12.1.tgz

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:49
da conraid
Non caricare il modulo due volte. O lo carichi in httpd.conf o richiami mod_php.conf, dove hai anche addtype

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:51
da ponce
il problema, cacciatorino, e' che stai installando un php aggiornato per apache (e compilato con l'apxs di apache) su apache2, che non c'e' sulla 11.

forse e' il caso che tu provi a ricompilare il pacchetto del php5 con lo slackbuild, magari rimuovendo prima apache (1.3.qualcosa) e php4

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:53
da Cacciatorino
conraid ha scritto:Non caricare il modulo due volte. O lo carichi in httpd.conf o richiami mod_php.conf, dove hai anche addtype

Adesso funziona, quando passi per Ascoli Piceno hai un supergelatone 5 gusti +panna + cioccolato fuso pagato!!!!!

(l'ho eliminato da httpd.conf, non capisco perche' prima dell'aggironamento andava...)

Ciao!

Re: SLACK 11 apache ko dopo aggiornamento php (urgente)

Inviato: gio 8 mag 2008, 13:54
da conraid
Cacciatorino ha scritto: Updated package for Slackware 11.0:
ftp://ftp.slackware.com/pub/slackware/s ... ck11.0.tgz
Cacciatorino, attento però
Nella 11 c'era apache1, quindi il php è compilato su quello immagino
Devi ricrearti il pacchetto per apache2