Pagina 1 di 1

Errore al boot su dbus + madwifi e 2.6.25.4

Inviato: sab 24 mag 2008, 18:45
da corrado
Ciao a tutti, ho appena terminato l'aggiornamento dalla 12.0 alla 12.1.
Sembra essere andato tutto bene, ma alla fine del boot mi si presenta una scritta rossa che mi dice:
"error: Unable to connect to dbus session bus (running as root?)"

Sapete darmi qualche notizia sul motivo di tale messaggio?

Saluti
corrado

Re: Errore al boot su dbus

Inviato: sab 24 mag 2008, 19:06
da conraid
corrado ha scritto:Ciao a tutti, ho appena terminato l'aggiornamento dalla 12.0 alla 12.1.
Sembra essere andato tutto bene, ma alla fine del boot mi si presenta una scritta rossa che mi dice:
"error: Unable to connect to dbus session bus (running as root?)"

Sapete darmi qualche notizia sul motivo di tale messaggio?
Non sai che programma ti da quell'errore?
DBus è avviato?

Re: Errore al boot su dbus

Inviato: sab 24 mag 2008, 19:45
da corrado
Non so a cosa sia dovuto. L'errore compare al boot dopo l'avvio del driver hpssd (mi sembra si chiami così) e poco prima del prompt per il login.
Ho ricompilato anche il kernel (2.6.25.4) ed è sorto un problema ancora più grave:
il boot si ferma dopo il "Triggering udev events: ..." subito dopo il "Going multiuser..." con qualsiasi kernel provi a farlo.
Soluzione drastica?

Saluti
corrado

Re: Errore al boot su dbus

Inviato: sab 24 mag 2008, 20:08
da d4z_c0nf
corrado ha scritto:Non so a cosa sia dovuto. L'errore compare al boot dopo l'avvio del driver hpssd (mi sembra si chiami così) e poco prima del prompt per il login.
Ho ricompilato anche il kernel (2.6.25.4) ed è sorto un problema ancora più grave:
il boot si ferma dopo il "Triggering udev events: ..." subito dopo il "Going multiuser..." con qualsiasi kernel provi a farlo.
Soluzione drastica?

Saluti
corrado
Magari ricompila il kernel con il config del generic o dell'huge di Pat, poi se funziona scremi.
Per quanto riguarda dbus non so che dirti, però una cosa sullo script di hp, nella 12.1 è segnalato che non deve essere più lanciato all'avvio, il pacchetto hplip è proprio cambiato. Quindi ti consiglio ti togliere lo script rc.hplip (una cosa del genere) dal path /etc/rc.d/

rock

Re: Errore al boot su dbus

Inviato: sab 24 mag 2008, 20:14
da corrado
d4z_c0nf ha scritto: Magari ricompila il kernel con il config del generic o dell'huge di Pat, poi se funziona scremi.
Per quanto riguarda dbus non so che dirti, però una cosa sullo script di hp, nella 12.1 è segnalato che non deve essere più lanciato all'avvio, il pacchetto hplip è proprio cambiato. Quindi ti consiglio ti togliere lo script rc.hplip (una cosa del genere) dal path /etc/rc.d/

rock
Il problema è che ora non parte più!
Il boot si blocca dopo il triggering udev events.

Saluti
corrado

Re: Errore al boot su dbus

Inviato: sab 24 mag 2008, 20:25
da d4z_c0nf
corrado ha scritto:
d4z_c0nf ha scritto: Magari ricompila il kernel con il config del generic o dell'huge di Pat, poi se funziona scremi.
Per quanto riguarda dbus non so che dirti, però una cosa sullo script di hp, nella 12.1 è segnalato che non deve essere più lanciato all'avvio, il pacchetto hplip è proprio cambiato. Quindi ti consiglio ti togliere lo script rc.hplip (una cosa del genere) dal path /etc/rc.d/

rock
Il problema è che ora non parte più!
Il boot si blocca dopo il triggering udev events.

Saluti
corrado
Puoi sempre avviare dal cd di installazione della 12 o 12.1.
Montare la partizione dove hai la slackware installata
mkdir slack
mount /dev/hdaN(o sdaN) /slack
chroot /slack
ti prendi i pacchetti dell'huge di pat (non dimenticare anche i modules) e li installi
dai
lilo -v
riavvii
e dovresti stare al punto di partenza.
rock

Re: Errore al boot su dbus

Inviato: sab 24 mag 2008, 20:32
da corrado
d4z_c0nf ha scritto: Puoi sempre avviare dal cd di installazione della 12 o 12.1.
Montare la partizione dove hai la slackware installata
mkdir slack
mount /dev/hdaN(o sdaN) /slack
chroot /slack
ti prendi i pacchetti dell'huge di pat (non dimenticare anche i modules) e li installi
dai
lilo -v
riavvii
e dovresti stare al punto di partenza.
rock
Grazie per i consigli.
Stavo provando, bootando con il dvd della 12.0, a rifare l'update di tutta la distro (la 12.1 ce l'ho in una dir della home...). Durante il boot ho notato che il passo successivo al "Triggering udev etc etc" è il lancio di inet1.
Non ho fatto il chroot, possono esserci problemi?

Saluti
corrado

Re: Errore al boot su dbus

Inviato: sab 24 mag 2008, 20:39
da d4z_c0nf
corrado ha scritto:
d4z_c0nf ha scritto: Puoi sempre avviare dal cd di installazione della 12 o 12.1.
Montare la partizione dove hai la slackware installata
mkdir slack
mount /dev/hdaN(o sdaN) /slack
chroot /slack
ti prendi i pacchetti dell'huge di pat (non dimenticare anche i modules) e li installi
dai
lilo -v
riavvii
e dovresti stare al punto di partenza.
rock
Grazie per i consigli.
Stavo provando, bootando con il dvd della 12.0, a rifare l'update di tutta la distro (la 12.1 ce l'ho in una dir della home...). Durante il boot ho notato che il passo successivo al "Triggering udev etc etc" è il lancio di inet1.
Non ho fatto il chroot, possono esserci problemi?

Saluti
corrado
Beh, il problema è che tu hai lanciato lilo del disco di installazione, se non fai il chroot lilo si prende di default il lilo.conf che sta in /etc, quindi senza il chroot quel lilo.conf non è il "tuo", visto che il tuo sta in /slack/etc/lilo.conf.
Scusami ma poi senza fare il chroot dove hai installato il kernel?
Riavvia col cd e fai il chroot.
rock
di default

Re: Errore al boot su dbus + Non parte più

Inviato: dom 25 mag 2008, 2:00
da corrado
Ho rifatto la procedura di upgrade dalla 12.0 alla 12.1 partendo dal dvd della 12.0.
In questo modo il pc riparte. Ho ricompilato il kernel 2.6.25.4 ed è ripartito anche con questo.
Ho iniziato allora a ricompilare il driver nvidia (tutto ok) e madwifi... ed è qui che nascono i problemi.
Installo il tgz e quando provo a caricare il modulo (modprobe ath_pci) ottengo dei messaggi incomprensibili da syslogd (si nota un kernel Oops...). Da questo punto in poi non funziona nemmeno il comando ifconfig (nel senso che se do il comando in konsole non accade nulla, non vedo più eth0 ed lo).
Il kernel l'ho ricompilato con il config che ho usato, con successo, anche sul 2.6.25.
Per creare il tgz di madwifi ho usato lo slackbuild di alien http://www.slackware.com/~alien/slackbuilds/madwifi/pkg
La versione del driver è la 0.9.3.3.
Non so se mi sono perso qualcosa, ma con la 12.0 ed il 2.6.25.4 i driver madwifi non mi avevano dato problemi.
Qualcuno ha qualche dritta?

Saluti
corrado

P.S. L'errore al boot su dbus rimane sempre.

Re: Errore al boot su dbus + Non parte più

Inviato: dom 25 mag 2008, 12:41
da conraid
corrado ha scritto: Qualcuno ha qualche dritta?
Ma che chipset hai?
Con i 2.6.25 i driver atheros sono compresi nel kernel. Se non hai bisogno di qualcosa di specifico, non c'è più necessità di usare madwifi

Ed i pacchetti che vedo da Alien Bob sono per il kernel 2.6.24.5 e vedo sono 0.9.4
Stai attento, se prendi un pacchetto di driver, deve essere compilato per lo stesso kernel e possibilmente quelli per slackware 12.1
Ma se usi il kernel 2.6.25.X o non usi madwifi o disabiliti il supporto nel kernel e ti ricompili "da solo" i driver

Re: Errore al boot su dbus + Non parte più

Inviato: dom 25 mag 2008, 13:12
da corrado
conraid ha scritto:
corrado ha scritto: Qualcuno ha qualche dritta?
Ma che chipset hai?
Con i 2.6.25 i driver atheros sono compresi nel kernel. Se non hai bisogno di qualcosa di specifico, non c'è più necessità di usare madwifi

Ed i pacchetti che vedo da Alien Bob sono per il kernel 2.6.24.5 e vedo sono 0.9.4
Stai attento, se prendi un pacchetto di driver, deve essere compilato per lo stesso kernel e possibilmente quelli per slackware 12.1
Ma se usi il kernel 2.6.25.X o non usi madwifi o disabiliti il supporto nel kernel e ti ricompili "da solo" i driver
Ho compilato il kernel con il modulo atheros.
Il modulo non è più ath_pci.
Ora l'interfaccia di rete mi viene vista come wlan0 e non più come ath0.
Ho provato ad adattare i comandi che prima usavo sostituendo wlan0 ad ath0 ma senza successo; i comandi sono questi:

Codice: Seleziona tutto

ifconfig eth0 down
ifconfig wlan0 a.b.c.d. netmask 255.255.255.0 up
iwconfid wlan0 essid "essid-mia-rete"
iwpriv authmode 2
iwconfig wlan0 key MIA-CHIAVE
route add default gw ip-mio-router
L'interfaccia la pingo ma non il router.

Saluti
corrado

Re: Errore al boot su dbus + madwifi e 2.6.25.4

Inviato: dom 25 mag 2008, 14:33
da conraid
Il fatto che sia ath0 o wlan0 puoi modificarlo con udev

guarda il file
/etc/udev/rules.d/70-persistent-net.rules
e modificalo secondo le tue necessità

Re: Errore al boot su dbus + madwifi e 2.6.25.4

Inviato: dom 25 mag 2008, 15:34
da corrado
conraid ha scritto:Il fatto che sia ath0 o wlan0 puoi modificarlo con udev

guarda il file
/etc/udev/rules.d/70-persistent-net.rules
e modificalo secondo le tue necessità
Non è un problema...ero solo abituato a vedere ath0 e non wlan0.
L'interfaccia la tiro su, il router me la trova come "dispositivo collegato" ma se metto down la eth0 e provo a navigare con la wlan0 non ci riesco. Ho postato i miei file di configurazione su un thread già aperto nella sezione hardware.

Non riesco a capire dove sia l'errore.

Saluti
corrado

EDIT: nei "dispositivi collegati" che posso vedere sul router, ci sono 2 host con ip diverso ma il MAC address è lo stesso, ed è quello della scheda eth0 :(