Pagina 1 di 1

Aiuto configurazione LAMP (Linux-Apache-MySql-Php) [risolto]

Inviato: sab 27 set 2008, 0:35
da refused
Non riesco a configurare LAMP (Linux-Apache-MySql-Php) sulla current neanche seguendo il wiki, potrebbe essere perche' apache a cui si fa riferimento e' diverso da quello che ho sul sistema?

Questi sono i pacchetti che ho installati:

apache-tomcat-6.0.18.1486-1l
apache-ant-1.7.0-i586-2bj (credo opzionale/inutile)
php-5.2.5-1486-1
php-serialization-0.27-noarch (come sopra)
mysql-5.0.51b-i486-1

cito direttamente dal wiki http://www.slacky.eu/wikislack/index.ph ... _Slackware

Cominciamo subito con il dire che se avete portato avanti un'installazione di tipo FULL di Slackware avete già installato sul vostro sistema tutto il software necessario per cominciare a lavorare con il vostro ambiente LAMP che dovrà solo essere configurato in alcuni suoi aspetti, in caso contrario dovrete procurarvi ed installare i pacchetti necessari che sono comunque presenti all'interno dei CD di Slackware.

I pacchetti necessari per installare il nostro ambiente LAMP sono i seguenti:

* mysql-4.1.14-i486-1.tgz (DBMS MySQL, SQL-based relational database server)
* apache-1.3.33-i486-1.tgz (The Apache HTTP Server)
* php-4.4.0-i486-4.tgz (HTML-embedded scripting language)


qualche info....

Dopo avere avviato apache con apachectl start mando un:

root@refused:~# apachectl configtest
Syntax OK


Pare che funzioni, ma aprendo http://localhost/ mi appare solamente la scritta "it works" e non la vera pagina di apache http://www.slacky.eu/wikislack/index.ph ... ver-on.jpg
Inoltre in httpd.conf mancano dei campi indicati nel wiki...

Non so altro a riguardo, help me!! [-o<

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 8:08
da DanBadJar
La pagina caricata è diversa semplicemente perchè la versione di Apache è diversa.
Per abilitare PHP su Apache ricordati di decommentare (togliere il cancelletto) nel file /etc/http/httpd.conf la riga

Codice: Seleziona tutto

# Include /etc/httpd/mod_php.conf

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 8:26
da aschenaz
Come mai questa scelta di Tomcat?
Hai intenzione di usare le servlet Java?
Mi pare, comunque, che Tomcat sia un componente aggiuntivo e, se
il web-server funziona, è segno che Apache c'è già installato (che
poi è sicuro se hai fatto un'installazione full).

Se non userai Java, ti consiglio di rimanere su Apache.

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 10:43
da conraid
refused ha scritto: Pare che funzioni, ma aprendo http://localhost/ mi appare solamente la scritta "it works" e non la vera pagina di apache http://www.slacky.eu/wikislack/index.ph ... ver-on.jpg
La "vera pagina" è bellino. E se ci metti una tua pagina allora? :-)
It works! ti dice che funziona, e la cambi da /var/www/htdocs/index.html


vedere sempre a che versione si riferisci e di quanto tempo fa un documento del wiki, altrimenti ci si trova nei casini per niente.

p.s.
già un utente l'altro giorno mi ha contattato via messenger con lo stesso problema, bisognerebbe mettere la scritta "VALIDO SOLO PER APACHE 1" :-)

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 11:32
da refused
ok grazie per le risposte immediate :) pero' php non funziona :(

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 11:37
da conraid
refused ha scritto:ok grazie per le risposte immediate :) pero' php non funziona :(
L'hai abilitato? Hai usato il pacchetto standard di Slackware?

Verso la fine del file /etc/httpd/httpd.conf troverai delle righe come queste

Codice: Seleziona tutto

# Uncomment the following line to enable PHP:
#
#Include /etc/httpd/mod_php.conf
Come dice chiaramente togli il commento per abilitare il PHP

Codice: Seleziona tutto

# Uncomment the following line to enable PHP:
#
Include /etc/httpd/mod_php.conf

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 12:19
da refused
si l'ho fatto :(

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 12:21
da conraid
refused ha scritto:si l'ho fatto :(
E che errore ti da?

p.s.
hai usato i pacchetti standard di slackware?

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 13:14
da refused
allora, i pacchetti sono quelli della 12.1, ho provato a smanettare con phpmyadmin e quando provo ad aprire http://localhost/phpadm/index.php (phpadm e' situata in /var/www/htdocs/) la pagina che mi appare dice:

La ragione di questo è che probabilmente non hai creato alcun file di configurazione. Potresti voler usare setup script per crearne uno.
Errore

Messaggio di MySQL: Documentazione
#1045 - Access denied for user 'root'@'localhost' (using password: NO)
phpMyAdmin non riesce a leggere il file di configurazione!
Questo può accadere se il php trova un parse error in esso oppure il php non trova il file.
Richiamate il file di configurazione direttamente utilizzando il link sotto e leggete il/i messaggio/i di errore del php che ricevete. Nella maggior parte dei casi ci sono un apostrofo o una virgoletta mancanti.
Se ricevete una pagina bianca, allora è tutto a posto.

./config.inc.php


Cliccando sul link mi appare una pagina che dice Starting to parse config file... ma rimane cosi'... suggerimenti? probabilmente ho qualcosa che non va con php

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 13:16
da conraid
Ma scusa, se ricevi quei messaggi il php va, altrimenti ti dava il codice della pagina.
Se leggi ti dice di configurare bene phpmyadmin (lo hai fatto?) per impostare i dati del DB.

Hai installato mysql, non intendo il pacchetto, ma il DB, con i permessi giusti?

Re: Aiuto configurazione LAMP (Linux-Apache-MySql-Php)

Inviato: sab 27 set 2008, 13:28
da refused
umh si il database l'ho configurato come dice il wiki e pare funzioni correttamente, comunque credo ora funzioni anche php perche' ho creato un file .php che contiene solamente <?php phpinfo(); ?>, fino a ieri se lo aprivo con un browser mi dava un errore o non funzionava, mentre ora mi appare una belllllissima pagina con tutte le informazioni di php :D
appena posso provo un sitino in php e metto [risolto]
grazie per l'aiuto