Aggiornamento slackware13 ma non partono kde e xfce4

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Scarcella
Linux 0.x
Linux 0.x
Messaggi: 29
Iscritto il: gio 11 dic 2008, 11:57
Slackware: 12.2
Kernel: 2.6.27.10
Desktop: kde 4.2.2

Aggiornamento slackware13 ma non partono kde e xfce4

Messaggio da Scarcella »

Salve ho fatto l'aggiornamento alla slackware13 dalla 12.2
all'inizio tutto bene, poi ho lanciato il comando slackpkg clean-system e ho tolto i pacchetti come diceva la guida, ho riavviato il sistema e non parte piu nulla, posso usare solo la shell. se lancio startx mi esce una serie di scirtte che purtroppo non riesco a leggere dall'inizio perchè scorrono in maniera veloce.
Volevo chiedere se esiste un file di log per vedere quale è il problema.

Grazie a tutti

Avatar utente
tigerwalk
Linux 3.x
Linux 3.x
Messaggi: 890
Iscritto il: lun 25 feb 2008, 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.37-14.2
Kernel: 3.10.17-tiger / 4.4.88-smp
Desktop: kde4/xfce4
Località: Napoli

Re: Aggiornamento slackware13 ma non partono kde e xfce4

Messaggio da tigerwalk »

Scarcella ha scritto:Salve ho fatto l'aggiornamento alla slackware13 dalla 12.2
all'inizio tutto bene, poi ho lanciato il comando slackpkg clean-system e ho tolto i pacchetti come diceva la guida, ho riavviato il sistema e non parte piu nulla, posso usare solo la shell. se lancio startx mi esce una serie di scirtte che purtroppo non riesco a leggere dall'inizio perchè scorrono in maniera veloce.
Volevo chiedere se esiste un file di log per vedere quale è il problema.

Grazie a tutti
Non è che hai saltato questo passo?

Avatar utente
raffaele181188
Packager
Packager
Messaggi: 789
Iscritto il: ven 7 set 2007, 21:40
Nome Cognome: Raffaele
Slackware: current
Kernel: 2.6.29.6
Desktop: KDE 4.3
Distribuzione: Ubuntu
Località: DearSkin (FG)

Re: Aggiornamento slackware13 ma non partono kde e xfce4

Messaggio da raffaele181188 »

Dovrebbe essere /var/log/Xorg.0.log
Oppure puoi anche provare

Codice: Seleziona tutto

startx &> ~/OutputStartX.txt

Scarcella
Linux 0.x
Linux 0.x
Messaggi: 29
Iscritto il: gio 11 dic 2008, 11:57
Slackware: 12.2
Kernel: 2.6.27.10
Desktop: kde 4.2.2

Re: Aggiornamento slackware13 ma non partono kde e xfce4

Messaggio da Scarcella »

raffaele181188 ha scritto:Dovrebbe essere /var/log/Xorg.0.log
Oppure puoi anche provare

Codice: Seleziona tutto

startx &> ~/OutputStartX.txt
ma il secondo (startx &> ecc ecc) crea un file di log? e dove me lo posiziona? Io sono un novellino con slackware :)

Mentre per quanto riguarda il fatto di aver saltato lo script? Cosa comporta? Quale è la soluzione?

Avatar utente
raffaele181188
Packager
Packager
Messaggi: 789
Iscritto il: ven 7 set 2007, 21:40
Nome Cognome: Raffaele
Slackware: current
Kernel: 2.6.29.6
Desktop: KDE 4.3
Distribuzione: Ubuntu
Località: DearSkin (FG)

Re: Aggiornamento slackware13 ma non partono kde e xfce4

Messaggio da raffaele181188 »

No, il log è quell'altro file, quel comando cattura l'output che vedi (e che non riesci a leggere) e lo mette nel file nella tua home (~)
Se hai saltato lo script probabilmente si scioglierà la piastra madre :D Se leggi quello scriptino serve solo per aggiornare i file di configurazione, ma non sono tanto convinto che il tuo problema sia lì.. Piuttosto, prova a togliere il tuo xorg.conf se non l'hai già fatto (mv xorg.conf xorg.conf.slack12) che si legge possa creare problemi. Ma soprattutto, posta il log :D Ah, chissà che magari non usi dei driver video proprietari compilati con il kernel della 12.2
Non so, le ho buttate tutte lì, vedi un po' tu e se non riesci posta il log

Scarcella
Linux 0.x
Linux 0.x
Messaggi: 29
Iscritto il: gio 11 dic 2008, 11:57
Slackware: 12.2
Kernel: 2.6.27.10
Desktop: kde 4.2.2

Re: Aggiornamento slackware13 ma non partono kde e xfce4

Messaggio da Scarcella »

Grazie a tutti....
Ho risolto il problema alla radice...Installato slackware13 da capo...ora va che è una meraviglia

Rispondi