Problema wi-fi

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Burroughs
Linux 4.x
Linux 4.x
Messaggi: 1026
Iscritto il: mer 15 dic 2004, 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Glasgow
Contatta:

Problema wi-fi

Messaggio da Burroughs »

Salve a tutti!
<BR>
<BR>Sto cercando da qualche giorno di far funzionare il wi-fi sul mio portatile, un Acer TravelMate 291 LMi, dotato di chipset Intel Pro/Wireless 2200BG su cui ho installato una Slack 10 con kernel aggiornato al 2.6.7 (quello che si trova sul secondo CD, per intenderci).
<BR>Ho scaricato i driver ed il firmware disponibili sul sito <a href="http://ipw2200.sourceforge.net" target="_blank" target="_new">http://ipw2200.sourceforge.net</a>, ho posizionato (dopo aver scompattato l´archivio relativo) il firmware della scheda nella directory /usr/lib/hotplug/firmware ed ho poi provveduto a compilare i driver, dando in sequenza un:
<BR>
<BR>-make;
<BR>-make install;
<BR>-modprobe ipw2200.
<BR>
<BR>Dopo il reboot, ho controllato con un lsmod che i moduli venissero caricati dal kernel, ma, analizzando l´output di dmesg, ho scoperto che:
<BR>
<BR>ieee80211_crypt: registered algorithm ´NULL´
<BR>ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 0.12
<BR>ipw2200: Copyright(c) 2003-2004 Intel Corporation
<BR>ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
<BR>divert: allocating divert_blk for eth0
<BR>ipw2200: ipw2200_boot.fw load failed
<BR>ipw2200: Unable to load firmware: 0xFFFFFFFE
<BR>divert: freeing divert_blk for eth0
<BR>ipw2200: failed to register network device
<BR>ipw2200: probe of 0000:02:02.0 failed with error -5
<BR>
<BR>Non so cosa fare anche perché in rete non ho trovato granché al riguardo.
<BR>L´unico dubbio che ho (anche se non so se c´entri qualcosa) è se su /etc/fstab
<BR>vada aggiunta una riga del tipo.
<BR>
<BR>none /sys sysfs defaults 0 0
<BR>
<BR>Sul sito del progetto IPW2200 è caldamente consigliato di farlo, ma non va neanche in questo modo.
<BR>Qualche consiglio???
<BR>Grazie anticipatamente,
<BR>
<BR>Burroughs.
<BR>
<BR>
<BR><br>
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

geps
Linux 0.x
Linux 0.x
Messaggi: 4
Iscritto il: sab 19 giu 2004, 0:00

Problema wi-fi

Messaggio da geps »

Prova usando <!-- BBCode Start --><A HREF="http://www.slackware.com/pb/download.ph ... 5-noarch-3" TARGET="_blank">questa versione di hotplug</A><!-- BBCode End -->. A me aveva smesso di caricare il firmware dopo l´aggiornamento.<br>

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom 12 ott 2003, 0:00
Località: A place where the streets have no name
Contatta:

Problema wi-fi

Messaggio da useless »

quella riga in fstab non ci vuole, /sys dovrebbe venire montato comunque dagli script di boot. con un semplice "mount" puoi vedere se lo è già o meno.
<BR>
<BR>ocio che il firmare xò potrebbe andare in /lib/firmware. guarda all´inizio di /etc/hotplug/firmware.agent com´è impostata FIRMWARE_DIR.<br>

Avatar utente
Burroughs
Linux 4.x
Linux 4.x
Messaggi: 1026
Iscritto il: mer 15 dic 2004, 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Glasgow
Contatta:

Problema wi-fi

Messaggio da Burroughs »

Avevi ragione tu: il problema dipendeva proprio dal fatto
<BR>che il firmware agent del kernel (il 2.6.7) carica di default i moduli del
<BR>firmware dei dispositivi andandoli a cercare nella directory /lib/firmware.
<BR>Mi è bastato creare la directory e copiare il contenuto
<BR>di /usr/lib/hotplug/firmware in essa per vedere, al successivo riavvio, la
<BR>periferica wireless dare segni di vita.
<BR>Si è verificato però un grosso problema subito dopo: dando iwconfig (ho
<BR>installato i wireless tools) non mi si risponde che la nuova periferica è
<BR>stata riconosciuta come wlan0, anzi, il kernel la vede come eth0.
<BR>Vabbè - ho pensato io - la scheda Ethernet la riconoscerà come eth1; do un
<BR>ifconfig eth1 per impostare indirizzo IP e subnet mask (uso una
<BR>configurazione IP statica) della scheda Ethernet, subito dopo un route add per
<BR>specificare che la scheda deve andare in Internet tramite router, ma nulla.
<BR>La scheda Ethernet "pinga" se stessa, ma non c´è verso di farle vedere il
<BR>router.
<BR>Se do un ifconfig, poi, mi vengono segnalate tre periferiche, "eth0", "eth1",
<BR>"eth2", a proposito delle quali si dice: "no wireless extensions".
<BR>
<BR>Riflettendoci bene, un problema simile l´avevo riscontrato con la Suse 9.2: la
<BR>scheda wi-fi era riconosciuta all´istante, ma la scheda Ethernet cessava di
<BR>pingare il router.
<BR>Risolvevo disabilitando brutalmente la scheda wireless.
<BR>Qui, mutatis mutandis, è la stessa cosa.
<BR>
<BR>Certo, potrei anche farmi uno scrittarello che mi copi alla bisogna il
<BR>contenuto di /usr/lib/hotplug/firmware in /lib/firmware e che lanci subito
<BR>dopo un ifconfig eth0 ed un route add, ma non sarebbe proprio elegantissimo,
<BR>a parte il fatto che mi toccherebbe molto probabilmente riavviare il sistema
<BR>per rendere le nuove impostazioni effettive.
<BR>
<BR>Hai qualche idea su come risolvere il problema?
<BR>Grazie ancora e scusa se non sono stato chiaro nell´esposizione.
<BR>Ciao!
<BR>
<BR>Burroughs.<br>
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

Avatar utente
rob
Linux 3.x
Linux 3.x
Messaggi: 924
Iscritto il: lun 22 nov 2004, 0:00
Località: Roma

Problema wi-fi

Messaggio da rob »

Scusate l´intromissione, ma io ho il problema speculare: la scheda wireless funziona solo se disattivo eth0 (che per me è proprio l´ethernet). Per avviare la schedina wifi ho fatto uno script, fatto sta che non posso usare contemporaneamente wireless ed ethernet...
<BR>Ho un kernel 2.6.7 e il modulo per la wifi è stato fatto da ndiswrapper (grande invenzione...)
<BR>resto in standby in attesa di aggiornamenti :-)
<BR>Un saluto
<BR>rob<br>

Avatar utente
Burroughs
Linux 4.x
Linux 4.x
Messaggi: 1026
Iscritto il: mer 15 dic 2004, 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Glasgow
Contatta:

Problema wi-fi

Messaggio da Burroughs »

Mi conforta sapere che non sono il solo ad avere questo problema.
<BR>Fra l´altro (aggiornamento dell´ultim´ora), visto che la scheda continuava a funzionare e a crearmi casini, sono stato costretto a fare un make uninstall dei driver.
<BR>Aspetto per Natale un access point, ma, in mancanza di questo, è chiaro che attualmente ho bisogno della mia vecchia, cara, interfaccia Ethernet.
<BR>
<BR>Burroughs.<br>
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

Avatar utente
Burroughs
Linux 4.x
Linux 4.x
Messaggi: 1026
Iscritto il: mer 15 dic 2004, 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Glasgow
Contatta:

Problema wi-fi

Messaggio da Burroughs »

Ho fatto un test poco fa: dopo aver dato un "make uninstall" ho reinstallato i
<BR>driver del mio chipset wi-fi, copiato i files del firmware nelle directories
<BR>che già sai e terminato con un "modprobe ipw2200".
<BR>Con mia somma soddisfazione, ho visto che il kernel rilevava la scheda wi-fi
<BR>come "eth2", lasciando come "eth0" la Ethernet.
<BR>Il router era tranquillamente raggiungibile.
<BR>Beh, mi son detto "Hai visto mai che abbiamo risolto il problema?".
<BR>Niente affatto, al successivo riavvio si è riverificato il casino di cui ti ho
<BR>detto nella precedente email.
<BR>Spero di aver dato qualche indizio in più.
<BR><br>
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom 12 ott 2003, 0:00
Località: A place where the streets have no name
Contatta:

Problema wi-fi

Messaggio da useless »

allora: le schede wireless si chiamano wlanX solo con alcuni driver, con altri si chiamano ethX, ma questo è un banale problema di nomelencatura, le funzionalità non cambiano.
<BR>quanto allo 0, 1... n, linux assegna i numeri nell´ordine in cui le rileva (credo), quindi se rileva prima la wireless, questa diventa eth0, altrimenti eth1, se ha già rilevato quella ethernet. credo anche se le schede i cui driver sono compilati nel kernel vengano rilevate prima di quelle che li hanno compilati come moduli, quindi se volete forzare un determinato ordine potete forse provare questo trucco.
<BR>detto questo: a cosa serve la rete ethernet quando avete una scheda wireless? non capisco xké vogliate attivarle entrambe! in ogni caso si tratta al 99% di un problema di routing. incollate qua: ifconfig -a, route -n, dmesg | grep ^eth e iwconfig.<br>

Avatar utente
Burroughs
Linux 4.x
Linux 4.x
Messaggi: 1026
Iscritto il: mer 15 dic 2004, 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Glasgow
Contatta:

Problema wi-fi

Messaggio da Burroughs »

Ciao!
<BR>Questa è la situazione: al boot di sistema, il kernel riconosce due schede, <eth0> (la ethernet) ed <eth2> (la wi-fi).
<BR>Ho realizzato uno script che carica delle impostazioni di base che eth2 deve avere per lavorare correttamente, tipo WEP key, modalità managed etc.
<BR>Il problema è però a livello di routing: nonostante un´istruzione ben precisa nello script che dice a eth2 di utilizzare 192.168.1.1 come indirizzo IP del router, se digito route -n noto che solo eth0 vede 192.168.1.1 come router, eth2 ha uno sconsolante 0.0.0.0.
<BR>
<BR>Non so che fare, se non disabilitare la scheda ethernet, ma è tutt´altro che probabile che risolverei il problema.
<BR>
<BR>Detto in modo poco scientifico, se il kernel riesce a vedere la scheda wi-fi come eth0 non ci sono problemi (ieri avevo lasciato la WLAN aperta, senza alcun encrypting e tutto funzionava alla perfezione; oggi che ho criptato tutto m´è spuntato ´sto problema).
<BR>
<BR>Burroughs.<br>
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom 12 ott 2003, 0:00
Località: A place where the streets have no name
Contatta:

Problema wi-fi

Messaggio da useless »

i parametri x la configurazione del wireless vanno in /etc/rc.d/rc.wireless.conf da slack10 in poi, sulle precedenti bisogna improvvisare qualcosa.
<BR>detto questo postami quel che ti chiedo nel post precedente e vediamo di farci qcos.<br>

Avatar utente
Burroughs
Linux 4.x
Linux 4.x
Messaggi: 1026
Iscritto il: mer 15 dic 2004, 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Glasgow
Contatta:

Problema wi-fi

Messaggio da Burroughs »

Grazie, useless!
<BR>
<BR>Al momento, visto che ´sta settimana sono al lavoro, non ho avuto tempo di investigare a fondo il problema.
<BR>Ho risolto temporaneamente con uno script che disabilita l´interfaccia ethernet consentendo alla scheda wi-fi di "vedere" il router ed operare bene.
<BR>Ciao!
<BR>
<BR>Burroughs.<br>
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

bhackerozzo
Linux 0.x
Linux 0.x
Messaggi: 67
Iscritto il: sab 18 dic 2004, 0:00

Problema wi-fi

Messaggio da bhackerozzo »

per chiamare wlan0 l´interfaccia wireless basta fare:
<BR>modprobe ipw2100 ifname=wlan0
<BR>per la ipw2200 dovrebbe essere uguale
<BR>se si vuole automatizzare, in slack aggiungere a /etc/modprobe.conf la riga:
<BR>options ipw2100 ifname=wlan0
<BR>
<BR>bhackerozzo<br>

Rispondi