KDE-4.3.2 in current.

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
conraid
Staff
Staff
Messaggi: 13474
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: KDE-4.3.2 in current.

Messaggio da conraid »

Roland ha scritto:Il menu nelle impostazioni di sistema credo venga dal pacchetto gtk-qt-engine, che però non riesco a compilarmi...mi sa che dovrò aspettare che arrivi nel repo della 13.
Ho quindi creato il file .gtkrc-2.0 come hai suggerito tu conraid ed ora è tornato quasi tutto a posto. Quasi perchè non vengono caricate alcune icone, ad esempio in gslapt (che uso per installare i pacchetti di slacky.eu)
Continuo a cercare nel forum l'eventuale soluzione ;)

EDIT: trovata ;)
ma hai installato solamente kde4.3.2?
se sei in -current devi installare tutti i pacchetti che vengono rilasciati, soprattutto quelli rilasciati prima di quel che ti interessa
slackpkg per questo è molto utile

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: KDE-4.3.2 in current.

Messaggio da phobos3576 »

Come mai non c'è traccia di PolicyKit?

Non doveva essere necessario su KDE 4.3.x?

Avatar utente
shark1500
Linux 3.x
Linux 3.x
Messaggi: 785
Iscritto il: gio 3 apr 2008, 14:33
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde
Località: Modna

Re: KDE-4.3.2 in current.

Messaggio da shark1500 »

Io non l'ho ancora provato, ho in mente un upgrade domenica sera, semplicemente perche` volevo fare le cose per bene, e ora non ho tempo, inoltre domani ho la presentazione al linux day della slackware e cosi` (a) faccio vedere qualcosa di simile alla 12.2 (b) non rischio che scoppi tutto questa notte e domani non ho il portatile per fare la presentazione :-).

Comunque volevo chiedere una cosa: sicuro che non si possa mettere sulla stable? Cosa non funzionerebbe?

Avatar utente
conraid
Staff
Staff
Messaggi: 13474
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: KDE-4.3.2 in current.

Messaggio da conraid »

la prima cosa che mi viene in mente è che le qt sono compilate "su" mysql 5.1 per esempio, è cambiato poco dalla stable, ma mysql e perl sono cambiati, non so quanto ne viene fatto uso
Se poi se installi kde e le dipendenze... a quel punto metti direttamente la current no?

Avatar utente
Roland
Linux 1.x
Linux 1.x
Messaggi: 175
Iscritto il: mer 20 ago 2008, 1:32
Slackware: current x86_64
Kernel: 3.2.13
Desktop: KDE 4.8.2
Località: Catanzaro Lido

Re: KDE-4.3.2 in current.

Messaggio da Roland »

conraid ha scritto:ma hai installato solamente kde4.3.2?
se sei in -current devi installare tutti i pacchetti che vengono rilasciati, soprattutto quelli rilasciati prima di quel che ti interessa
slackpkg per questo è molto utile
sìsì sono in -current. Ormai uso stabilmente slackpkg da un po'. Stamattina ho dato

Codice: Seleziona tutto

slackpkg update
slackpkg install-new
slackpkg upgrade-all
il problema delle icone si è risolto dopo essere giunto qui http://alien.slackbook.org/blog/gtk-ico ... y-missing/ grazie ad una rapida ricerca nel forum ;)

Avatar utente
Burroughs
Linux 4.x
Linux 4.x
Messaggi: 1017
Iscritto il: mer 15 dic 2004, 0:00
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux
Località: Glasgow
Contatta:

Re: KDE-4.3.2 in current.

Messaggio da Burroughs »

Comunque, se qualcuno, con una 13.0 "da battaglia", provasse ad aggiornare KDE, farebbe cosa gradita... :)

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)

Avatar utente
Random
Linux 0.x
Linux 0.x
Messaggi: 12
Iscritto il: lun 14 set 2009, 16:20
Nome Cognome: Giulio
Slackware: 13.0-current i486
Kernel: 2.6.29.6
Desktop: KDE 4.3.2
Distribuzione: Arch KDEmod
Località: Torino

Re: KDE-4.3.2 in current.

Messaggio da Random »

Aggiornato, lo sto usando in questo momento, vi faccio sapere se riscontro problemi...:)

sir_alex
Linux 3.x
Linux 3.x
Messaggi: 735
Iscritto il: lun 21 mar 2005, 0:00
Kernel: 2.6.35-22
Desktop: KDE4
Distribuzione: Ubuntu
Località: Milano - Corbola (RO)
Contatta:

Re: KDE-4.3.2 in current.

Messaggio da sir_alex »

conraid ha scritto: - se si usa "Vista delle directory" va dato il permesso di esecuzione ai file .desktop dentro la directory scelta (io ho Desktop), altrimenti c'è una nota sull'icona
Grazie, era da un po' che non capivo il motivo di quei punti esclamativi... :D

Avatar utente
raffaele181188
Packager
Packager
Messaggi: 789
Iscritto il: ven 7 set 2007, 21:40
Nome Cognome: Raffaele
Slackware: current
Kernel: 2.6.29.6
Desktop: KDE 4.3
Distribuzione: Ubuntu
Località: DearSkin (FG)

Re: KDE-4.3.2 in current.

Messaggio da raffaele181188 »

Io lo sto usando da un po'.. E' davvero molto bello
Devo dire che ho avuto già tre crash (Dolphin, Konqueror e Plasma) [-X
Però, se non erro, si diceva che il problema per non metterlo nella 13 era PolicyKit... E ora mi dite che non c'è PolicyKit? Questa chi me la spiega? :shock:

Vic Steele
Linux 3.x
Linux 3.x
Messaggi: 534
Iscritto il: dom 27 apr 2008, 13:46
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15
Località: Potenza
Contatta:

Re: KDE-4.3.2 in current.

Messaggio da Vic Steele »

PolicyKit (accoppiato a Polkit-QT) è una feature che c'è dalla versione 4.3.
Puoi scegliere di eliminare a monte il "problema" compilando senza il suo supporto, ed è la soluzione che è stata adottata.
A mio avviso è un modo di lasciare incompleto il prodotto. Poi, comunque, dal loro canto ci sono anche buoni motivi (per esempio il Polkit è in netta fase di testing).
Con google comunque dovreste trovare un po' di documenti sull'argomento.

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3558
Iscritto il: sab 26 giu 2004, 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: KDE-4.3.2 in current.

Messaggio da Trotto@81 »

raffaele181188 ha scritto:Io lo sto usando da un po'.. E' davvero molto bello
Devo dire che ho avuto già tre crash (Dolphin, Konqueror e Plasma) [-X
Però, se non erro, si diceva che il problema per non metterlo nella 13 era PolicyKit... E ora mi dite che non c'è PolicyKit? Questa chi me la spiega? :shock:
Quindi si rischia di avere problemi per chi ci lavora con il pc.
Volevo piallare la 12.2 e mettere la current della 64 vista l'implementazione del 4.3.2 ma non ne sono così convinto ora.

Avatar utente
raffaele181188
Packager
Packager
Messaggi: 789
Iscritto il: ven 7 set 2007, 21:40
Nome Cognome: Raffaele
Slackware: current
Kernel: 2.6.29.6
Desktop: KDE 4.3
Distribuzione: Ubuntu
Località: DearSkin (FG)

Re: KDE-4.3.2 in current.

Messaggio da raffaele181188 »

Non saprei dirti.. A me plasma crasha piuttosto spesso :( roba che non vedevo da un sacco di tempo.. Boh, forse è sfortuna, o magari qualche pacchetto "strano" (la mia slack è parecchio pasticciata). Di certo il 4.2.4 non mi è mai crashato in diversi mesi.
C'è da dire, però, che i crash di plasma non sono affatto brutali, e mi si presenta subito una adorabile finestrella che mi chiede di fare il bug report e mi riavvia la desktopshell. Però ti riporto anche che qui nel Forum dicono che la serie 4.3 è più stabile della 4.2 8) quindi magari può essere qualche conflitto nel mio stack.

Avatar utente
ermes
Linux 2.x
Linux 2.x
Messaggi: 372
Iscritto il: dom 20 feb 2005, 0:00
Slackware: current 64
Desktop: kde
Località: Rho (Mi)

Re: KDE-4.3.2 in current.

Messaggio da ermes »

... fatto l'aggiornamento.
alcuni problemi riscontrati:
- ho dovuto cancellare la dir ".kde" altrimenti il server grafico, pur partendo, mi visualizzava solo un schermo nero (non ho letto che la stessa cosa sia successa ad altri)
- come altri hanno segnalato ho già avuto 4 crash su dolphin (stavo cercando di utilizzare il comando "elimina" e di visualizzare le directory nascoste)

ciao

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3558
Iscritto il: sab 26 giu 2004, 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: KDE-4.3.2 in current.

Messaggio da Trotto@81 »

Ma avete installato la current da zero?
Alcuni ne parlano bene, altri male, è una lotteria.
È vero che la slack non è KDE, ma se ci devo lavorare, il DE non mi deve dare problemi.

Avatar utente
conraid
Staff
Staff
Messaggi: 13474
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: KDE-4.3.2 in current.

Messaggio da conraid »

Trotto@81 ha scritto:Ma avete installato la current da zero?
Alcuni ne parlano bene, altri male, è una lotteria.
È vero che la slack non è KDE, ma se ci devo lavorare con il DE non mi deve dare problemi.
io sono in -current perenne, comunque mi sembra più stabile di kde4.2
dolphin non mi crasha, ma ho provato solamente alcune cose segnalate qui, non lo uso quasi mai
konqueror idem come sopra, non lo uso, ancora nemmeno aperto
plasma crashava molto anche prima, questa volta ancora non è crashato, ma anche qui sinceramente uso poco e nulla
non ho dovuto modificare .kde (in 3 installazioni, una qui sul fisso con nvidia, due sul notebook, 32 e 64bit, ma li l'ho provato ancora meno)

Rispondi