Pacchetti e versioni

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
aschenaz
Staff
Staff
Messaggi: 4622
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 5.4.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Pacchetti e versioni

Messaggio da aschenaz »

E' sempre obbligatorio installare i pacchetti relativi alla versione in uso?
Mi spiego meglio: io ho due pc, uno con la 10.1, che tengo abbastanza aggiornato ed uno con la 10.0, che usano principalmente le mie bambine. Ora vorrei aggiornare Gimp su quest'ultimo, ma le ultime versioni pacchettizzate sono dedicate esclusivamente alla 10.1. Che succede se installo comunque? Devo ricorrere per forza ai sorgenti?
Prima di provare ho preferito chiedere...

Avatar utente
useless
Staff
Staff
Messaggi: 3896
Iscritto il: dom 12 ott 2003, 0:00
Località: A place where the streets have no name
Contatta:

Messaggio da useless »

no, figurati, xò non è garantito il funzionamento del pacchetto. in generale se le versioni sono abbastanza simili (10.0 vs 10.1), 99 su 100 ti va bene, se le versioni sono molto diverse (8.0 vs 10.1) è improbabile (ma non impossibile!) che funzioni. dipende tutto dalle librerie con cui il pkg in questione è linkato. l'unico modo x accertarsene è provare :), intanto danni non ne fai, tuttal+ non parte il programma e disinstalli il pkg.

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4622
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 5.4.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Messaggio da aschenaz »

Grazie!
Oggi proverò...
Ciao,

wasabi
Linux 2.x
Linux 2.x
Messaggi: 243
Iscritto il: gio 25 nov 2004, 0:00

Messaggio da wasabi »

Non funzionerà...
Non perdere tempo! Quello che dice Useless è senza ombra di dubbio vero però io ho esperienze dirette in merito...Proprio il tuo caso con gimp!
Gimp ti chiederà di aggiornare le glibc ed altre amenità varie moooolto sensibili agli aggiornamenti. Quindi non funzionerà di certo. Quando ho provato circa un mese fa, ho persino osato aggiornare tutte le dipendenze richieste ma a quanto pare qualcosa è andato male e mi sono ritrovato una macchina azzannata completamente. Per fortuna usiamo Slack e quindi pochi colpi di removepkg e addpkg da una distro live hanno riportato tutto allo stato originale!!!
Morale: ti sbrighi prima ad aggiornare la macchina a Slack 10.1 !!!
In bocca al lupo,
ciao anche al grande useless!!!

Rispondi