Pagina 1 di 3
driver scheda di rete
Inviato: mer 20 lug 2005, 11:49
da Rjo
innanzitutto ciao a tutti.
ho un problema sulla scheda di rete ,praticamente quando pingo il router non mi da risposta.
ho guardato la configurazione fatta con netconfig ed è ok ..ho guardato con dmesg|grep eth e su eth0 mi viene solo la riga davicom......,irq5
(se è importante posto l'intera riga).
pero' ad esempio nella guida che ho qua dovrebbero apparirmi altre due righe dove dice:
eth0 identified..
et0: link up ....
a sto punto penso che i driver non siano caricati della mia davicom....se è cosi' sapete dirmi nel kernel quali sono quelli relativi a questa scheda di rete ?
grazie mille
Inviato: mer 20 lug 2005, 12:31
da Paoletta
googlando mi sembra che tu debba fare:
#modprobe tulip
oppure (se ifconfig non ti rileva la scheda)
#modprobe dmfe
Inviato: mer 20 lug 2005, 13:18
da DarkNeo
Scusa se dai un ifconfig e ti riconosce la scheda di rete come eth0 e per di più tui fa usare il netconfig vuol dire che non cè bisogno di driver comunque se non fosse così i moduli per le schede di rete le trovi compilando il kernel in questa sezione:
Device Drivers --> Networking support --> Ethernet (10 or 100Mbit) / Ethernet (1000Mbit) se hai una gigabit
Inviato: mer 20 lug 2005, 13:20
da l1q1d
cosa ti da "ifconfig -a"?
Inviato: mer 20 lug 2005, 13:50
da Rjo
grazie per le risposte..comunque:
ho provato a caricare tulip e non funziona uguale cosi come dmfeCmq posto l'output
#dmesg|grep eth
eth0: Davicom DM9102/DM9102A rev 64 at 0xc400, 00:60:6E:77:4A:D9, IRQ 5.
# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:60:6E:77:4A:D9
inet addr:10.0.0.7 Bcast:10.255.255.255 Mask:255.0.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:252 (252.0 b)
Interrupt:5 Base address:0xc400
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:772 (772.0 b) TX bytes:772 (772.0 b)
su suse non mi dava problemi ,quindi escludevo problemi lato router..ma anche qua non saprei. Adesso guardo un po' sul kernel o al limite lo porto al 2.6 (se è utile)
[/i]
Inviato: mer 20 lug 2005, 14:01
da Rjo
anzi scusate con
# modprobe dmfe
/lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz: init_module: No such device
/lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz: insmod /lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz failed
/lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz: insmod dmfe failed
Inviato: mer 20 lug 2005, 16:37
da Paoletta
# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:60:6E:77:4A:D9
inet addr:10.0.0.7 Bcast:10.255.255.255 Mask:255.0.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:252 (252.0 b)
Interrupt:5 Base address:0xc400
questo vuol dire che il kernel riconosce la tua scheda di rete, le viene pure assegnato un indirizzo ip dal tuo router:10.0.0.7;
quindi il kernel carica il modulo per la tua scheda di rete;
che ti dice:
route -n
Inviato: mer 20 lug 2005, 16:57
da Paoletta
oltre all'output di
route -n
posta anche il contenuto di /etc/resolv.conf
Inviato: mer 20 lug 2005, 17:45
da Rjo
Kernel IP routing table
Destination- Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0- 0.0.0.0- 255.255.255.0- U 0 0 0 eth0
127.0.0.0- 0.0.0.0- 255.0.0.0- U 0 0 0 lo
0.0.0.0- 10.0.0.2- 0.0.0.0- UG 1 0 0 eth0
search rjo
nameserver 10.0.0.2 (ho provato pure il dns primario di libero)
Inviato: mer 20 lug 2005, 17:58
da DarkNeo
Rjo ha scritto:anzi scusate con
# modprobe dmfe
Ma dopo sei andato in /etc/rc.d/rc.modules ad aggiungere /sbin/modprobe dmfe?
Inviato: mer 20 lug 2005, 18:26
da Rjo
c'erano di gia e sono quelli delle davicom 9xxxx
#/sbin/modprobe dmfe
tu intendi decommentarlo? comunque ho provato ma solito output
Inviato: mer 20 lug 2005, 20:37
da Paoletta
in teoria tutti i parametri son giusti e non c' è bisogno di altri driver...
non è che per caso è impostato qualche fw (se non sulla tua macchina magari sul router)?
posta l'output di:
# iptables -L
P.S. già che ci sei, posta anche l'output di
$ lsmod
Inviato: mer 20 lug 2005, 20:38
da DarkNeo
Rjo ha scritto:c'erano di gia e sono quelli delle davicom 9xxxx
#/sbin/modprobe dmfe
tu intendi decommentarlo? comunque ho provato ma solito output
Si
Inviato: mer 20 lug 2005, 20:46
da Luci0
ma cosa pinghi
ma sto router che indirizzo ha ...
10.0.0.2 per caso ... forse
se dai un named così tanto per provare riesci a risolvere?
Inviato: mer 20 lug 2005, 21:04
da Paoletta
io tanto per provare metterei la metric del default gw della routing table a 0 anzichè a 1...
#route del default
#route add default gw 10.0.0.2 metric 0