Pagina 1 di 1
contigurazione lan e modem adsl ethernet
Inviato: mer 27 lug 2005, 10:26
da moruz83
salve ragazzi.
non riesco a configurare le due cose...
cioe mi spiego meglio.
se uso netconfig mi configura una sola scheda di rete. e internet funziona (senza firewall)
io invece voglio configurarle tutte e due. per farlo ho modificato il file /etc/hosts e /etc/rc.c/rc.inet1.conf.
cosi non da neanche piu errori quando lancio dmesg | grep eth
pero quando mi collego non riesco a navigare... allora pensavo fosse il firewall.. ma anche senza di esso non riesco.
premetto che le schede di rete le vede correttamente e che funzionano (sotto win va tutto liscio).
qualche consiglio?
grazie a tutti. ciaoz
Inviato: mer 27 lug 2005, 10:30
da Paoletta
ma come hai modificato rc.inet1.conf? potresti postarlo...
e che c'entra /etc/hosts? quello serve per le traduzioni da nomi a ip...comunque posta anche quello, così vediamo che hai modificato!
ciao!
Inviato: mer 27 lug 2005, 10:30
da MDS
Dacci un po' più di info....
Codice: Seleziona tutto
lspci
lsmod
ifconfig -a
route -n
iptables -L -v -n
cat /etc/resolv.conf
Comunque la prima prova che ti condiglio è di invertire i cavi tra le 2 schede... può essere che una volta configurata la seconda scheda è diventata eth0 e quella che in precedenza lo era è diventata eth1.
Dicci Dicci
Inviato: mer 27 lug 2005, 11:02
da moruz83
allora il modem è attaccato su eth1
eth0 e collegata all'altro pc.
alloca eccovi un po di info.
si in /etc/hosts avevo aggiunto due ip statici uno di questa macchina e uno dell'altra.
[/b]questo ORA è il file inet1.conf:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""
# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""
# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""
# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""
# Default gateway IP address:
GATEWAY=""
# Change this to "yes" for debugging output to stdout. Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"
alche se lo "yes" dovrebbe essere in eth1 giusto? ma con net config mi imposta per default la eth0. e non capisco come ma cosi funziona tutto.lspci: vi incollo solo quelloc che ci interessa
00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
lsmod:
Module Size Used by
ppp_synctty 7680 0
ppp_async 9984 1
ppp_generic 24596 6 ppp_synctty,ppp_async
slhc 7040 1 ppp_generic
snd_pcm_oss 50984 0
snd_mixer_oss 18560 2 snd_pcm_oss
ohci_hcd 18820 0
ehci_hcd 28548 0
via_agp 6912 1
8139too 21120 0
mii 4480 1 8139too
crc32 4096 1 8139too
joydev 8256 0
snd_emu10k1 98216 1
snd_rawmidi 22080 1 snd_emu10k1
snd_seq_device 7948 2 snd_emu10k1,snd_rawmidi
snd_ac97_codec 76152 1 snd_emu10k1
snd_pcm 84104 3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_timer 23044 2 snd_emu10k1,snd_pcm
snd_page_alloc 9608 2 snd_emu10k1,snd_pcm
snd_util_mem 3968 1 snd_emu10k1
snd_hwdep 8608 1 snd_emu10k1
snd 50404 10 snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_seq_device,snd_ac97_codec,snd_pcm,snd_timer,snd_util_mem,snd_hwdep
soundcore 7136 2 snd
emu10k1_gp 2816 0
gameport 3584 1 emu10k1_gp
uhci_hcd 28560 0
nvidia 3920052 12
evdev 7552 0
nls_utf8 1792 4
nls_cp437 5632 4
vfat 11648 4
fat 39872 1 vfat
usb_storage 65088 0
agpgart 27688 2 via_agp,nvidia
parport_pc 30784 1
lp 9516 0
parport 34248 2 parport_pc,lp
psmouse 18696 0
ext3 110440 1
jbd 49048 1 ext3
ifconfig -a:
eth0 Link encap:Ethernet HWaddr 00:50:BF:0E:ED:9A
BROADCAST NOTRAILERS MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:2360 (2.3 Kb)
Interrupt:11 Base address:0xd400
eth1 Link encap:Ethernet HWaddr 00:08:A1:34:49:FC
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:31002 errors:0 dropped:0 overruns:0 frame:0
TX packets:21182 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:42396543 (40.4 Mb) TX bytes:1847432 (1.7 Mb)
Interrupt:12 Base address:0xd800
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:884 (884.0 b) TX bytes:884 (884.0 b)
ppp0 Link encap:Point-to-Point Protocol
inet addr:82.59.179.72 P-t-P:192.168.100.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:30841 errors:0 dropped:0 overruns:0 frame:0
TX packets:21022 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:41704734 (39.7 Mb) TX bytes:1375244 (1.3 Mb)
route -n:
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.100.1 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.100.1 0.0.0.0 UG 0 0 0 ppp0
iptables -L -v -n:
Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
pkts bytes target prot opt in out source destination
cat /etc/resolv.conf:
nameserver 212.216.112.112
nameserver 212.216.172.62
datemi un una mano grazie!
Inviato: mer 27 lug 2005, 11:19
da Paoletta
io fossi in te metterei a mano "yes" su eth1,senza usare netconfig;
per eth0, che è collegata all'altro pc e non deve andar su internet, metteri i parametri staticamente;
IPADDR[0]="ip"
NETMASK[0]="netmask"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]="yes"
DHCP_HOSTNAME[1]=""
ciao!
Inviato: mer 27 lug 2005, 11:37
da moruz83
e si e quello che gia avevo fatto... ma non riesco a navigare...
non mi risolve l'indirizzo eppure il dns è corretto...
grazie comunque... continuo a smanettare...
ciaoz
Inviato: mer 27 lug 2005, 11:41
da Firetux
ma al posto di 0 e 1 non bisogna mettere eth0 e eth1?
Inviato: mer 27 lug 2005, 11:42
da moruz83
quali 0 e 1 dici?
Inviato: mer 27 lug 2005, 11:51
da Firetux
no niente, scusa! mi stavo sbagliando io
Inviato: mer 27 lug 2005, 11:59
da Paoletta
senti, ma...
se uso netconfig mi configura una sola scheda di rete. e internet funziona (senza firewall)
quindi quando configuravi solo eth0 con netconfig riuscivi a navigare,vero?
non sarà mica che è eth0 quella attaccata al modem ed eth1 quella che è connessa all'altro PC? questo spiegherebbe tutto...
Inviato: mer 27 lug 2005, 12:19
da moruz83
ti rispondo cosi
dmesg | grep eth
divert: not allocating divert_blk for non-ethernet device lo
divert: allocating divert_blk for eth0
eth0: RealTek RTL8139 at 0xd400, 00:50:bf:0e:ed:9a, IRQ 11
eth0: Identified 8139 chip type 'RTL-8139B'
divert: allocating divert_blk for eth1
eth1: RealTek RTL8139 at 0xd800, 00:08:a1:34:49:fc, IRQ 12
eth1: Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link down
eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
divert: not allocating divert_blk for non-ethernet device ppp0
eth0 e attaccata al pc spento ora
eth1 c'è il modem
sembra come se si confonda con le schede...
le schede sono quasi uguali
eth0: Identified 8139 chip type 'RTL-8139B'
eth1: Identified 8139 chip type 'RTL-8100B/8139D'
il mdoulo viene caricato staticamente (si dice cosi?) dal kernel...
pero una sola volta... ma comunque le riconosce... giusto?
Inviato: mer 27 lug 2005, 13:37
da moruz83
sembrerebeb che abbia risolto così:
# Config information for eth0:
IPADDR[0]="192.168.0.1"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""
# Default gateway IP address:
GATEWAY=""
# Change this to "yes" for debugging output to stdout. Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"
forse gli dava fastidio lo "yes" del dhcp su eth1
mha...
comunque meno male che funzia tutto.... happy slack a tutti
ciaoz
Inviato: mer 27 lug 2005, 19:08
da Paoletta
meno male!anche se non so spiegarmelo...