Pagina 1 di 1

Vmware problema.....

Inviato: ven 19 ago 2005, 9:41
da Heidegger
Salve ho installato correttamente Vmware, ho un Slack 10.0 con kernel di base 2.4.26
Ora......dentro vmware ho installato windows xp professional giusto perchè così quando mi serve necessariamente di usarlo non devo arrestare slack :-D
Sembrava andare tutto a gonfie vele ma al riavvio successivo se tento di far partire l'emulazione di xp mi da 4 errori:
1 Could not open /dev/vmmon: No such device.
Please make sure that the kernel module `vmmon' is loaded.

2 Failed to initialize monitor device.

3 Unable to change virtual machine power state: Cannot find a valid peer process to connect to.

4 Failed to reply to the dialog: Pipe: Read failed

Ora quello che non capisco è questo: se io disinstallalo Vmware e lo reinstallo funziona tutto quanto....posso installarci dentro qualsiasi sistema. Se poi riavvio una o due volte quando tento di riaccedere alla macchina virtuale mi da questi errori.....perchè? Se ci fosse qualche problema non dovrebbe funzionare da subito.....perchè dopo il "riavvio" non funziona più?
AIUTO :-D
Thanks mitici come al solito.
Bye
Heidegger :-D

Inviato: ven 19 ago 2005, 9:46
da Heidegger
Ah comunque vi faccio presente che nel primo errore lui segnale che non trova il dispositivo vmmon sotto /dev
Invece io ho controllato con :
ls /dev/vmmon
ed ovviamente viene rilevato......
spero vi possa essere d'aiuto questo. Ciao e grazie

Inviato: ven 19 ago 2005, 10:42
da DaNiMoTh
per il problema n°1, usa lo script che è stato creato in /etc/init.d chiamato vmware.

Io l'ho spostato in /etc/rc.d/ e l'ho chiamato rc.vmware. Fai così:

# /etc/rc.d/rc.vmware start
#vmware

Inviato: ven 19 ago 2005, 11:12
da Heidegger
Grazie sei stato grandioso....dopo aver fatto questo praticamente rifunziona tutto.....ossia tutti gli altri 3 problemi non ci sono più.....unico dubbio ogni volta che avvio il sistema prima di lanciare vmware devo lanciare questo script?
E se lo metto direttamente come comando in /etc/rc.d/rc.local per fare in modo che si lanci da solo all'avvio? Può essere una soluzione? Ciao ti ringrazio tantissimo! :-D

Inviato: ven 19 ago 2005, 11:29
da Heidegger
Ok facendo partire lo script in rc.local va tutto benissimo! Ti ringrazio tanto. Bye :-D

Inviato: sab 20 ago 2005, 17:43
da pennega
ti dovrebbe bastare anche caricare semplicemente il modulo vmmon...
io faccio così e non ho avuto problemi...