Pagina 1 di 1

.htaccess: internal error

Inviato: ven 30 set 2005, 18:31
da fabriBit
Scusate, qui vi posto l'errore..
c'è già un post riguardo .htaccess ma non ho risolto, ache se il problema che ho io è identico...

il problema è semplice: voglio obbligare un utente a inserire user e password per accedere alla directory "prova" che si trova sul mio sito web...
ho creato il file .htaccess all'interno della directory /var/www/mioweb/prova in questo modo:

AuthUserFile /var/www/mioweb/prova/.htpasswd
AuthType Basic
require valid-user
<Limit GET POST>
require valid-user
</Limit>

poi dentro "/var/www/mioweb/prova" ho creato il file .htpasswd così
htpasswd -c .htpasswd nome_utente
#password

poi in htpd.conf ho modificato
AllowOverride AuthConf

riavviato Apache e mi dà l'errore che vi posto.....

http://img243.imageshack.us/my.php?imag ... ine9sz.png
ciao e grazie..
risponderò lunedi
buon weekend a tutti

Inviato: ven 30 set 2005, 21:48
da manny
Hai decommentato in /etc/apche/httpd.conf anche la riga:

AccessFileName .htaccess

alla sezione Accessfilename?

Ciao!
Manny

Inviato: lun 3 ott 2005, 12:05
da fabriBit
manny ha scritto:Hai decommentato in /etc/apche/httpd.conf anche la riga:

AccessFileName .htaccess

alla sezione Accessfilename?

Ciao!
Manny
si è decommentata... :(

Inviato: lun 3 ott 2005, 13:39
da manny
Queste sono le istruzioni che ho seguito per crearmi il mio .htaccess (e che ho trascritto per ricordarmele), ed ha funzionato:

Creare un file passwd per Apache che contenga il nome utente+passwd, in questo modo:

#htpasswd -c passwd nome-utente

Il flag “-c” è necessario solo la prima volta che si lancia il comando “htpasswd” per creare il file “passwd”

Una volta lanciato il comando “htpasswd”, il sistema richiederà la password scelta e la memorizzerà.

Creare un file chiamato .htaccess nella direttori da proteggere, con le seguenti direttive:

AuthName "Informazioni Riservate"
AuthType Basic
AuthUserFile /etc/apache/passwd
AuthGroupFile /etc/apache/group
require valid-user

Informare apache di leggere il file .htaccess:
Aprire /etc/apache/httpd.conf e aggiungere la seguente riga:
AllowOverride AuthConfig
e commentare la riga originale:
# AllowOverride None
alla sezione (### Section 2: 'Main' server configuration):
# This controls which options the .htaccess files in directories can
# override. Can also be "All", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"
Decommentare inoltre la riga:
AccessFileName .htaccess
nella sezione (sempre 2):
# AccessFileName: The name of the file to look for in each directory
# for access control information.

A questo punto riavviare apache:
/etc/rc.d/rc.httpd restart
e verificare che tutto funzioni.


Fai sapere se risolvi (per i posteri :wink: )
Manny

Inviato: mar 4 ott 2005, 17:31
da fabriBit
manny ha scritto:Queste sono le istruzioni che ho seguito per crearmi il mio .htaccess (e che ho trascritto per ricordarmele), ed ha funzionato:

Creare un file passwd per Apache che contenga il nome utente+passwd, in questo modo:

#htpasswd -c passwd nome-utente

Il flag “-c” è necessario solo la prima volta che si lancia il comando “htpasswd” per creare il file “passwd”

Una volta lanciato il comando “htpasswd”, il sistema richiederà la password scelta e la memorizzerà.

Creare un file chiamato .htaccess nella direttori da proteggere, con le seguenti direttive:

AuthName "Informazioni Riservate"
AuthType Basic
AuthUserFile /etc/apache/passwd
AuthGroupFile /etc/apache/group
require valid-user

Informare apache di leggere il file .htaccess:
Aprire /etc/apache/httpd.conf e aggiungere la seguente riga:
AllowOverride AuthConfig
e commentare la riga originale:
# AllowOverride None
alla sezione (### Section 2: 'Main' server configuration):
# This controls which options the .htaccess files in directories can
# override. Can also be "All", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"
Decommentare inoltre la riga:
AccessFileName .htaccess
nella sezione (sempre 2):
# AccessFileName: The name of the file to look for in each directory
# for access control information.

A questo punto riavviare apache:
/etc/rc.d/rc.httpd restart
e verificare che tutto funzioni.


Fai sapere se risolvi (per i posteri :wink: )
Manny
ti ringrazio per la risposta..
non funziona...
il sito lo vedo, ma quando voglio entrare nella directory protetta mi dà errore..
erroere interno che sembra dipendere dalla direttiva allowoverride, nel senso che quando è settata u none mi fà entrare nella directory protette senza ovviamente chiedermi nè user nè password, se seguo il tuo consiglio e cioè allowoverride = authconfig allora mi dà l'errore che ti dicevo sopra...

non sà cosa fare..
.htaccess .htpasswd sembrano tutto ok....