Pagina 1 di 1

problemi vari con mysql

Inviato: gio 1 dic 2005, 11:52
da gastone
salve ragazzi un saluto a tutti quanti Voi, e faccio i mniei complimenti per questo sito sempre di ottimo aiuto!
Sono nuovo di queste parti ho gia letto la parte inerene a mysql di for dummies ed ho dato una sbirciatina nei vari post ma ancora non ho risolto!
I problemi sono i seguenti!
Premetto ho una slackware 10.2 con kernel 2.4.31
da shell
mysql -uroot
la procedura per settare la password
tutto ok, poi passo alla procedura per creare il database e qui arrivano i problemi!
decido a sto punto di ricominciare tutto da capo poichè sono inesperto.
Quindi
mysql -uroot
la risposta è la seguente
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
ci saranno ancora un sacco di problemi ma incominciamo a risolvere uno alla volta, quindi se riesco ad andare avanti vi posto il resto!

Inviato: gio 1 dic 2005, 12:41
da Bart
Ciao ;),
innanzitutto benvenuto.
Hai provato a cercare nel forum? Su Mysql ci sono 200 post che trattano di questi problemi. L'ultimo anche piuttosto recente...

Inviato: gio 1 dic 2005, 16:09
da DaNiMoTh
prova

mysql -h localhost -uroot -p[password]

ciao!

Inviato: gio 1 dic 2005, 18:01
da gastone90
ciao, benvenuto! abbiamo i nick simili, ci scambieranno :P

:wink:

mi scuso

Inviato: sab 3 dic 2005, 23:34
da gastone
Ragazzi mi scuso per aver tardato a rispondere quanti di voi sono stati così gentili e cortesi nel darmi una mano ed insieme il benvenuto.
A Bart si ho dato un occhiatina sebbene fugace ma mi riprpongo di farlo con + cura!
A DaNiMoTh ho provato con la tu sintassi ovvero
mysql -h localhost -uroot -p[password]
scrivendo quanto dici e mettendo dopo il -pla mia password senza spazi e senza parentesi, (mi scuso per questi piccoli dettagli per te insignificanti, ma tante volte cado im errore) ed il risultato è il seguente:

root@gastone:/home/nicola# mysql -h localhost -uroot -pmia password
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 1 to server version: 4.1.14-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> create database
-> maximus
-> ;
Query OK, 1 row affected (0.21 sec)

mysql>

penso che sia andato a buon fine e che ho risolto.
A questo punto le domande sono 2.
La prima perchè con l'altra sintassi mi dava quell'errore?
La 2 è perchè dopo
Query OK, 1 row affected (0.21 sec)
mi ridà ancora
mysql> ?
A questo punto esco semplicemente con un ctrl c!!!

Re: mi scuso

Inviato: sab 3 dic 2005, 23:35
da gastone
Infine ringrazio gastone 80, e pazienza se ci scambieranno!
Un saluto

Inviato: dom 4 dic 2005, 12:29
da Paoletta
La 2 è perchè dopo
Query OK, 1 row affected (0.21 sec)
mi ridà ancora
mysql> ?
beh, ti ridà il prompt di mysql

Inviato: dom 4 dic 2005, 13:16
da DaNiMoTh
per uscire, mi sembra ci sia un comando apposta ( l'help ti aiuterà un pò! )

ciao

Inviato: lun 5 dic 2005, 8:00
da aschenaz
Per uscire basta un \q.

Se non vuoi usare la console, puoi scaricarti il phpMyadmin o qualche altro simile gestore di mysql.

Ciao,
nino