Xsane Scanner Scanjet 3400C

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 337
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Xsane Scanner Scanjet 3400C

Messaggio da Linpassion »

Ciao scrivo perchè ho un problema sane. La mia distro è Slack15 stable 64, e lo scannere usb è un HP Scanjet 3400c, che collego al pc all'occorrenza. Ora il problema è che con xsane dopo la prima pagine ho i seguneti casi: xsane va in blocco la ventola del pc gira in maniera pazzesca, la seconda pagina scansiona meta foglio ignorando il restoe va in blocco, va subito in blocco. Ho provato ad esegure sanimage da terminale, lo scanner lo vede ma libusb va in busy e non so come sbloccare. A volte funziona staccando tutto e riavviando o spegnendo il pc, ma capite bene che è impensabile se si lavora con molti fogli. non credo che dipenda dalla distribuzione, e non so se dipenda dall'alimentaro dello scanner che si scalda molto. Come posso risolvere?
Nel mentre provo a fare altre prove.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 3046
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 6.6.16
Desktop: lxde
Località: Pisa
Contatta:

Re: Xsane Scanner Scanjet 3400C

Messaggio da ponce »

prova ad avviare da una live (ad esempio l'ultima ubuntu) e ad usare xsane da li' e vedi se te lo fa ancora: nel caso lo facesse ancora e' probabile che sia un problema hardware (cavo usb o scanner).
anche un memtest (per il pc) sicuramente non farebbe male.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 337
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: Xsane Scanner Scanjet 3400C

Messaggio da Linpassion »

Ad ora tramite terminale sembra andare tutto ok
scanimage --mode Gray --format jpeg > 4.jpg
Sembra che il problema sorga quando uso una gui xsane o simplescan... che ad un certo punto anche si butto giù l'app con xkill, il devicee rimane busy. dopo provo come hai suggerito.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 337
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: Xsane Scanner Scanjet 3400C

Messaggio da Linpassion »

Ora ho fatto 4 test due scansioni a 75 e due a 150. Le prime due ok, l'ultima a 150 in blocco.
Con htop vedo questo

Immagine

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2922
Iscritto il: mer 13 feb 2008, 16:19
Slackware: 15.0
Kernel: 5.15.19
Desktop: KDE5
Località: Bulagna
Contatta:

Re: Xsane Scanner Scanjet 3400C

Messaggio da 414N »

Ci sono messaggi particolari riguardo il bus USB nel dmesg?

Rispondi