[RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3536
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

[RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da joe »

Alla fine l'ho fatto...
Ho eseguito la procedura di aggiornamento da 14.2 a 15.0.
Sapevo che qualcosa non sarebbe andato per il verso giusto, ma che fosse così incasinata la situaizone speravo di no.
Ad ogni modo, ho ceffato un passaggio piuttosto importante:
sulla 14.2 avevo i driver nvidia proprietari presi da SBo.
Prima di fare l'aggiornamento avrei dovuto rimuoverli e passare ad una configurazione coi nouveau, perché al lancio di "slackpkg clean-system", invece di pulire il sistema vengono lasciati per strada tanti bei pezzetti di link simbolici che compromettono i lsuccessivo funzionamento del sistema (ma dico... questo beato script "nvidia-switch --remove" non lo si potrebbe inserire in un qualche script di disinstallazione del pacchetto nvidia di SBo? Ci sarà evidentemente il suo motivo per dover fare quel passagigo a mano... ma se lo sis scorda
è un casino).
Alla fine ho rimosso i vecchi links rotti e li ho ricreati collegati ai files di xorg (quelli nuovi della 15.0 non i vecchi backuppati dal paccheto nvidia SBo). In conclusione sono riuscito a configurare di nuovo i nouveau. Il kernel nuovo con la sua initrd e le voci in grub. Quindi ora il sistema posso riavviarlo senza grossi problemi. Neanche X partiva poi alla fine sono riuscito.
Invece non sono riuscito a ri-compilare i driver nvidia. Ma per il momento va bene così...

Infatti pur avviandosi X, se provo a lanciare firefox o konqueror o anceh il browser testuale "links" ottengo un errore relativo ancora a nvidia:

Codice: Seleziona tutto

$ links
links: error while loading shared libraries: libnvidia-glsi.so.340.108: cannot open shared object file: No such file or directory

Codice: Seleziona tutto

$ /usr/lib64/firefox/firefox-bin
XPCOMGlueLoad error for file /usr/lib64/firefox/libmozgtk.so:
libnvidia-glsi.so.340.108: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
Per capirci, questo messaggio lo sto inviando con "lynx", immaginate la comodità .
Ora, ho cercato questo "libnvidia-glsi.so.340.108", ma non sono riuscito a capire dove sia stato e soprattutto quale altro link simbolico o altro file lo richiami...

Se avete qualche idea su come sistemare questa roba vi ringrazio in anticipo!
Ultima modifica di joe il sab 14 mag 2022, 13:38, modificato 1 volta in totale.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3536
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da joe »

Niente, ho almeno in parte risolto...
Sono andato a spulciare lo script di rimozione nvidia-switch e ho notato che non avevo sistemato a mano "libEGL.so.1"

Codice: Seleziona tutto

     if [ -e libEGL.so.1.0.0-xorg ]; then
         mv libEGL.so.1.0.0-xorg libEGL.so.1.0.0
         ln -sf libEGL.so.1.0.0 libEGL.so.1
         ln -sf libEGL.so.1.0.0 libEGL.so
     fi
Nel mio caso il file backuppato (quello targato "-xorg") non serve più perché era quello di salck-14.2, quindi l'ho buttato.
Ho poi rinominato il libEGL di nvidia, ma in realtà si può rimuovere, anzi si deve perché e compilato sul vecchio sistema.
E infine ho ricreato i links libEGL.so e libEGL.so.1 in modo che puntino alla nuova libEGL.so.1.1.0 stock di slack-15.0.

Alla fine la situazione in /usr/lib64 è la seguente (il targato -nvidia appunto va rimosso):

Codice: Seleziona tutto

:/usr/lib64# file libEGL.so*
libEGL.so:                symbolic link to libEGL.so.1.1.0
libEGL.so.1:              symbolic link to libEGL.so.1.1.0
libEGL.so.1.1.0:          ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
libEGL.so.340.108-nvidia: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
In questo modo sia links che firefox, così come altri tipo anche gvim o konqueror ecc ecc, partono, senza più quell'errore relativo a libnvidia-glsi.

rik70
Iper Master
Iper Master
Messaggi: 2365
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 4.19
Desktop: Sway
Distribuzione: Arch Linux

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da rik70 »

Nel caso qualcosa non vada ancora, reinstalla con slackpkg quantomeno tutti i pacchetti 'l' e 'x'.
Il comando:

Codice: Seleziona tutto

slackpkg reinstall l/* x/*
oppure dillo tu a me.

Poi dai di nuovo

Codice: Seleziona tutto

slackpkg upgrade-all
** Per la versione che usi dei driver nvidia serve questa serie di patch, esclusa la prima:
https://aur.archlinux.org/cgit/aur.git/ ... -340xx-lts

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3536
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da joe »

Grazie rik.
Qualche pacchetto in effetti avevo già provato a reinstallarlo, ma non tutto così. Il fatto è che il README è ceffato, nvidia-switch modifica più files di quel paio riportato lì, e sarebbe il caso di esplicitarli meglio, in modo che sia possibile farlo anche a mano e che funzioni. Altrimenti meglio mettere: "leggetevi lo script e fate a mano quello che avrebbe fatto lui se non vi foste scordati di lanciarlo prima della rimozione".

Come se non bastasse dal mirror multilib di slackware.uk ho riscontrato errori sul checksum di un paio di pacchetti... che non crdo c'entrino nulla con quest'altro problema (appunto risolto). In realtà erano riferiti ai file ".asc"... i txz li ho verificati ed erano buoni in termini di md5. Alla fine è rientrato impostando il mirror di default quello di alien nederland ".nl". In pratica in /etc/slackpkg/slackpkgplus.conf:

Codice: Seleziona tutto

MIRRORPLUS['multilib']=https://slackware.nl/people/alien/multilib/15.0/
Anche multilib non è che semplifichi le cose in effetti... d'altra parte serve.

Sì per quanto riguarda il driver nvidia-kernel, non compila un accidente. Però dopo essere stato costretto in frambuffer con lynx, ora coi nouveau è già una pacchia! :lol:
Questo è il contenuto della dir di build scaricata da SBo, l'ho fatto a mano senza sbopkg perché in effetti mancano delle patches...
Salta fuori anche l'errore di svista sul compilatore risolvibile lanciando con CC=gcc ./nvidia-legacy340-kernel.Slackbuild.

Codice: Seleziona tutto

nvidia-legacy340-kernel# tree
.
├── 10-nvidia.conf
├── NVIDIA-Linux-x86_64-340.108.run
├── README
├── doinst.sh
├── nvidia-legacy340-kernel.SlackBuild
├── nvidia-legacy340-kernel.info
├── nvidia-modprobe-340.108.tar.bz2
├── nvidia-persistenced-340.108.tar.bz2
├── nvidia-settings-340.108.tar.bz2
├── nvidia-xconfig-340.108.tar.bz2
├── patches
│   ├── 0001-kernel-5.7.patch
│   ├── 0002-kernel-5.8.patch
│   ├── 0003-kernel-5.9.patch
│   ├── 0004-kernel-5.10.patch
│   ├── 0005-kernel-5.11.patch
│   └── 0007-kernel-5.15.patch
└── slack-desc

1 directory, 17 files
Dirai, perché manca la patch "0006"?
Perché nell'applicarla dà un'errore e esce FAILED. È quella per il kernel 5.14.


Tanto per continuare l'OT: ecco il responso dopo il lancio dello SB. L'ho interrotto perché l'errore salta fuori subito e poi alla fine non riesce a costruire il modulo nvidia.ko o come si chiama vado a memoria...

Codice: Seleziona tutto

# CC=gcc ./nvidia-legacy340-kernel.SlackBuild
Creating directory NVIDIA-Linux-x86_64-340.108
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 340.108......................................................
...............................................................................................................................
..............................................
patching file kernel/Makefile
patching file kernel/conftest.sh
patching file kernel/dkms.conf
patching file kernel/nv-drm.c
patching file kernel/nv-linux.h
patching file kernel/nv-procfs.c
patching file kernel/nv-time.h
patching file kernel/nv.c
patching file kernel/os-interface.c
patching file kernel/uvm/Makefile
patching file kernel/uvm/conftest.sh
patching file kernel/uvm/nvidia_uvm_lite.c
patching file kernel/nv-linux.h
patching file kernel/nvidia-modules-common.mk
patching file kernel/os-mlock.c
patching file kernel/uvm/nvidia_uvm_lite_api.c
patching file kernel/nv-drm.c
patching file kernel/nv-linux.h
patching file kernel/nv.c
patching file kernel/uvm/nvidia_uvm_linux.h
patching file kernel/nv-drm.c
Hunk #1 succeeded at 364 (offset 42 lines).
patching file kernel/nv-linux.h
patching file kernel/uvm/nvidia_uvm_linux.h
patching file kernel/nv-drm.c
Hunk #1 succeeded at 519 (offset -10 lines).
NVIDIA: calling KBUILD...
make[1]: ingresso nella directory «/usr/src/linux-5.15.38»
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (                \
echo >&2;                                                       \
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \
echo >&2 ;                                                      \
/bin/false)
make -f ./scripts/Makefile.build obj=/tmp/SBo/NVIDIA-Linux-x86_64-340.108/kernel \
single-build= \
need-builtin=1 need-modorder=1
^Cmake[2]: *** [/tmp/SBo/NVIDIA-Linux-x86_64-340.108/kernel/nvidia-modules-common.mk:155: conftest-compile-test] Interruzione
make[1]: *** [Makefile:1868: /tmp/SBo/NVIDIA-Linux-x86_64-340.108/kernel] Interruzione
make: *** [Makefile:202: nvidia.ko] Interruzione


rik70
Iper Master
Iper Master
Messaggi: 2365
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 4.19
Desktop: Sway
Distribuzione: Arch Linux

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da rik70 »

joe ha scritto:
sab 14 mag 2022, 16:41
Dirai, perché manca la patch "0006"?
Perché nell'applicarla dà un'errore e esce FAILED. È quella per il kernel 5.14.
Devi sostituire tutte le patch.
Scarica https://aur.archlinux.org/cgit/aur.git/ ... lts.tar.gz e scompattalo nella root dei sorgenti del pacchetto.

Poi nello SlackBuild sostituisci:

Codice: Seleziona tutto

for i in $CWD/patches/* ; do patch -p1 < $i ; done
con

Codice: Seleziona tutto

for i in $CWD/nvidia-340xx-lts/0*-kernel*.patch ; do patch -p1 < $i ; done
e vedrai che compila:

Codice: Seleziona tutto

Creating Slackware package:  /tmp/nvidia-legacy340-kernel-340.108_5.15.38-x86_64-1_SBo.tgz

./
install/
install/doinst.sh
install/slack-desc
lib/
lib/modules/
lib/modules/5.15.38/
lib/modules/5.15.38/kernel/
lib/modules/5.15.38/kernel/drivers/
lib/modules/5.15.38/kernel/drivers/video/
lib/modules/5.15.38/kernel/drivers/video/nvidia-uvm.ko
lib/modules/5.15.38/kernel/drivers/video/nvidia.ko
usr/
usr/doc/
usr/doc/nvidia-legacy340-kernel-340.108_5.15.38/
usr/doc/nvidia-legacy340-kernel-340.108_5.15.38/nvidia-legacy340-kernel.SlackBuild
usr/share/
usr/share/X11/
usr/share/X11/xorg.conf.d/
usr/share/X11/xorg.conf.d/10-nvidia.conf

Slackware package /tmp/nvidia-legacy340-kernel-340.108_5.15.38-x86_64-1_SBo.tgz created.
Occhio poi alla questione 'ABI XORG', se deciderai di usare i driver proprietari.

rik70
Iper Master
Iper Master
Messaggi: 2365
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 4.19
Desktop: Sway
Distribuzione: Arch Linux

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da rik70 »

*Ps.

Io comunque, al posto tuo, se non ti danno problemi terrei i nouveau.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3536
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da joe »

Ora per principio devo farli compilare...
Poi perché mai terresti i nouveau?
Se per disgrazia ti serve supporto al 3D con qualcosa? Da quello che ricordavo io erano un pochino meglio i closed, anche se sono closed e fanno girare veramente molto gli zebedei in manovre come questa... di aggiornamento di sistema, che va be' se non si usa la current non è poi un problema così ricorrente...

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2916
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.17.4
Desktop: lxde
Località: Pisa
Contatta:

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da ponce »

li ho appena aggiornati in git: se ti puo' servire questo e' il tarball (in questo momento compila anche con kernel 5.17.x della current).

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3536
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da joe »

Grazie ponce!
No guarda fortunatamente con le patch di arch prese dal link di rik ha funzionato. Nel senso che ha creato il modulo:

Codice: Seleziona tutto

Creating Slackware package:  /tmp/nvidia-legacy340-kernel-340.108_5.15.38-x86_64-1_SBo.tgz

./
install/
install/doinst.sh
install/slack-desc
lib/
lib/modules/
lib/modules/5.15.38/
lib/modules/5.15.38/kernel/
lib/modules/5.15.38/kernel/drivers/
lib/modules/5.15.38/kernel/drivers/video/
lib/modules/5.15.38/kernel/drivers/video/nvidia-uvm.ko
lib/modules/5.15.38/kernel/drivers/video/nvidia.ko
usr/
usr/doc/
usr/doc/nvidia-legacy340-kernel-340.108_5.15.38/
usr/doc/nvidia-legacy340-kernel-340.108_5.15.38/nvidia-legacy340-kernel.SlackBuild
usr/share/
usr/share/X11/
usr/share/X11/xorg.conf.d/
usr/share/X11/xorg.conf.d/10-nvidia.conf

Slackware package /tmp/nvidia-legacy340-kernel-340.108_5.15.38-x86_64-1_SBo.tgz created.
Però... Questo errore si ripete almeno due volte allo schermo durante la compilazione.

Codice: Seleziona tutto

echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";      \
È un warning "normale" ignorabile?
Capita anche da voi?
Oppure è sintomo di scorretta compilazione che magari poi può portare ad ulteriori malfunzionamenti in qualcosa a valle?


Aggiungo due cose:
le patch di arch sono le stesse di SBo tranne la 0005 relativa al kernel 5.11, le altre sono identiche e possono risiedere tranquillamente nella subdir "patches" che vengono applicate senza errori.

Leggevo qualche post su LQ in particolare questo:
https://www.linuxquestions.org/question ... ost6351276
E in particolare questa frase mi ha lasciato perplesso:
Installing Multilib means also that you should use your own built kernels, otherwise you cannot build external kernel modules.

Ma siamo sicuri? A voi risulta sta cosa?
In pratica il tizio rileva che la compilazione non ha creato il modulo e attribuisce il problema al fatto che GCC in uso sul sistema multilib è gcc-11.2.0_multilib-x86_64-2alien, ad esempio nel caso della 15.0, mentre il kernel in uso, in effetti è stato generato sul sistema di Pat su cui girava un altro compilatore, stessa versione ma non preparato per multilib.

Poi il problema non era quello riportato dal tizio credo, anche se non ho letto tutto, ma come farebbe altrimenti a funzionare la compilazione nel mio caso che ho multilib e nvidia.ko è a tutti gli effetti un modulo per il kernel?
Quanto c'è di vero in quel post? O è banalmente una cantonata?

rik70
Iper Master
Iper Master
Messaggi: 2365
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 4.19
Desktop: Sway
Distribuzione: Arch Linux

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da rik70 »

ponce ha scritto:
sab 14 mag 2022, 20:04
Ora per principio devo farli compilare...
E mi sembra giusto 8)
joe ha scritto:
sab 14 mag 2022, 19:59

Poi perché mai terresti i nouveau?
Perché gli nvidia non li aggiornano dal 2019.
joe ha scritto:
sab 14 mag 2022, 19:59
Se per disgrazia ti serve supporto al 3D con qualcosa?
Perché non funziona il 3D coi nouveau? Chiedo eh, perché è da molto che non bazzico con nvidia.
joe ha scritto:
sab 14 mag 2022, 20:49
È un warning "normale" ignorabile?
Sì.
joe ha scritto:
sab 14 mag 2022, 20:49
https://www.linuxquestions.org/question ... ost6351276
Non ho letto lo storico, ma da quello che capisco lì la compilazione non è andata a buon fine e il tizio s'è ritrovato con un pacchetto praticamente vuoto.

Tu hai la multilib? Il pacchetto che hai generato contiene i moduli(64-bit) del kernel?
Da quello che hai postato vedo di sì.
Quindi non hai il problema.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3536
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da joe »

Sì infatti, come appunto scrivevo il problema del tizio in realtà non era il fatto di avere sistema multilib e kernel stock.. Altrimenti non avrebbe funzionato neanche a me.
Però leggendo lì m'era ritornata in mente una vecchia lettura dagli archivi ltpd, forse era roba di LFS in cui si parlava di possibili benefici in termini forse di stabilità (ma non ricordo bene... era una cosa del genere) dovuti a compilare prima il kernel e poi il compilatore quindi ancora il kernel col compilatore ricompilato, insomma il senso era di avere tutti i pezzi il più "vicini" possibile. Ripeto, magari ricordo male.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3536
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: [RISOLTO] Errore dopo aggiornamento da 14.2 a 15.0 per libnvidia-glsi.so.340.108

Messaggio da joe »

Ok, direi che almeno per il momento sembra tutto ok. Ho compilato anche il pacchetto del driver (il modulo del kernel in build time non sebra necessario o per lo meno non ha dato errori) e ho:
1- installato il pacchetto apposito di blacklist per nouveau (poi magari vedrò di informarmi meglio anch'io sullo stato dell'arte del driver open per GPU tipo la mia che è una misera GeForce 210.
2- installato il pacchetto del kernel
3- installato il pacchetto del driver
4- copiato il file /usr/share/X11/xorg.conf.d/10-nvidia in /etc/X11/xorg.conf.d
5- attivato VDPAU in

Codice: Seleziona tutto

/etc/profile.d/vdpau.sh
export VDPAU_LOG=0
export VDPAU_DRIVER="nvidia"
6- riavviato
sembrerebbe tutto apposto.

Rispondi