aggiornamento di virtualbox-kernel con kernel 5.18 (patch)

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
gian_d
Linux 3.x
Linux 3.x
Messaggi: 541
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.19.xx
Desktop: KDE 5.25
Località: Sardinia
Contatta:

aggiornamento di virtualbox-kernel con kernel 5.18 (patch)

Messaggio da gian_d »

Per chi usa lo slackbuild per la versione 6.1.32 di VirtualBox segnalo che con la current o, comunque, con il kernel 5.18, lo slackbuild preso da slackbuilds.org incappa in un errore di compilazione.
Da quel che ho capito con le versioni più recenti di VirtualBox il problema non si presenta, in ogni caso si può usare anche la 6.1.32 inserendo nello slackbuild la sequente patch (rif. https://www.mail-archive.com/arch-commi ... 21191.html ):

Codice: Seleziona tutto

--- virtualbox-kernel-6.1.32/vboxnetflt/linux/VBoxNetFlt-linux.c
+++ virtualbox-kernel-6.1.32_fix/vboxnetflt/linux/VBoxNetFlt-linux.c
@@ -2312,5 +2312,11 @@
                 Log6(("vboxNetFltPortOsXmit: pBuf->cb dump:\n%.*Rhxd\n", sizeof(pBuf->cb), pBuf->cb));
                 Log6(("vboxNetFltPortOsXmit: netif_rx_ni(%p)\n", pBuf));
+#if RTLNX_VER_MIN(5,18,0)
+                local_bh_disable();
+                err = netif_rx(pBuf);
+                local_bh_enable();
+#else
                 err = netif_rx_ni(pBuf);
+#endif
                 if (err)
                     rc = RTErrConvertFromErrno(err);


Avatar utente
red
Linux 3.x
Linux 3.x
Messaggi: 804
Iscritto il: gio 20 gen 2005, 0:00
Slackware: 13.0
Kernel: 2.6.33.4
Desktop: fluxbox
Località: Verona
Contatta:

Re: aggiornamento di virtualbox-kernel con kernel 5.18 (patch)

Messaggio da red »

Confermo stesso comportamento e stessa soluzione anche con versione 6.1.34!

Rispondi