problema con la tastiera [risolto]

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 471
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 6.0.7 preemptive
Desktop: KDE 5.23
Distribuzione: Debian Bullseye
Località: Novara, provincia

problema con la tastiera [risolto]

Messaggio da Rama »

di punto in bianco se premo il tasto del punto interrogativo salta fuori _
< al posto del punto e virgola, ecc...
in Impostazioni di KDE la mappatura e' IT l'hardware 101 tasti generic, la stessa della Debian che non mi da' noie
che fare -punto interregativo
Ultima modifica di Rama il dom 21 ago 2022, 22:54, modificato 1 volta in totale.

erio
Linux 4.x
Linux 4.x
Messaggi: 1295
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: problema con la tastiera

Messaggio da erio »

mappatura inglese prova questo : setxkbmap it non so se ti funziona la mia e' inglese

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 471
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 6.0.7 preemptive
Desktop: KDE 5.23
Distribuzione: Debian Bullseye
Località: Novara, provincia

Re: problema con la tastiera

Messaggio da Rama »

risolto, grazie: ?
però non capisco perché, un minuto prima era a posto un minuto dopo no;

gian_d
Linux 3.x
Linux 3.x
Messaggi: 576
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.19.xx
Desktop: KDE 5.26
Località: Sardinia
Contatta:

Re: problema con la tastiera [risolto]

Messaggio da gian_d »

Stranissimo, proprio adesso mi è successa la stessa cosa!

gian_d
Linux 3.x
Linux 3.x
Messaggi: 576
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.19.xx
Desktop: KDE 5.26
Località: Sardinia
Contatta:

Re: problema con la tastiera [risolto]

Messaggio da gian_d »

Ops... scoperto l'inghippo, era una cavolata che avevo combinato io: stamattina avevo disattivato alcuni servizi in background e tra questi anche il demone della tastiera. A quanto pare disabilitando questo servizio, ogni volta che si accede all'account viene abilitata la tastiera inglese.

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 471
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 6.0.7 preemptive
Desktop: KDE 5.23
Distribuzione: Debian Bullseye
Località: Novara, provincia

Re: problema con la tastiera [risolto]

Messaggio da Rama »

ah, ecco, oggi è successo anche a me;
per non avere attivo un demone inutile ho messo setxkbmap it in rc.local;

gian_d
Linux 3.x
Linux 3.x
Messaggi: 576
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.19.xx
Desktop: KDE 5.26
Località: Sardinia
Contatta:

Re: problema con la tastiera [risolto]

Messaggio da gian_d »

Aspe', non sono sicuro di aver capito:
1. hai impostato setxkbmap it in rc.local
2. hai disabilitato il demone della tastiera di KDE

In questo modo viene comunque abilitata la tastiera italiana. Ho capito bene?

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 471
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 6.0.7 preemptive
Desktop: KDE 5.23
Distribuzione: Debian Bullseye
Località: Novara, provincia

Re: problema con la tastiera [risolto]

Messaggio da Rama »

sì, ma non funziona;
non capisco il perché, altri comandi in rc.local vengono eseguiti;

gian_d
Linux 3.x
Linux 3.x
Messaggi: 576
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.19.xx
Desktop: KDE 5.26
Località: Sardinia
Contatta:

Re: problema con la tastiera [risolto]

Messaggio da gian_d »

Ah, ecco. In effetti se tutto fila per il verso giusto non c'è gusto :-D

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 471
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 6.0.7 preemptive
Desktop: KDE 5.23
Distribuzione: Debian Bullseye
Località: Novara, provincia

Re: problema con la tastiera [risolto]

Messaggio da Rama »

ho anche seguito la vecchia guida della mia defunta HP:

La tastiera italiana può essere impostata dal Centro di Controllo, in alternativa si può farlo editando (fate sempre una copia di backup, un errore in questi tipi di file può pregiudicare l'OS) il file /etc/X11/XF86Config e cambiando nella sezione Core keyboard's InputDevice section la riga
# Option "XkbLayout" "de"
in
Option "XkbLayout" "it"
inoltre nel file /etc/profile aggiungete o modificate LC_ALL in: LC_ALL="it_IT"
Per fare in modo che i programmi localizzati in italiano si servano della nostra lingua aggiungete, nello stesso file:
export LANG="it_IT@euro"
export CHARSET="iso8859-15"
poi in /etc/profile.d/lang.sh
export LANG=it_IT@euro
infine in /etc/profile.d/lang.csh modificate il setnev: setenv LANG it_IT
Inoltre, se non funziona il tasto "<>" decommentate
Option "XkbModel" "pc105" in XF86Config.

senza risultato;
visto che per mesi non ho avuto 'sto problema sarà colpa di qualche aggiornamento recente;

erio
Linux 4.x
Linux 4.x
Messaggi: 1295
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: problema con la tastiera [risolto]

Messaggio da erio »

vedi questo se vi e' utile: Per prima cosa viene italianizzato il sistema impostando la lingua nel file /etc/profile.d/lang.sh e viene impostata la mappatura della tastiera per xorg grazie ad una copia del file /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf in /etc/X11/xorg.conf.d/ in cui viene sostituito il valore "us" con quello settato nella variabile lng.

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 471
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 6.0.7 preemptive
Desktop: KDE 5.23
Distribuzione: Debian Bullseye
Località: Novara, provincia

Re: problema con la tastiera [risolto]

Messaggio da Rama »

/etc/profile.d/lang.sh l'avevo già fatto, modificati i due file contenuti in /xorg.conf.d vedrò al riavvio;
ma siamo solo in due ad avere questo problema?
...
stavolta è andata;

erio
Linux 4.x
Linux 4.x
Messaggi: 1295
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: problema con la tastiera [risolto]

Messaggio da erio »

questa modifica dovrebbe essere ad un livello piu basso quindi non modificabile....credo mo non sono sicuro.

Avatar utente
Rama
Linux 2.x
Linux 2.x
Messaggi: 471
Iscritto il: sab 29 mar 2008, 12:18
Slackware: 15.0 x86_64
Kernel: 6.0.7 preemptive
Desktop: KDE 5.23
Distribuzione: Debian Bullseye
Località: Novara, provincia

Re: problema con la tastiera [risolto]

Messaggio da Rama »

erio ha scritto:
gio 1 set 2022, 19:06
la mappatura della tastiera per xorg grazie ad una copia del file /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf in /etc/X11/xorg.conf.d/ in cui viene sostituito il valore "us" con quello settato nella variabile lng.
ho appena reinstallato la Slack per il problema di un altro thread e a quanto pare basta solo questa modifica, dopo che quelle fatte in Impostazioni di sistema in KDE non avevano avuto effetto;

Rispondi