Xfce 4.18 su Slackware64-15

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 639
Iscritto il: lun 3 mag 2004, 0:00
Nome Cognome: Luigi Picaro
Slackware: 15.0-x64
Kernel: 6.1
Desktop: Xfce-4.16
Località: Salerno

Xfce 4.18 su Slackware64-15

Messaggio da lennynero »

Salve a tutti,
come da titolo vorrei provare il nuovo Xfce sulla mia slack "ferma" alla 15.0.
Ho scaricato tutti i pacchetti della nuova versione 4.18 dal ramo current e li ho sostituiti ai miei pacchetti alla versione 4.16, presenti nella stable. Purtroppo dopo l'avvio di X rimango su una schermata nera, probabilmente a causa del fatto che i nuovi pacchetti sono stati buildati con la current (con glibc 2.34).
In questo post però sembrava che la cosa potesse essere fattibile, anche se si parla di build&run...

Qualcuno mi chiarisce la situazione?

Grazie in anticipo.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3661
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 15.0
Kernel: 5.15.38
Desktop: dwm

Re: Xfce 4.18 su Slackware64-15

Messaggio da joe »

Non ho provato direttamente, ma come dicono lì su reddit, conviene compilarselo in locale. Lo puoi fare "facilmente" scaricando la "directory" di xfce dalla dir source del repo slackware current.

Esempi da qui con lftp da terminale:

Codice: Seleziona tutto

lftp slackware.uk:/slackware/slackware64-current/source/xfce
hai il prompt e quoi fare "get" di quello che vuoi.

Anni fa c'era cneh uno script per compilarsi in locale tutto il set di applicazioni xfce:

https://mirrors.slackware.com/slackware ... ild-all.sh

Ora non c'è più, almeno lì nella stessa dir...
Comunque il succo è quello: non è buona norma far girare xfce precompilato della current di dicembre 2022 o gennaio 2023, sulla stabile uscita quasi un anno prima.
La current nel frattempo è cambiata parecchio, e i precompilati in generale non sono più compatibili, magari qualcuno sì ma compilare sul sistema target di solito assicura una piena compatibilità, se funziona perché a volte sono necesarie anche dipendenze in build-time di cui il vecchio sistema non dispone, e aggiornare anche quelle potrebbe non essere un'opzione in quanto tutto il resto del sistema si appoggia sulle vecchie.

Io proverei a ricompilare tutti i pacchetti della serie "xfce" usando gli slackbuilds della current di Pat, come fa nello script vecchio, controlla che i pacchetti siano gli stessi ed eventualmente modificalo per adattarlo al repo.

Per scaricare tutta la serie:

lftp -c "open slackware.uk:/slackware/slackware64-current/source/; mirror xfce"

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 639
Iscritto il: lun 3 mag 2004, 0:00
Nome Cognome: Luigi Picaro
Slackware: 15.0-x64
Kernel: 6.1
Desktop: Xfce-4.16
Località: Salerno

Re: Xfce 4.18 su Slackware64-15

Messaggio da lennynero »

Grazie mille Joe,
ho compilato i sorgenti presi della current ed in effetti tutto funziona correttamente.
La compilazione di alcuni pacchetti dipende dall'installazione delle versioni nuove di altri pacchetti:
  • xfconf dipende dal nuovo libxfce4util
  • thunar dipende dai nuovi exo e libxfce4ui
  • panel dipende dal nuovo garcon
  • xfce4-screenshooter dipende da libsoup >= 3.0.0
*bonus: ho provato anche xfdashboard 1.0.0, ma richiede clutter, che richiede cogl... ;)

Rispondi