Pagina 1 di 1

Slackware64-current e problemi kernel 4.4.x

Inviato: ven 1 lug 2016, 9:57
da targzeta
Ciao, attualmente con la current ho i seguenti problemi:
  • collegando un monitor esterno sulla docking station, ho un kernel panic.
  • con il nuovo kernel 4.4.14 non riesco a montare la directory crittata con ecryptfs. Ho anche installato il modulo kernel-module-ecryptfs-4.4.14-x86_64-1.txz (ovviamente dopo il pacchetto kernel-modules-4.4.14-x86_64-1.txz) ma non funziona uguale, ottengo:

    Codice: Seleziona tutto

    [   77.531998] Error opening lower file for lower_dentry [0xffff88022d57bcc0] and lower_mnt [0xffff88024469c320]; rc = [-124]
    [   77.532002] ecryptfs_open: Error attempting to initialize the lower file for the dentry with name [targzeta]; rc = [-124]
    [   79.906672] Error opening lower file for lower_dentry [0xffff880093249300] and lower_mnt [0xffff88024469c320]; rc = [-124]
    [   79.906680] ecryptfs_open: Error attempting to initialize the lower file for the dentry with name [/]; rc = [-124]
    [   83.001721] Error opening lower file for lower_dentry [0xffff88022d57bcc0] and lower_mnt [0xffff88024469c320]; rc = [-124]
    [   83.001732] ecryptfs_open: Error attempting to initialize the lower file for the dentry with name [targzeta]; rc = [-124]
  • sempre con ecryptfs ho anche il problema che il modulo non si carica automaticamente e modprobe mi dice modprobe: ERROR: could not insert 'ecryptfs': Exec format error. Purtroppo la soluzione indicata nel thread che vi ho linkato con me non funziona perché il kernel-generic mi va in kernel panic. Ogni volta all'avvio mi tocca loggarmi come root ed eseguire a mano insmod.
Domandona: secondo voi è possibile che la prossima release si porti dentro il kernel 4.4 con tutti questi problemi?

Emanuele

Re: Slackware64-current e problemi kernel 4.4.x

Inviato: ven 1 lug 2016, 11:24
da boh
A mio parere no, ma sicuramente è meglio segnalarlo a Pat (se non l'hai già fatto) ;)

Re: Slackware64-current e problemi kernel 4.4.x

Inviato: ven 1 lug 2016, 11:34
da Ansa89
targzeta ha scritto:secondo voi è possibile che la prossima release si porti dentro il kernel 4.4 con tutti questi problemi?
Penso di sì: il kernel 4.4 è ufficialmente LTS; mentre il 4.5, 4.6 e il futuro 4.7 non avranno il supporto a lungo termine.
Il problema del monitor esterno è dovuto al fatto che hai un processore (con scheda grafica integrata) troppo nuovo, infatti anche nel topic che hai linkato suggeriscono di aggiornare al 4.5.
Il consiglio che ti do (dato che non sei più un newbie da un po' di tempo ;) ), è quello di compilarti manualmente l'ultimo kernel stabile e tenerlo aggiornato manualmente; in questo modo dovresti risolvere sia i problemi delle scheda grafica, sia quelli legati a ecryptfs.

Purtroppo se Pat non aggiorna il kernel ad una major version più recente, la prossima slackware non sarà compatibile con i computer più recenti.

Re: Slackware64-current e problemi kernel 4.4.x

Inviato: ven 1 lug 2016, 12:57
da ponce