Problemi con libreoffice dopo ultimo aggiornamento a current [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
aschenaz
Staff
Staff
Messaggi: 4616
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Problemi con libreoffice dopo ultimo aggiornamento a current [RISOLTO]

Messaggio da aschenaz »

Riscontrate problemi in avvio di libreoffice 6.0.5?
Questo è ciò che mi restituisce:

Codice: Seleziona tutto

javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx
/usr/lib64/libreoffice/program/soffice.bin: error while loading shared libraries: libboost_system.so.1.67.0: cannot open shared object file: No such file or directory
Ho provato a reinstallarlo; ho reinstallato anche Boost...

Inoltre, nell'ultimo aggiornamento, non era andata a buon fine l'installazione di Calligra, ma i file vecchi erano stati eliminati. Potrebbe essere dipeso da quello? Calligra l'ho comunque installato e funziona...

Di recente ho anche installato Cinelerra e Kdenlive con relative dipendenze...

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current

Messaggio da conraid »

Si è aggiornato boost devi ricompilare tutto quel che dipende da esso.

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4616
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current

Messaggio da aschenaz »

Mi sa che aspetto che faccia tutto AlienBob :lol:
Grazie, Corrado.

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current

Messaggio da conraid »

Anche io devo aspettare lui, ma... ti allego uno script che ho usato per creare link simbolici, scelta pessima ma sembra funzionare.
Una volta che Alien rilascia il pacchetto rilancia lo script sostituendo il make_link finale con del_link

Codice: Seleziona tutto

#!/bin/sh

cd /usr/lib64

make_link() {
ln -s libboost_atomic.so.1.68.0 libboost_atomic.so.1.67.0
ln -s libboost_chrono.so.1.68.0 libboost_chrono.so.1.67.0
ln -s libboost_container.so.1.68.0 libboost_container.so.1.67.0
ln -s libboost_context.so.1.68.0 libboost_context.so.1.67.0
ln -s libboost_coroutine.so.1.68.0 libboost_coroutine.so.1.67.0
ln -s libboost_date_time.so.1.68.0 libboost_date_time.so.1.67.0
ln -s libboost_fiber.so.1.68.0 libboost_fiber.so.1.67.0
ln -s libboost_filesystem.so.1.68.0 libboost_filesystem.so.1.67.0
ln -s libboost_graph.so.1.68.0 libboost_graph.so.1.67.0
ln -s libboost_iostreams.so.1.68.0 libboost_iostreams.so.1.67.0
ln -s libboost_locale.so.1.68.0 libboost_locale.so.1.67.0
ln -s libboost_log.so.1.68.0 libboost_log.so.1.67.0
ln -s libboost_log_setup.so.1.68.0 libboost_log_setup.so.1.67.0
ln -s libboost_math_c99.so.1.68.0 libboost_math_c99.so.1.67.0
ln -s libboost_math_c99f.so.1.68.0 libboost_math_c99f.so.1.67.0
ln -s libboost_math_c99l.so.1.68.0 libboost_math_c99l.so.1.67.0
ln -s libboost_math_tr1.so.1.68.0 libboost_math_tr1.so.1.67.0
ln -s libboost_math_tr1f.so.1.68.0 libboost_math_tr1f.so.1.67.0
ln -s libboost_math_tr1l.so.1.68.0 libboost_math_tr1l.so.1.67.0
ln -s libboost_prg_exec_monitor.so.1.68.0 libboost_prg_exec_monitor.so.1.67.0
ln -s libboost_program_options.so.1.68.0 libboost_program_options.so.1.67.0
ln -s libboost_python27.so.1.68.0 libboost_python27.so.1.67.0
ln -s libboost_python36.so.1.68.0 libboost_python36.so.1.67.0
ln -s libboost_random.so.1.68.0 libboost_random.so.1.67.0
ln -s libboost_regex.so.1.68.0 libboost_regex.so.1.67.0
ln -s libboost_serialization.so.1.68.0 libboost_serialization.so.1.67.0
ln -s libboost_signals.so.1.68.0 libboost_signals.so.1.67.0
ln -s libboost_stacktrace_addr2line.so.1.68.0 libboost_stacktrace_addr2line.so.1.67.0
ln -s libboost_stacktrace_basic.so.1.68.0 libboost_stacktrace_basic.so.1.67.0
ln -s libboost_stacktrace_noop.so.1.68.0 libboost_stacktrace_noop.so.1.67.0
ln -s libboost_system.so.1.68.0 libboost_system.so.1.67.0
ln -s libboost_thread.so.1.68.0 libboost_thread.so.1.67.0
ln -s libboost_timer.so.1.68.0 libboost_timer.so.1.67.0
ln -s libboost_type_erasure.so.1.68.0 libboost_type_erasure.so.1.67.0
ln -s libboost_unit_test_framework.so.1.68.0 libboost_unit_test_framework.so.1.67.0
ln -s libboost_wave.so.1.68.0 libboost_wave.so.1.67.0
ln -s libboost_wserialization.so.1.68.0 libboost_wserialization.so.1.67.0
}

del_link() {
rm  libboost_atomic.so.1.67.0
rm  libboost_chrono.so.1.67.0
rm  libboost_container.so.1.67.0
rm  libboost_context.so.1.67.0
rm  libboost_coroutine.so.1.67.0
rm  libboost_date_time.so.1.67.0
rm  libboost_fiber.so.1.67.0
rm  libboost_filesystem.so.1.67.0
rm  libboost_graph.so.1.67.0
rm  libboost_iostreams.so.1.67.0
rm  libboost_locale.so.1.67.0
rm  libboost_log.so.1.67.0
rm  libboost_log_setup.so.1.67.0
rm  libboost_math_c99.so.1.67.0
rm  libboost_math_c99f.so.1.67.0
rm  libboost_math_c99l.so.1.67.0
rm  libboost_math_tr1.so.1.67.0
rm  libboost_math_tr1f.so.1.67.0
rm  libboost_math_tr1l.so.1.67.0
rm  libboost_prg_exec_monitor.so.1.67.0
rm  libboost_program_options.so.1.67.0
rm  libboost_python27.so.1.67.0
rm  libboost_python36.so.1.67.0
rm  libboost_random.so.1.67.0
rm  libboost_regex.so.1.67.0
rm  libboost_serialization.so.1.67.0
rm  libboost_signals.so.1.67.0
rm  libboost_stacktrace_addr2line.so.1.67.0
rm  libboost_stacktrace_basic.so.1.67.0
rm  libboost_stacktrace_noop.so.1.67.0
rm  libboost_system.so.1.67.0
rm  libboost_thread.so.1.67.0
rm  libboost_timer.so.1.67.0
rm  libboost_type_erasure.so.1.67.0
rm  libboost_unit_test_framework.so.1.67.0
rm  libboost_wave.so.1.67.0
rm  libboost_wserialization.so.1.67.0
}

make_link

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current

Messaggio da conraid »

Avevo 5 minuti. Miglioratelo che sicuramente ho fatto errori

Codice: Seleziona tutto

#!/bin/sh

set -eu

if [[ $EUID -ne 0 ]]; then
  echo "This script must be run as root" 1>&2
  exit
fi

if [ -e /usr/lib64 ]; then
  LIBDIRSUFFIX="64"
else
  LIBDIRSUFFIX=""
fi

BVER=$(echo /var/lib/pkgtools/packages/boost-* | cut -d/ -f6 | cut -d- -f2)
REQV=$(ldd /usr/lib$LIBDIRSUFFIX/libreoffice/program/soffice.bin | grep "not found" | grep boost |  cut -d" " -f1 | cut -d. -f3- | uniq)


_usage() {
  echo "Usage: $0 COMMAND"
  echo "COMMAND:"
  echo "  -m | --make	 make link"
  echo "  -d | --delete	 delete link"
  echo "  -h | --help	 this help"
}

make_link() {
  cd /usr/lib$LIBDIRSUFFIX

  for i in libboost_*$BVER; do
    ln -s $i ${i%%.*}.so.$REQV
  done
}

del_link() {
  cd /usr/lib$LIBDIRSUFFIX
  rm libboost_*.so.$REQV
}

if [ $# != 1 ]; then
  _usage
  exit
fi

case ${1:-""} in
  -m | --make )
    make_link
    ;;
  -d | --delete )
    del_link
    ;;
  -h | --help )
    _usage
    exit
    ;;
  * )
    _usage
    exit 1
esac

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4616
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current

Messaggio da aschenaz »

Grazie mille Corrado! :thumbright:

No, non ci metterò mano per ora: di sicuro, arrugginito come sono, combinerei casini.
Aspetterò un altro po', ricorrendoci qualora libreoffice mi dovesse servire con urgenza.

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current

Messaggio da conraid »

C'è un errore nella funzione del_link perché naturalmetne a quel punto il programma non ha più librerie che mancano, domani sistemo. Metto parametri da passare da linea di comando. Anche se è sforzo inutile :)

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current

Messaggio da conraid »

come detto è uno sforzo inutile, alla fine basta il primo script, al limite con un ciclo for, ma comunque...

Codice: Seleziona tutto

#!/bin/sh

set -eu

if [[ $EUID -ne 0 ]]; then
  echo "This script must be run as root" 1>&2
  exit
fi

if [ -e /usr/lib64 ]; then
  LIBDIRSUFFIX="64"
else
  LIBDIRSUFFIX=""
fi

if ! [ -x /usr/bin/libreoffice -o -x /usr/bin/soffice ]; then
  echo "LIBREOFFICE is not installed"
  exit
fi

BVER=$(echo /var/lib/pkgtools/packages/boost-* | cut -d/ -f6 | cut -d- -f2)
if [ -z $BVER ]; then
  echo "BOOST is not installed"
  exit
fi

_usage() {
  echo "Usage: $0 COMMAND"
  echo "COMMAND:"
  echo "  -m | --make    make link"
  echo "  -d | --delete    delete link"
  echo "  -h | --help    this help"
}

make_link() {
  REQBV=$(ldd /usr/lib$LIBDIRSUFFIX/libreoffice/program/soffice.bin | grep "not found" | grep boost |  cut -d" " -f1 | cut -d. -f3- | uniq)
  if [ -z $REQBV ]; then
    echo "BOOST REQUEST is NULL."
    echo "Probably all right and you do not have to do anything"
    exit
  fi
  
  echo "BOOST REQUEST is $REQBV It's correct? [Y/n]"
  read CONFIRM
  
  if echo "$CONFIRM" | grep -iq "^n" ;then
    exit
  fi

  cd /usr/lib$LIBDIRSUFFIX

  for i in libboost_*$BVER; do
    ln -s $i ${i%%.*}.so.$REQBV
  done
}

del_link() {
  REQBV=$(ls -l /usr/lib64/libboost_system.so.* | grep ^l | cut -d" " -f12 | cut -d/ -f4- | cut -d. -f3-)
  
  echo "DELETE $REQBV link boost version. It's correct? [Y/n]"
  read CONFIRM
  
  if echo "$CONFIRM" | grep -iq "^n" ;then
    exit
  fi

  cd /usr/lib$LIBDIRSUFFIX
  rm libboost_*.so.$REQBV
}

if [ $# != 1 ]; then
  _usage
  exit
fi

case ${1:-""} in
  -m | --make )
    make_link
    ;;
  -d | --delete )
    del_link
    ;;
  -h | --help )
    _usage
    exit
    ;;
  * )
    _usage
    exit 1
esac

è fatto al volo, spero non ci sia errori, l'ho provato e funziona.

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4616
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current

Messaggio da aschenaz »

=D>
Grande, Corrado, funziona perfettamente! :)
Grazie!

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2744
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.6.5
Desktop: lxde
Località: Pisa
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current [RISOLTO]

Messaggio da ponce »

giusto per riportare che Alien Bob ha aggiornato poco fa libreoffice per current alla versione 6.1.0.

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4616
Iscritto il: mer 28 lug 2004, 0:00
Nome Cognome: Nino
Slackware: current
Kernel: 4.14.x
Desktop: KDE
Località: Reggio Calabria
Contatta:

Re: Problemi con libreoffice dopo ultimo aggiornamento a current [RISOLTO]

Messaggio da aschenaz »

:thumbright: Grazie per la segnalazione, Matteo!
Aggiornato.

Rispondi