[RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
rik70
Iper Master
Iper Master
Messaggi: 2056
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 5.1.x
Desktop: Xfce 4.12
Distribuzione: archlinux

[RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda rik70 » mer mar 27, 2019 17:46

Mi sa che è un argomento che è stato già trattato, ma a cosa è dovuto questo errore?

Mi è capitato in 2 casi:

- compilando freetype dopo aver disinstallato il pacchetto originario;
- compilando il pacchetto del ramo SBo-git/current xf86-video-qxl con l'opzione '--enable-xspice=yes'.
L'errore è questo(nel caso di freetype il file è /usr/lib64/libfreetype.la):

Codice: Seleziona tutto

/usr/bin/grep: /usr/lib64/libopus.la: No such file or directory
/usr/bin/sed: can't read /usr/lib64/libopus.la: No such file or directory
libtool:   error: '/usr/lib64/libopus.la' is not a valid libtool archive
make[3]: *** [Makefile:689: spiceqxl_drv.la] Error 1
make[3]: uscita dalla directory "/tmp/SBo/xf86-video-qxl-0.1.5/src"
make[2]: *** [Makefile:948: all-recursive] Error 1
make[2]: uscita dalla directory "/tmp/SBo/xf86-video-qxl-0.1.5/src"
make[1]: *** [Makefile:457: all-recursive] Error 1
make[1]: uscita dalla directory "/tmp/SBo/xf86-video-qxl-0.1.5"
make: *** [Makefile:389: all] Error 2


Grazie in anticipo.
Ultima modifica di rik70 il mer mar 27, 2019 18:29, modificato 1 volta in totale.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2579
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.1.4
Desktop: lxde
Località: Pisa
Contatta:

Re: Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda ponce » mer mar 27, 2019 17:52

probabilmente e' dovuto al fatto che stai usando current e che in passato hai compilato qualcosa che si e' linkato a dei file *.la che adesso non ci sono piu'

Codice: Seleziona tutto

Thu Apr 19 01:04:06 UTC 2018
Hi folks, and welcome to the third ever Slackware Mass Rebuild (and the
longest ChangeLog entry in project history). There were two primary
motivations for rebuilding everything in the main tree. The first was to
switch to the new C++ ABI. The second was to get rid of all the .la files
in the LD_LIBRARY_PATH. Really, having .la files installed has been mostly
obsolete since things began to use pkg-config instead, but it's not easy
to get rid of them unless you do it all at once. If you just take them out
of one package, any other packages containing .la files that refer to the
removed ones will be broken. We've removed a few here and there before
(and then handled any packages that had referred to them with a rebuild),
but it was time to finally remove all the ones in /lib{,64} and
/usr/lib{,64}. One of the reasons that this really needed to happen is that
many projects are starting to migrate to build systems other than autotools,
and those systems do not generate .la files. So if we didn't get rid of them
now, we might end up in a situation later on where they are being removed
by upstream and then we would have to chase down the dependency breakage and
recompile (possibly many) other packages. The .la files that are outside of
the LD_LIBRARY_PATH were not removed (and shouldn't be) - those ones are
often used by the lt_dlopen() function to load plugins and removing those
ones can break things. But those ones don't cause problems... they aren't
likely to try to infect .la files produced by other packages.
IMPORTANT NOTE: If you have any third party or other packages installed on
your system that don't come with Slackware, and those packages have installed
any .la files, it is very likely that they refer to some .la files which we
have just removed, and that trying to compile against these packages will no
longer work. Luckily, the solution is simple: remove them. This command will
remove any stale .la files from the LD_LIBRARY_PATH:
rm /{,usr/}lib{,64}/*.la

puo' darsi che ti basti dare l'ultimo comando indicato nel ChangeLog: io per sicurezza dopo quell'aggiornamento ho ricompilato tutti i pacchetti di terze parti e non mi si e' mai presentato il problema.

rik70
Iper Master
Iper Master
Messaggi: 2056
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 5.1.x
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda rik70 » mer mar 27, 2019 18:05

Grazie.
Ho questo:

Codice: Seleziona tutto

var/log//packages/./spice-0.14.1-x86_64-1ponce:usr/lib64/libspice-server.la

Dici che devo/posso modificare lo SlackBuild?

P.s.
Con freetype mi capita con la 14.2

rik70
Iper Master
Iper Master
Messaggi: 2056
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 5.1.x
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda rik70 » mer mar 27, 2019 18:15

P.s.
Ma rimaniamo in current. Durante la compilazione del pacchetto spice appare:

Codice: Seleziona tutto

libtool: install: /usr/bin/ginstall -c .libs/libspice-server.lai /tmp/SBo/package-spice/usr/lib64/libspice-server.la
libtool: warning: remember to run 'libtool --finish /usr/lib64'

rik70
Iper Master
Iper Master
Messaggi: 2056
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 5.1.x
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda rik70 » mer mar 27, 2019 18:28

Ok risolto modificando lo spice.SlackBuild aggiungendo dopo

Codice: Seleziona tutto

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

Codice: Seleziona tutto

rm -v $PKG/usr/lib64/libspice-server.la || exit


Poi ho ricompilato i pacchetti che dipendevano da spice, compreso xf86-video-qxl:

Codice: Seleziona tutto

Done building package for xf86-video-qxl.
Built package: xf86-video-qxl-0.1.5-x86_64-1ponce.tgz

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2579
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.1.4
Desktop: lxde
Località: Pisa
Contatta:

Re: Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda ponce » mer mar 27, 2019 18:32

rik70 ha scritto:Grazie.
Ho questo:

Codice: Seleziona tutto

var/log//packages/./spice-0.14.1-x86_64-1ponce:usr/lib64/libspice-server.la

Dici che devo/posso modificare lo SlackBuild?

no, forse mi sono spiegato male: il problema non e' generato dallo SlackBuild di spice, ce l'hai perche' in passato hai compilato spice e questo ha utilizzato /usr/lib64/libopus.la, dovresti poterlo verificare nel file /usr/lib64/libspice-server.la.
se rimuovi spice, lo ricompili e il file /usr/lib64/libopus.la non e' nel sistema, quando verra' generato il file /usr/lib64/libspice-server.la non ci saranno riferimenti a /usr/lib64/libopus.la e non dovresti aver problemi a compilare xf86-video-qxl.
poi si, in futuro, quando su SBo metteremo online gli SlackBuild per la 15.0, modificheremo ogni SlackBuild perche' includa una riga simile a questa

Codice: Seleziona tutto

# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la

ma per ora non ce n'e' bisogno.
Con freetype mi capita con la 14.2

quello e' strano, forse c'e' qualche libreria, dipendenza di freetype, che non fornisce piu' qualche file *.la.
rik70 ha scritto:P.s.
Ma rimaniamo in current. Durante la compilazione del pacchetto spice appare:

Codice: Seleziona tutto

libtool: install: /usr/bin/ginstall -c .libs/libspice-server.lai /tmp/SBo/package-spice/usr/lib64/libspice-server.la
libtool: warning: remember to run 'libtool --finish /usr/lib64'

questo e' un warning ininfluente, puoi ignorarlo tranquillamente visto che stai facendo un pacchetto.

rik70 ha scritto:Ok risolto modificando lo spice.SlackBuild aggiungendo dopo

Codice: Seleziona tutto

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

Codice: Seleziona tutto

rm -v $PKG/usr/lib64/libspice-server.la || exit

in realta' credo che non ce ne dovrebbe essere bisogno, sarebbe stato sufficiente ricompilare spice, come scrivevo sopra.

rik70
Iper Master
Iper Master
Messaggi: 2056
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 5.1.x
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: [RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda rik70 » mer mar 27, 2019 18:38

ponce ha scritto:in realta' credo che non ce ne dovrebbe essere bisogno, sarebbe stato sufficiente ricompilare spice, come scrivevo sopra.
Ah, ok troppa fretta da parte mia :)
Grazie.

Probabilmente ho prima compilato spice dal repo SBo-14.2 e poi l'ho ricompilato, reinstallandolo sopra, dal ramo -git/current.

Ora voglio vedere se riesco a uscirne anche dalla faccenda 'freetype + 14.2'

Edit:
no, forse mi sono spiegato male: il problema non e' generato dallo SlackBuild di spice, ce l'hai perche' in passato hai compilato spice e questo ha utilizzato /usr/lib64/libopus.la, dovresti poterlo verificare nel file /usr/lib64/libspice-server.la.
Hai ragione, ho fatto casini io. Non mi ero accorto che su current c'era già il pacchetto opus e l'avevo sovrascritto con quello SBo-14.2.
Ultima modifica di rik70 il mer mar 27, 2019 18:44, modificato 1 volta in totale.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2579
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.1.4
Desktop: lxde
Località: Pisa
Contatta:

Re: [RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda ponce » mer mar 27, 2019 18:41

...e li' che errore ti da quando compili freetype?

rik70
Iper Master
Iper Master
Messaggi: 2056
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 5.1.x
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: [RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda rik70 » mer mar 27, 2019 18:47

ponce ha scritto:...e li' che errore ti da quando compili freetype?

Codice: Seleziona tutto

/usr/bin/grep: /usr/lib64/libfreetype.la: No such file or directory
/usr/bin/sed: can't read /usr/lib64/libfreetype.la: No such file or directory
libtool:   error: '/usr/lib64/libfreetype.la' is not a valid libtool archive
config.mk:55: recipe for target '/tmp/freetype-2.6.3/objs/libfreetype.la' failed
make: *** [/tmp/freetype-2.6.3/objs/libfreetype.la] Error 1
./builds/unix/libtool --mode=link gcc -o /tmp/freetype-2.6.3/objs/libfreetype.la  /tmp/freetype-2.6.3/objs/ftsystem.lo /tmp/freetype-2.6.3/objs/ftdebug.lo /tmp/freetype-2.6.3/objs/ftinit.lo /tmp/freetype-2.6.3/objs/ftbase.lo /tmp/freetype-2.6.3/objs/ftbbox.lo /tmp/freetype-2.6.3/objs/ftbdf.lo /tmp/freetype-2.6.3/objs/ftbitmap.lo /tmp/freetype-2.6.3/objs/ftcid.lo /tmp/freetype-2.6.3/objs/ftfntfmt.lo /tmp/freetype-2.6.3/objs/ftfstype.lo /tmp/freetype-2.6.3/objs/ftgasp.lo /tmp/freetype-2.6.3/objs/ftglyph.lo /tmp/freetype-2.6.3/objs/ftgxval.lo /tmp/freetype-2.6.3/objs/ftlcdfil.lo /tmp/freetype-2.6.3/objs/ftmm.lo /tmp/freetype-2.6.3/objs/ftotval.lo /tmp/freetype-2.6.3/objs/ftpatent.lo /tmp/freetype-2.6.3/objs/ftpfr.lo /tmp/freetype-2.6.3/objs/ftstroke.lo /tmp/freetype-2.6.3/objs/ftsynth.lo /tmp/freetype-2.6.3/objs/fttype1.lo /tmp/freetype-2.6.3/objs/ftwinfnt.lo /tmp/freetype-2.6.3/objs/truetype.lo /tmp/freetype-2.6.3/objs/type1.lo /tmp/freetype-2.6.3/objs/cff.lo /tmp/freetype-2.6.3/objs/type1cid.lo /tmp/freetype-2.6.3/objs/pfr.lo /tmp/freetype-2.6.3/objs/type42.lo /tmp/freetype-2.6.3/objs/winfnt.lo /tmp/freetype-2.6.3/objs/pcf.lo /tmp/freetype-2.6.3/objs/bdf.lo /tmp/freetype-2.6.3/objs/sfnt.lo /tmp/freetype-2.6.3/objs/autofit.lo /tmp/freetype-2.6.3/objs/pshinter.lo /tmp/freetype-2.6.3/objs/raster.lo /tmp/freetype-2.6.3/objs/smooth.lo /tmp/freetype-2.6.3/objs/ftcache.lo /tmp/freetype-2.6.3/objs/gxvalid.lo /tmp/freetype-2.6.3/objs/ftgzip.lo /tmp/freetype-2.6.3/objs/ftlzw.lo /tmp/freetype-2.6.3/objs/ftbzip2.lo /tmp/freetype-2.6.3/objs/otvalid.lo /tmp/freetype-2.6.3/objs/psaux.lo /tmp/freetype-2.6.3/objs/psnames.lo -rpath /usr/lib64 -version-info 18:3:12 -lz -lbz2 -lpng16 -lharfbuzz -no-undefined
/usr/bin/grep: /usr/lib64/libfreetype.la: No such file or directory
/usr/bin/sed: can't read /usr/lib64/libfreetype.la: No such file or directory
libtool:   error: '/usr/lib64/libfreetype.la' is not a valid libtool archive
config.mk:55: recipe for target '/tmp/freetype-2.6.3/objs/libfreetype.la' failed
make: *** [/tmp/freetype-2.6.3/objs/libfreetype.la] Error 1

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2579
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.1.4
Desktop: lxde
Località: Pisa
Contatta:

Re: [RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda ponce » mer mar 27, 2019 18:56

da una prova empirica sembra che freetype sia particolarmente scemo e faccia riferimento a se stesso (comunque quello e' solo un file di testo innocuo), quindi dovrebbe essere sufficiente averlo installato mentre lo ricompili.

rik70
Iper Master
Iper Master
Messaggi: 2056
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 5.1.x
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: [RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda rik70 » mer mar 27, 2019 19:04

ponce ha scritto:da una prova empirica sembra che freetype sia particolarmente scemo e faccia riferimento a se stesso (comunque quello e' solo un file di testo innocuo), quindi dovrebbe essere sufficiente averlo installato mentre lo ricompili.
Infatti...
la cosa singolare è che l'errore non si presenta se compilo freetype 2.10.0.

Diversamente dal caso riguardante la current, dove se prestavo attenzione al log dell'errore forse capivo che il problema era il pacchetto opus,
perché lì cerca una libreria che dovrebbe installare lui stesso?

Mi piacerebbe scoprire quale accrocchio ha usato Pat per compilare il pacchetto :)

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2579
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.1.4
Desktop: lxde
Località: Pisa
Contatta:

Re: [RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda ponce » mer mar 27, 2019 19:13

magari e' un problema appunto di quella versione e poi l'hanno corretto.

rik70
Iper Master
Iper Master
Messaggi: 2056
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.2
Kernel: 5.1.x
Desktop: Xfce 4.12
Distribuzione: archlinux

Re: [RISOLTO]Errore compilazione: "libtool: error: /usr/lib64/**.la is not a valid libtool archive"

Messaggioda rik70 » gio mar 28, 2019 9:55

ponce ha scritto:magari e' un problema appunto di quella versione e poi l'hanno corretto.

In effetti è strano... però sembra più un problema legato alla distro.

Su current ad esempio non da errore, stessa cosa su 14.1 - però arch i686.

L'errore si presenta anche con altre versioni di freetype, esempio la 2.7 e la 2.5.

Boh... lasciamo irrisolto il problema.