Pagina 1 di 1

Project ERROR: Qt 5.2 or greater is required

Inviato: mer 19 feb 2020, 20:11
da gian_d
Questo messaggio di errore è restituito dalla compilazione via slackbuild di decklink-sdk (dipendenza opzionale di ffmpeg) dopo l'aggiornamento di Qt5 alla versione 5.13.2, ma credo si abbia lo stesso risultato anche con versioni meno recenti a partire da Qt 5.10.0 in su

In realtà l'errore è causato da qmake se nel sorgente del software da compilare è contenuta la chiamata alla funzione lessThan(QT_VERSION, 5.x ), funzione non valida per versioni di Qt5 uguali o superiori a 5.10.0 (rif: https://bugreports.qt.io/browse/QTBUG-63325 )

Io uso la versione 10.11.1 di decklink-sdk installata con lo slackbuild del repository di Ponce e ho risolto applicando la seguente patch:

Codice: Seleziona tutto

--- "Blackmagic DeckLink SDK 10.11.1/Linux/Samples/H265TestEncoder/H265TestEncoder.pro"	2018-07-05 14:02:16.000000000 +0200
+++ "Blackmagic DeckLink SDK-fixed 10.11.1/Linux/Samples/H265TestEncoder/H265TestEncoder.pro"	2020-02-19 19:26:06.989562839 +0100
@@ -30,7 +30,7 @@
                src\
                ../../include
 
-lessThan(QT_VERSION, 5.2) {
+versionAtLeast($$QT_VERSION, 5.2){
 	error("Qt 5.2 or greater is required.")
 }
 
Lo slackbuild del repository è predisposto per l'installazione di una versione meno recente di Decklink SDK, in ogni modo il concetto non cambia. La compilazione funziona finché si usa una versione di Qt5 precedente alla 5.10.0 mentre va in errore se si installa il pacchetto attualmente rilasciato con la current. Perciò è sufficiente inserire la chiamata alla patch nel codice dello slackbuild.

Naturalmente il problema potrebbe presentarsi anche con la compilazione di software di terze parti i cui sorgenti non sono aggiornati per versioni di Qt5 uguali o superiori a 5.10.0. Ho visto che in rete ci sono segnalazioni relative a questo problema, più o meno recenti. Qualora dovesse succedere il sorgente va patchato sostituendo la funzione versionAtLeast() al posto di lessThan()

Re: Project ERROR: Qt 5.2 or greater is required

Inviato: mer 19 feb 2020, 20:42
da ponce
ma hai una scheda di acquisizione blackmagic?

comunque ti conviene segnalarlo direttamente al maintainer di decklink-sdk, perche' molto presto sara' aggiornato qt5 anche per la 14.2 (alla 5.12.x, probabilmente).

Re: Project ERROR: Qt 5.2 or greater is required

Inviato: mer 19 feb 2020, 21:52
da gian_d
No :-D
Diversi pacchetti soprattutto della categoria del multimediale sono installati finché non mi prendo la briga di leggere a che servono, allora nel dubbio li installo con l'intento di documentarmi prima o poi. Cosa che faccio molto raramente per pigrizia o per tempo e soprattutto perché in fatto di multimediale sono un emerito ignorante dato che poi mi limito poi a ritoccare file video con avidemux e file audio con audacity.
Però proprio a causa della mia ignoranza installo anche tutte le dipendenze opzionali per pacchetti come vlc o librerie base come ffmpeg contando sul fatto che potrebbero aggiungere funzionalità o meno a questo software.

Dalla tua obiezione ora capisco che non mi serve a un piffero. E con questo mi spiego perché il sito di Blackmagick vende hardware. Va be', fatti due risate ma abbi pietà e non infierire su un povero vecchio utonto :-D

Re: Project ERROR: Qt 5.2 or greater is required

Inviato: mer 19 feb 2020, 21:56
da ponce
comunque non era un'obiezione: lo chiedevo perche' io per esempio ne ho una e l'ho usata per acquisire vecchie videocassette (anche se ha una grossa varieta' di ingressi anche per altro). :)

Re: Project ERROR: Qt 5.2 or greater is required

Inviato: mer 19 feb 2020, 22:47
da gian_d
Una dozina di anni fa mi sarebbe interessato perché era in progetto, ho ancora un serie di videocassette conservate, ma nel frattempo non ho più il lettore di videocassette e penso che queste siano ormai rovinate dal tempo. Peraltro se dovessi installare una scheda di acquisizione dovrei pagare il canone RAI, che invece non pago perché non ho nessun apparecchio TV e nessun dispositivo abilitato a ricevere/acquisire segnali TV.

Re: Project ERROR: Qt 5.2 or greater is required

Inviato: gio 20 feb 2020, 5:35
da ponce
il modello di scheda che ho io non ha un sintonizzatore integrato. ;)