sudo_pam non dipende da pam

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5305
Iscritto il: ven 2 giu 2006, 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

sudo_pam non dipende da pam

Messaggio da ZeroUno »

Ho fatto la cavolata...
upgrade di tutti i pacchetti a pam prima di installare il pacchetto pam.
Accidentalmente chiusa la shell di root, ovviamente su - e login come root in console o ssh sono negati.
Ultimo tentativo prima di rebootare in rescue mode.
$ sudo -i
ed è andata!!!!

Codice: Seleziona tutto

# ldd /usr/bin/sudo
        linux-vdso.so.1 (0x00007ffff2740000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00007fae93bdd000)
        libsudo_util.so.0 => /usr/libexec/sudo/libsudo_util.so.0 (0x00007fae93bc3000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fae93ba1000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fae93b9c000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fae939b7000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fae93c7a000)
gli manca la dipendenza da libpam.so

dallo slackbuild

Codice: Seleziona tutto

# Choose correct options depending on whether PAM is installed:
if [ -L /lib${LIBDIRSUFFIX}/libpam.so.? ]; then
  PAM_OPTIONS="--enable-pam-session --with-pam=yes"


Ho provato anche su una macchina redhat ed anche lì ldd non dà libpam.so come dipendenza.

E' normale?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

rik70
Iper Master
Iper Master
Messaggi: 2157
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 5.6.x-ck1
Desktop: Xfce 4.14
Distribuzione: Arch Linux

Re: sudo_pam non dipende da pam

Messaggio da rik70 »

Sì è normale.
O almeno, è così anche in ArchLinux.

Rispondi