errore compilazione blender su current

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 172
Iscritto il: mar 8 set 2009, 11:39
Slackware: current
Località: Vinci -FI-

errore compilazione blender su current

Messaggio da dafrasaga »

Ciao a tutti,
da qualche giorno non riescio a compilare Blender in quando mi da questo errore:

Codice: Seleziona tutto

-- Installing: /tmp/SBo/package-blender/usr/share/blender/2.82/datafiles/studiolights/matcap/jade.exr
-- Installing: /tmp/SBo/package-blender/usr/share/blender/2.82/datafiles/studiolights/matcap/check_rim_dark.exr
build/bin/blender: error while loading shared libraries: libGLEW.so.2.1: cannot open shared object file: No such file or directory
  executing: build/bin/blender --help
Traceback (most recent call last):
  File "./doc/manpage/blender.1.py", line 55, in <module>
    blender_help = subprocess.run(
  File "/usr/lib64/python3.8/subprocess.py", line 512, in run
    raise CalledProcessError(retcode, process.args,
subprocess.CalledProcessError: Command '['build/bin/blender', '--help']' returned non-zero exit status 127.

Blender:
Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

(Y)es to continue, (N)o to abort, (R)etry the build?: 
la compilazione va tutta bene.. mi sembra che l'errore sia solo quando installa i files..

La libreria di GLEW installata è la

Codice: Seleziona tutto

root@darkstar:/home/gabriele$ pkg-config --modversion glew
2.2.0
Idee??

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2768
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: errore compilazione blender su current

Messaggio da ponce »

credo che tu debba ricompilare anche tutte le dipendenze di Blender.

dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 172
Iscritto il: mar 8 set 2009, 11:39
Slackware: current
Località: Vinci -FI-

Re: errore compilazione blender su current

Messaggio da dafrasaga »

l'avevo fatto .. ma niente .. l'unica cosa è che la dipendenza di opencv la installo dai pacchetti di alienbob ktown invece che da slackbuild.. riproverò

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2768
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: errore compilazione blender su current

Messaggio da ponce »

dafrasaga ha scritto:
gio 9 apr 2020, 11:07
l'unica cosa è che la dipendenza di opencv la installo dai pacchetti di alienbob ktown invece che da slackbuild
probabilmente devi ricompilare anche quello

erio
Linux 4.x
Linux 4.x
Messaggi: 1212
Iscritto il: ven 9 ott 2009, 19:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: errore compilazione blender su current

Messaggio da erio »

scrivo perche' ho compilato blender su una current aggiornata, sbopkg via blender.sqf ha compilato tutto.opencv la versione di ktown e' diversa da sbopkg e pesa poco, non so se questo influisce sulla riuscita dello slackbuild.

idefix
Linux 1.x
Linux 1.x
Messaggi: 192
Iscritto il: gio 19 giu 2008, 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Kernel: 4.4.19
Desktop: tde 14.0.3

Re: errore compilazione blender su current

Messaggio da idefix »

si potrebbe usare un binario gia pronto. magari semplifica un po le cose.

http://www.lazytux.it/release/slackware ... pimage.txz

io non lo uso quindi non so se ha tutti i requisiti.

dafrasaga
Linux 1.x
Linux 1.x
Messaggi: 172
Iscritto il: mar 8 set 2009, 11:39
Slackware: current
Località: Vinci -FI-

Re: errore compilazione blender su current

Messaggio da dafrasaga »

Ciao, anche io ho optato per la versione compilata da https://www.blender.org/download/...( non mi ero accorto che ci fosse :shock: )... ho qualche problema di freeze che ancora non ho approfondito..

idefix
Linux 1.x
Linux 1.x
Messaggi: 192
Iscritto il: gio 19 giu 2008, 1:48
Nome Cognome: stefano
Slackware: slack64-14.2
Kernel: 4.4.19
Desktop: tde 14.0.3

Re: errore compilazione blender su current

Messaggio da idefix »

io non usandolo non saprei, magari non va d'accordo con
qualche altro soft, forse i driver video. come magari
necessita di qualche libreria che danno per scontata...
puo essere utile lanciarlo da terminale e vederne l'output.

Avatar utente
414N
Iper Master
Iper Master
Messaggi: 2902
Iscritto il: mer 13 feb 2008, 16:19
Slackware: 14.2
Kernel: 4.4.19
Desktop: KDE4
Località: Bulagna
Contatta:

Re: errore compilazione blender su current

Messaggio da 414N »

Anche io ho riscontrato diversi problemi nella build da sorgenti, che avvengono nella fase di linking finale del binario.
La maggior parte dei casi che ho incontrato riguardano problemi di linking verso opencv4, dove magari la libreria .so di opencv ha subito un bump di versione ma una delle dipendenze transitive di blender punta ancora alla versione precedente.
Le ultime due volte che mi è successo ho verificato che si trattava sempre della libreria "openimageio" rimasta indietro rispetto alla versione di opencv installata a sistema.
Puoi aiutarti ad individuare "rotture di linking" mediante lo script orphans di GrapefruiTgirl: LINK su LQ.

Rispondi