Pagina 1 di 1

[risolto] emulatori terminale non funzionanti dopo aggiornamento current con slackpkg

Inviato: mer 22 lug 2020, 12:07
da red
Ciao a tutti,
normalmente tengo aggiornata la mia Current64 con slackpkg con in blacklist i pacchetti del kernel.

Solita procedura:
update
upgrade slackpkg
install-new
upgrade-all
clean-system

Mi sono recentemente accorto che a parte konsole e xterm, gli altri emulatori non funzionano, in particolare rxvt e aterm.
Avete idea di quale possa essere il problema?

Grazie!

[edit] Dimenticavo: in /usr/bin non ci sono gli eseguibili, anche dopo aver ricompilato ed installato il relativo slackbuild

Re: emulatori terminale non funzionanti dopo aggiornamento current con slackpkg

Inviato: mer 22 lug 2020, 14:05
da ponce
ciao red,

puoi provare a vedere quello che succede se provi a lanciarli da un'altro emulatore di terminale: prova ad aprire un xterm e poi lancia il comando

Codice: Seleziona tutto

urxvt
(questo e' il nome del binario di rxvt-unicode, incluso in Slackware current) che output ti restituisce?

aterm non e' compreso proprio in current e per installarlo devi prendere lo script su SBo e aggiungere questa riga allo SlackBuild, prima della linea che inizia con "CFLAGS"

Codice: Seleziona tutto

sed -i 's%<sys/stropts.h>%<sys/ioctl.h>%;s%I_PUSH,%TIOCPKT,%' src/command.c

Re: emulatori terminale non funzionanti dopo aggiornamento current con slackpkg

Inviato: mer 22 lug 2020, 14:34
da red
In effetti aterm è andato a posto con quella modifica.
rxvt invece non funzionava in alcun modo.
Ho iniziato a pensare fosse andato storto qualcosa nell'aggiornamento dei pacchetti.
Ho finito giusto ora di reinstallare gli ultimi aggiornamenti e stavo proprio per scrivere che adesso rxvt funziona.
Con la tua dritta sullo slackbuilds ora è a posto anche aterm, quindi risolto!

Grazie per le info :D