Pagina 1 di 1

Current to stable to unknown..

Inviato: gio 1 apr 2021, 22:06
da guybrush.d
Ciao a tutti,
è un po' che non scrivo sul forum, quando la famiglia si "allarga" è difficile mantenere attivi gli hobbies...
Comunque, visto il pupox nell'ultimo upgrade del pc ho deciso di prendere un laptop (ASUS ROG), la prima
cosa che ho fatto è stato partizionare ed inserire la penna con slackware 14.2, installazione come al solito
senza problemi, ho tribolato un po' a causa di elilo ma alla fine sono riuscito ad avere un' installazione completa
sul laptop. Nel momento in cui ho riavviato però ottengo un meraviglioso kernel panic, probabilmente il kernel
usato ha qualche driver che non supporta l'hardware del portatile, per cui sono passato a current e l'installazione
funziona senza problemi, sto scrivendo da firefox al momento, il problema che ho riguarda i pacchetti ho convertito
il sistema al multilib di AlienBob con slackpkg e configurato i repository, utilizzo xfce per cui le qt mi servono solo
per alcune app, che tra l'altro cerco di usare con appimage per avere le versioni aggiornate, quella che mi sta dando
grossi problemi è tellico, che non riesco a far funzionare, ho provato a generare un appimage ma non ci sono riuscito,
per cui, visto che ho seguito i passi della guida per convertire il sistema in multilib, ho wine che funziona senza problemi,
non riesco a capire perchè quando lancio alcune applicazioni a 32 bit mi viene detto che il binario a 32 bit non è supportato,
e non riesco ad installare le qt4 su current per cui vorrei ritornare alla 14.2, come posso risolvere? Come faccio il downgrade
del sistema senza incasinare tutto? Oppure Come installo exnovo la 14.2 con un kernel aggiornato? Oppure come resto a current
sistemando il problema delle multilib ed installando le qt4? Cosa mi conviene fare? A voi le risposte e grazie per l'aiuto!
PS:: Non vorrei installare una utuntu o debian distro perchè alla fine i pacchetti che uso sono limitati e poi posso sempre usare
gli slackbuid o le appimage...ciao

Re: Current to stable to unknown..

Inviato: ven 2 apr 2021, 11:13
da ponce
congratulazioni per il pupo!

tellico qui ha compilato, aggiornandolo alla versione 3.4, con queste modifiche allo SlackBuild che e' su SBo

Codice: Seleziona tutto

diff --git a/office/tellico/tellico.SlackBuild b/office/tellico/tellico.SlackBuild
index 87b35d67d7..c08442cc47 100644
--- a/office/tellico/tellico.SlackBuild
+++ b/office/tellico/tellico.SlackBuild
@@ -27,7 +27,7 @@
 # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
 
 PRGNAM=tellico
-VERSION=${VERSION:-2.3.12}
+VERSION=${VERSION:-3.4}
 BUILD=${BUILD:-1}
 TAG=${TAG:-_SBo}
 
@@ -64,7 +64,7 @@ rm -rf $PKG
 mkdir -p $TMP $PKG $OUTPUT
 rm -rf $TMP/$PRGNAM-$VERSION
 cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
 cd $PRGNAM-$VERSION
 chown -R root:root .
 find -L . \
@@ -92,7 +92,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
   | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
 
 mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COMPILING COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COMPILING COPYING ChangeLog README.md $PKG/usr/doc/$PRGNAM-$VERSION
 cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
 
 mkdir $PKG/install
diff --git a/office/tellico/tellico.info b/office/tellico/tellico.info
index 0e7fdd0310..bb95fec8cb 100644
--- a/office/tellico/tellico.info
+++ b/office/tellico/tellico.info
@@ -1,8 +1,8 @@
 PRGNAM="tellico"
-VERSION="2.3.12"
+VERSION="3.4"
 HOMEPAGE="https://tellico-project.org/"
-DOWNLOAD="https://tellico-project.org/files/tellico-2.3.12.tar.bz2"
-MD5SUM="607e94e0141aadf741aab7fa6db15a5c"
+DOWNLOAD="https://tellico-project.org/files/tellico-3.4.tar.xz"
+MD5SUM="f46ab546ac335a9107c2130faea1fb9d"
 DOWNLOAD_x86_64=""
 MD5SUM_x86_64=""
 REQUIRES=""
per wine e le applicazione a 32 bit non ho idea, forse potresti incollare gli errori che ti danno le applicazioni (quali sono)?

per quel che riguarda le qt4 non sono piu' supportate da tempo, quindi secondo me ti conviene trovare nuove versioni delle applicazioni che usi che utilizzino le qt5.

Re: Current to stable to unknown..

Inviato: ven 2 apr 2021, 14:03
da guybrush.d
Grazie Ponce,
stamattina ero quasi tentato di installare un'altra distro e tenere slack solo sul nas! Poi ci ho ripensato...Diciamo che addesso provo ad andare avanti cosi e
installerò le applicazioni che mi servono passo passo, prima o poi finiranno...Ora provo lo slackbuild di tellico, grazie intanto anche per il pupo...