Pagina 1 di 1

problema con la tastiera [risolto]

Inviato: dom 21 ago 2022, 19:52
da Rama
di punto in bianco se premo il tasto del punto interrogativo salta fuori _
< al posto del punto e virgola, ecc...
in Impostazioni di KDE la mappatura e' IT l'hardware 101 tasti generic, la stessa della Debian che non mi da' noie
che fare -punto interregativo

Re: problema con la tastiera

Inviato: dom 21 ago 2022, 21:07
da erio
mappatura inglese prova questo : setxkbmap it non so se ti funziona la mia e' inglese

Re: problema con la tastiera

Inviato: dom 21 ago 2022, 22:52
da Rama
risolto, grazie: ?
però non capisco perché, un minuto prima era a posto un minuto dopo no;

Re: problema con la tastiera [risolto]

Inviato: mar 23 ago 2022, 12:50
da gian_d
Stranissimo, proprio adesso mi è successa la stessa cosa!

Re: problema con la tastiera [risolto]

Inviato: mar 23 ago 2022, 16:00
da gian_d
Ops... scoperto l'inghippo, era una cavolata che avevo combinato io: stamattina avevo disattivato alcuni servizi in background e tra questi anche il demone della tastiera. A quanto pare disabilitando questo servizio, ogni volta che si accede all'account viene abilitata la tastiera inglese.

Re: problema con la tastiera [risolto]

Inviato: mer 31 ago 2022, 17:15
da Rama
ah, ecco, oggi è successo anche a me;
per non avere attivo un demone inutile ho messo setxkbmap it in rc.local;

Re: problema con la tastiera [risolto]

Inviato: mer 31 ago 2022, 18:57
da gian_d
Aspe', non sono sicuro di aver capito:
1. hai impostato setxkbmap it in rc.local
2. hai disabilitato il demone della tastiera di KDE

In questo modo viene comunque abilitata la tastiera italiana. Ho capito bene?

Re: problema con la tastiera [risolto]

Inviato: gio 1 set 2022, 16:20
da Rama
sì, ma non funziona;
non capisco il perché, altri comandi in rc.local vengono eseguiti;

Re: problema con la tastiera [risolto]

Inviato: gio 1 set 2022, 17:01
da gian_d
Ah, ecco. In effetti se tutto fila per il verso giusto non c'è gusto :-D

Re: problema con la tastiera [risolto]

Inviato: gio 1 set 2022, 17:13
da Rama
ho anche seguito la vecchia guida della mia defunta HP:

La tastiera italiana può essere impostata dal Centro di Controllo, in alternativa si può farlo editando (fate sempre una copia di backup, un errore in questi tipi di file può pregiudicare l'OS) il file /etc/X11/XF86Config e cambiando nella sezione Core keyboard's InputDevice section la riga
# Option "XkbLayout" "de"
in
Option "XkbLayout" "it"
inoltre nel file /etc/profile aggiungete o modificate LC_ALL in: LC_ALL="it_IT"
Per fare in modo che i programmi localizzati in italiano si servano della nostra lingua aggiungete, nello stesso file:
export LANG="it_IT@euro"
export CHARSET="iso8859-15"
poi in /etc/profile.d/lang.sh
export LANG=it_IT@euro
infine in /etc/profile.d/lang.csh modificate il setnev: setenv LANG it_IT
Inoltre, se non funziona il tasto "<>" decommentate
Option "XkbModel" "pc105" in XF86Config.

senza risultato;
visto che per mesi non ho avuto 'sto problema sarà colpa di qualche aggiornamento recente;

Re: problema con la tastiera [risolto]

Inviato: gio 1 set 2022, 19:06
da erio
vedi questo se vi e' utile: Per prima cosa viene italianizzato il sistema impostando la lingua nel file /etc/profile.d/lang.sh e viene impostata la mappatura della tastiera per xorg grazie ad una copia del file /usr/share/X11/xorg.conf.d/90-keyboard-layout.conf in /etc/X11/xorg.conf.d/ in cui viene sostituito il valore "us" con quello settato nella variabile lng.

Re: problema con la tastiera [risolto]

Inviato: gio 1 set 2022, 19:56
da Rama
/etc/profile.d/lang.sh l'avevo già fatto, modificati i due file contenuti in /xorg.conf.d vedrò al riavvio;
ma siamo solo in due ad avere questo problema?
...
stavolta è andata;

Re: problema con la tastiera [risolto]

Inviato: gio 1 set 2022, 23:03
da erio
questa modifica dovrebbe essere ad un livello piu basso quindi non modificabile....credo mo non sono sicuro.