[SOLVED] Scheda video NVIDIA GeForce GT 730

Usate questo forum per richieste di aiuto e consigli sull'hardware montato nelle vostre macchine con GNU/Linux Slackware.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata e la versione del Kernel. Questi dati aiutano le persone che possono rispondere.
2) Citare il tipo di hardware coinvolto in modo dettagliato.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT. Non usare termini gergali come procio, mobo e simili per identificare i componenti hardware.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 300
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

[SOLVED] Scheda video NVIDIA GeForce GT 730

Messaggio da Linpassion »

Dunque sul pc nuovo, anche se obsoleta ho la scheda grafica GeForce GT 730. La mia domanda daa nubbio è la seguente: devo comunque installare ugualmente i driver NVIDI anche se lspci mi restituisce
VGA compatible controller: NVIDIA Corporation GK208B [GeForce GT 730] (rev a1)
Se si, dopo il primo test fallimentare, perchè ho letto male la procedura, dovrei fare cosi:

- avviare da root senza X attivo;
- blacklistare i driver (qui ci devo lavorare perchè ancora non ho capito come si fa);
- compilare ed installare in sequenza
libdvdpau
nvidia-kernel
nvidia-driver.

Ultima cosa, senza fare tutta questa procedura, avviando blender e quindi attivare cuda, non me lo trova, ma poi ho visto che in slackbuild c'è pure cuda, devo compialre anche quello? Grazie.
Ultima modifica di Linpassion il mar 1 nov 2022, 11:03, modificato 1 volta in totale.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3634
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 15.0
Kernel: 5.15.38
Desktop: dwm

Re: Scheda video NVIDIA GeForce GT 730

Messaggio da joe »

Che versione di Slackware usi? Ancora quella in firma 14.2 o la 15.0?

In ogni caso sì se vuoi sfruttare la scheda video al meglio direi che ti convengono i driver closed. Se on fai nulla dovrebbe essere gestita dai nouveau open, che magari non sono neanche male per il tuo modello di scheda, se hanno limitazioni puoi scoprirlo solo informandoti sul loro sito che è tipo freedesktop qualcosa...

Se vuoi provare i driver nvidia, vai di slackbuild, per la tua scheda ci sono i due pacchetti "legacy470". Se usi sbopkg li puoi installare con quello altrimenti parti da qui:

https://slackbuilds.org/result/?search=470&sv=15.0

Leggi i README, prima installi la parte kernel poi la parte driver. Se sei sulla 15.0 dovrebbe essere anche un po' più semplice.

Se al momento hai installati dei pacchetti di vecchi driver nvidia ecc specificalo, solo tu puoi sapere la situazione di partenza del tuo sistema.

Per il blacklist come leggerai nei README devi installare il pacchetto apposito che trovi nella serie extra:

xf86-video-nouveau-blacklist

In pratica se parti da slack vanilla, installi quello lì, installi il pacchetto "nvidia-legacy..kernel", poi quello nvidia-legacy...driver e dovresti aver fatto. Ovviamente devi riavviare.
Ma prima di farlo leggi i README perché potrei aver scordato qualche passaggio.

Se non parti da vanilla e hai già installato drivers nvidia proprietari fermati lì.
Dipende da cosa stai facendo girare, se sei su slack-14.2 devi usare il tool nvidia-switch prima di toglierli... ecc.
Insomma dovresti prima di tutto dare più informazioni sul sistema che stai usando.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 300
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: Scheda video NVIDIA GeForce GT 730

Messaggio da Linpassion »

Ciao! Attualmente stp usando la Slackware 15 - ho dimenticato di specificarlo - ed noveau è installato,e reistallando tutto i files nvidia non sono presenti.
Ho provato non da X ad usare il driver ufficiale .run dal NVIDIA, ma alla fine dopo aver generato il file .con in modprobe.d, si arresta e va in errore...nel log non c'è scritto niente di utile.

gian_d
Linux 3.x
Linux 3.x
Messaggi: 576
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.19.xx
Desktop: KDE 5.26
Località: Sardinia
Contatta:

Re: Scheda video NVIDIA GeForce GT 730

Messaggio da gian_d »

Prima di qualsiasi installazione devi mettere in blacklist nouveau. Strano che il pacchetto di installazione di Nvidia non te l'abbia segnalato, che io sappia si arresta da subito se c'è nouveau installato. Per metterlo in blacklist trovi il pacchetto specifico distribuito con la slackware in extra.

In ogni modo ti sconsiglio di installare il driver proprietario usando direttamente il run di Nvidia. Oltre a incasinarti il sistema potresti saltare qualche operazione necessaria per la configurazione infognarti in un bicchiere d'acqua rendendo più complicato eventuali ripristini. Io lo facevo anni fa, non era complicato ma quando dovevi fare manutenzione diventava tutto più ostico. Il fatto stesso che sia incappato in chissà quale errore la dice lunga.

Gli slackbuild rendono più facile la cosa: per qualsiasi necessità disinstalli il pacchetto e ti ritrovi il sistema pulito senza driver. Naturalmente devi usare lo slackbuild compatibile con la tua scheda grafica, io ho la stessa scheda grafica, devi perciò usare lo slackbuild nvidia-legacy470-driver (e il corrispondente slackbuild per i moduli kernel)

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3634
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 15.0
Kernel: 5.15.38
Desktop: dwm

Re: Scheda video NVIDIA GeForce GT 730

Messaggio da joe »

Anche secondo me la strada facile in questo caso c'è ed è la seguente:
  1. lasciare perdere il .run nvidia, e nel caso di averne già tentato l'installazione rimuoverlo con un comando del tipo:

    Codice: Seleziona tutto

    NVIDIA-Linux-x86_64-470.141.03.run --uninstall
    
    (controlla lanciandolo con l'argomento "--help" per assicurarti che l'opzione --uninstall esista per la versione dell'installer in questione)
  2. una volta assicurato di aver rimosso ciò che aveva installato il .run, installare pacchetto slackware ufficiale presente in "extra" xf86-video-nouveau-blacklist
  3. creare ed installare pacchetto nvidia-legacy470-kernel da SBo vedi link sopra
  4. creare ed installare pacchetto nvidia-legacy470-driver da SBo vedi link sopra
  5. riavviare
Prova e facci sapere

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 300
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: Scheda video NVIDIA GeForce GT 730

Messaggio da Linpassion »

Grazie, ora funziona tutto correttamente, ed ora ho potuto mettere anche cuudatoolkit per usare la gpu in Blender. Grazie!

gian_d
Linux 3.x
Linux 3.x
Messaggi: 576
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.19.xx
Desktop: KDE 5.26
Località: Sardinia
Contatta:

Re: [SOLVED] Scheda video NVIDIA GeForce GT 730

Messaggio da gian_d »

Cavolo, cudatoolkit mi ha sempre fatto dannare, alla fine ci ho rinunciato definitivamente. Ma hai usato lo slackbuild da SBo?

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 300
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: [SOLVED] Scheda video NVIDIA GeForce GT 730

Messaggio da Linpassion »

Si per cuda ho usato Slackbuild della 15 che però come dipendenza chiede il driver nvidia.Dopo averli installati ho mandato in esecuzione

Codice: Seleziona tutto

sqg -p cudatoolkit -o qcuda
per generare il queue secondo l'ordine delle dipendenze (è bestiale questo sistema), dopodichè invece di usare
sbopkg -i qcuda
ho caricato il queue qcuda direttamennte dall'interfaccia cli di sbopkg. In questo modo prima dellai compilazione posso vedere se alcuni pacchetti già sono presenti, quindi
compilo solo quelli mancanti. Faccio così (ma non so se sia possibile anche da linea di comando) perchè poi sono solito archiviare i pacchetti. In questo modo se
si incasina il sistema e devo reinstallare i software non ho files duplicati. A questo punto una volta aperto blender - uso la 2.90 e nelle imopstazioni di sistema cuda è abilitato.
Prova e vedi se ti funziona.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3634
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 15.0
Kernel: 5.15.38
Desktop: dwm

Re: [SOLVED] Scheda video NVIDIA GeForce GT 730

Messaggio da joe »

Certo che si può, consigliatissimo lanciare sbopkg con l'opzione help:

Codice: Seleziona tutto

-k              Skip installed packages when building.
Ho notato che lanciando direttamente sbopkg, mi avverte che è presente una coda per il pacchetto in questione. Nelle versioni precedenti mi pare non lo facesse... ma forse è perché avevo generato le code dell'intero repo con sqg, non ricordo più. In pratica mi propone di scegliere la coda piuttosto che il pacchetto singolo. Così se scelgo la coda lui mi crea tutti i pacchetti di dipendenza presenti nella stessa, insieme al pacchetto "target" cui la coda serve appunto come dipendenza.
Se NON voglio ricompilare il mondo ma solo i pacchetti non ancora installati, posso aggiungere l'opzione "-k" che appunto salta il rebuild di eventuali pacchetti già installati.

Esempio, se vuoi installare cudatoolkit senza ricompilare e ripacchettizzare:
- zulu-openjdk8, nvidia-driver
- nvidia-kernel
- ecc ecc... quindi altri eventuali pacchetti necessari per dipendenza

Basta lanciare:

Codice: Seleziona tutto

sbopkg -i cudatoolkit -k
Questo dovrebbe proporti la pacchettizzazione dell'intera [q]ueue, cioè la coda di dipendenze per cudatoolkit, incluso cudatoolkit.
Tu scegli "q", appunto la coda quindi.
E prima di cominciare ti mostra un report di ciò che andrà a lavorare e costruire:

Codice: Seleziona tutto

~# sbopkg -i cudatoolkit
Both a queuefile and a package were found with the name "cudatoolkit".

Use (Q)ueuefile, (P)ackage, or (A)bort?: q
Come si vede io scelgo "q"...
Ed ecco cosa salta fuori:

Codice: Seleziona tutto

PRE-CHECK LOG
Using the SBo repository for Slackware 15.0
Queue Process:  Download, build, and install

apache-ant:
  Checking GPG for apache-ant.tar.gz ... OK
  Processing apache-ant 1.10.12-1
  Using original .info file
  Using original SlackBuild file
  No build options selected.

openjdk7:
  Checking GPG for openjdk7.tar.gz ... OK
  Processing openjdk7 7u321-2
  Using original .info file
  Using original SlackBuild file
  No build options selected.

openjdk8:
  Checking GPG for openjdk8.tar.gz ... OK
  Processing openjdk8 8u345-2
  Using original .info file
  Using original SlackBuild file
  No build options selected.

nvidia-kernel:
  Checking GPG for nvidia-kernel.tar.gz ... OK
  Processing nvidia-kernel 515.76-1
  Using original .info file
  Using original SlackBuild file
  No build options selected.

nvidia-driver:
  Checking GPG for nvidia-driver.tar.gz ... OK
  Processing nvidia-driver 515.76-1
  Using original .info file
  Using original SlackBuild file
  No build options selected.

cudatoolkit:
  Checking GPG for cudatoolkit.tar.gz ... OK
  Processing cudatoolkit 10.2.89-1
  Using original .info file
  Using original SlackBuild file
  No build options selected.

+++++++++++++++++++++++++++++++++++++++++++

Pre-check complete.   

Do you wish to proceed based on the search results above? Packages not
found will be skipped during the process.

(P)roceed or (Q)uit?:
Use (Q)ueuefile, (P)ackage, or (A)bort?: q
L'opzione -k ti evita appunto la ricompilazione di eventuali pacchetti della cosa che sono già installati sul sistema.

Serve comunque una attenzione.
La dipendenza generica di cudatoolkit è nvidia-kernel e nvidia-driver.
Ma nel caso della tua scheda tu hai installato (o comunque devi installare) i driver nvidia-legacy470-kernel e nvidia-legacy470-driver, altrimenti la tua scheda video non è correttamente gestita.
Per cui dalla coda generata automaticamente dovrai togliere i due pacchetti di default e mettere i legacy che servono per la tua scheda. Anche se generi la coda con sqg dovrai poi mettervi mano sostituendo il nome dei pacchetti più recenti con quelli legacy.

La coda non è altro che un file di testo con un pacchetto per riga, e va posizionata nella dir /var/lib/sbopkg/queues.
O per lo meno a me di default le piazza lì. Poi ci sarebbe una variabile da impostare nel sbopkg.conf per controllare sta roba, ma va be', non complichiamo...

In pratica se tu vai a vedere com'è fatta la coda di cudatoolkit ti basta:

Codice: Seleziona tutto

# cat /var/lib/sbopkg/queues/cudatoolkit.sqf
apache-ant
openjdk7
openjdk8
nvidia-kernel
nvidia-driver
cudatoolkit
In questo caso la cosa più conveniente è quindi quella di creare una copia della coda con i due pacchetti driver e kernel modificati col nome dei corrispondenti legacy470.
La nuova coda così creata andrà salvata sempre nella dir delle code, ma con nome non ambiguo, potrebbe essere un'idea:

Codice: Seleziona tutto

# cat /var/lib/sbopkg/queues/custom-cudatoolkit.sqf 
apache-ant
openjdk7
openjdk8
nvidia-legacy470-kernel
nvidia-legacy470-driver
cudatoolkit
Se non rinominiamo così potrebbe accadere che aggiornando sbopkg o anche solo il repository le nostre modifiche vadano perse.

Per lanciare la nostra coda senza rischiare di ricompilare roba già installata che non serve reinstallare:

Codice: Seleziona tutto

# sbopkg -k -i custom-cudatoolkit

PRE-CHECK LOG
Using the SBo repository for Slackware 15.0
Queue Process:  Download, build, and install

apache-ant:
  Checking GPG for apache-ant.tar.gz ... OK
  Processing apache-ant 1.10.12-1
  Using original .info file
  Using original SlackBuild file
  No build options selected.

openjdk7:
  Checking GPG for openjdk7.tar.gz ... OK
  Processing openjdk7 7u321-2
  Using original .info file
  Using original SlackBuild file
  No build options selected.

openjdk8:
  Checking GPG for openjdk8.tar.gz ... OK
  Processing openjdk8 8u345-2
  Using original .info file
  Using original SlackBuild file
  No build options selected.

nvidia-legacy470-kernel:
  Checking GPG for nvidia-legacy470-kernel.tar.gz ... OK
  Processing nvidia-legacy470-kernel 470.141.03-1
  Using original .info file
  Using original SlackBuild file
  No build options selected.

nvidia-legacy470-driver:
  Checking GPG for nvidia-legacy470-driver.tar.gz ... OK
  Processing nvidia-legacy470-driver 470.141.03-1
  Using original .info file
  Using original SlackBuild file
  No build options selected.

cudatoolkit:
  Checking GPG for cudatoolkit.tar.gz ... OK
  Processing cudatoolkit 10.2.89-1
  Using original .info file
  Using original SlackBuild file
  No build options selected.

+++++++++++++++++++++++++++++++++++++++++++

Pre-check complete.

Do you wish to proceed based on the search results above? Packages not
found will be skipped during the process.

(P)roceed or (Q)uit?:
Poi anche qui la cosa non è mica finita. Perché compilare le openjdk (se si hanno già installate l'opzione "-k" ce le risparmia) è una roba molto dispendiosa. Probabilmente è conveniente toglierle dalla coda creata semi-automaticamente e mettere la sola zulu-openjdk8, che è più semplicemente una ripacchettizzazione di openjdk e anche dalla pagina di cudatoolkit su SBo dovrebbe essere sufficiente come dipendenza.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 300
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: [SOLVED] Scheda video NVIDIA GeForce GT 730

Messaggio da Linpassion »

Certo come ho scritto, prima di compilare cuda avevo installato i files che mi avete suggerito poco sopra

Rispondi