[SOLVED] HPLaserJet1020 e Slackware 15

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 290
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

[SOLVED] HPLaserJet1020 e Slackware 15

Messaggio da Linpassion »

Presso che per problemi logistici e di lavoro non tengo la stampante sempre collegata al portatile, perciò la connetto fisicamente al bisogno.
Detto questo ogni volta che ho bisogno e la collego (via usb), la Slackware mi chiede l'installazione dei drivers foo. Non riesco a capire come mai questa cosa, oppure è normale.
Poi siccome l'installazione è via wifi, il che è noioso, ho provato a cercare in rete una installazione da terminale, ma non ho trovato nula.
Ultima modifica di Linpassion il mer 14 set 2022, 21:38, modificato 1 volta in totale.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2935
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.18.14
Desktop: lxde
Località: Pisa
Contatta:

Re: HPLaserJet1020 e Slackware 15

Messaggio da ponce »

potresti provare ad usare (da utente non privilegiato) l'utility hp-setup.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 290
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: HPLaserJet1020 e Slackware 15

Messaggio da Linpassion »

Proverò

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 290
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: HPLaserJet1020 e Slackware 15

Messaggio da Linpassion »

Non funziona. Oggi ho ricollegato la stampante via usb e solita solfa, richiesta installazione dei driver. E se selezione la stampante già installata va in errore di comunicazione, andando in idle.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 290
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: HPLaserJet1020 e Slackware 15

Messaggio da Linpassion »

Oggi ho riprovato in diversi modi senza approdare a nessun risultato. anche un'altra distro fa la stessa cosa risolvendo in maniera buona, ma non mi piace molto la gestione dei pacchetti, che in slackware è più lineare. Detto questo In slack ho provato i seguenti tentativi:

1 - Uso di hp-setup da utente, purtroppo non riesce a scaricare il plug-ins lasciando questo messaggio
error: Plugin download failed with error code = 8
error: file does not match its checksum. File may have been corrupted or altered

Done.
error: The device you are trying to setup requires a binary plug-in. Some functionalities may not work as expected without plug-ins. Please run 'hp-plugin' as normal user to install plug-ins. Visit http://hplipopensource.com for more infomation

2 - Ho provato ad andare sul sito - http://hplipopensource.com - come indicato dal messaggio di errore, provando ad installare da sorgenti, ma a questo punto l'applicazione hp non funziona più


3 - Un altro tentativo è stato di passare da Cups dove vedo diversi drivers dell'hp1020 , ma qualsiasi io selezioni la stampante non funziona


4 - Nel dubbio ho ricompilato da Slackbuild il foomatic-db ma senza successo, cosi come hplip-plugin che mi da il seguente errore
error: Plugin download failed with error code = 8

error: file does not match its checksum. File may have been corrupted or altered

5 - ultimo tentativo è di provare a cercare il file .ppd per caricarlo manualmente dal setup, purtroppo da https://www.openprinting.org/printer/HP ... erJet_1020 il sito https://foo2zjs.rkkda.com/ per scaricare foo2js non è più raggiongibile.

Nel mentre riprovo a trovare una soluzione.

Avatar utente
Linpassion
Linux 2.x
Linux 2.x
Messaggi: 290
Iscritto il: mar 30 ott 2012, 11:17
Slackware: 14.2
Desktop: xfce, fluxbox

Re: HPLaserJet1020 e Slackware 15

Messaggio da Linpassion »

Dopo tanti giri ho risolo in questo modo, e sembra che il driver non si smemorizza. I passaggi fatti sono questi:

1 Da github ho scaricato il pacchetto foo2js-master, quindi lho decompresso in usr/src e compilato come indicato dal file INSTALL
[
make uninstall
make
make install
rm -f /lib/udev/rules.d/*printers.rules
make install-hotplug
make cups
/quote]

2 Dopo ho riavviato la macchina, quindi da Cups ho avviato l'installazione schegliendo HP LaserJet 1020 USB FN0GA0S HPLIP (HP LaserJet 1020). A questo punto una volta scelta la stampante, nel mio caso hp Laserjet1020, ho inserito il ppd manualmente da cups, selezionando il file in usr/src/foo2js-master/PPD/HP-Laserjet_1020.PPD .

3 Da XFCE poi ho disattivato l'avvio dell'applicazione HP nel systray.

Rispondi