Teamviewer su Slackware-14.2_64bit

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3263
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Teamviewer su Slackware-14.2_64bit

Messaggio da joe »

Mi ero scordato di postare qui il finale dell'indagine:
https://community.teamviewer.com/t5/Tea ... e/m-p/2005

La funzionalità, banalmente è stata rimossa. Ora consigliano di provare il programma usando un altro dispositivo dotato di teamviewer.
Consiglio che potevo anche avere dalla dott.ssa Grazia Arcazzo, ma va bè: a risposta gratuita non si guarda in bocca :lol:

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 618
Iscritto il: lun 3 mag 2004, 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: Teamviewer su Slackware-14.2_64bit

Messaggio da lennynero »

joe ha scritto:Mi ero scordato di postare qui il finale dell'indagine:
https://community.teamviewer.com/t5/Tea ... e/m-p/2005

La funzionalità, banalmente è stata rimossa. Ora consigliano di provare il programma usando un altro dispositivo dotato di teamviewer.
Consiglio che potevo anche avere dalla dott.ssa Grazia Arcazzo, ma va bè: a risposta gratuita non si guarda in bocca :lol:
Hey Joe -cit. :)-,
aldilà dell'enorme aiuto di Cristian che citando Grazia ti ha risolto l'enigma... ma volevo capire: perché ci si è infognati nel discorso multilibs? Io ho provato ad usare lo Slackbuild di sBO ma alla fine il "client"(di cui ho bisogno) non parte, citandomi un sacco di roba delle qt5... tu come hai risolto con le dipendenze?
Tieni presente che io sono su una 14.2 abbastanza pulita, ma con le multilibs di Alien.

Grazie in anticipo.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2768
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: Teamviewer su Slackware-14.2_64bit

Messaggio da ponce »

rispetto all'anno scorso (il topic e' di un anno fa), quando teamviewer usava wine per funzionare (e quindi aveva bisogno delle multilib), ora il client e' nativo e non funziona senza qt5-webkit (che a sua volta ha bisogno di qt5, e cosi' via) ma non servono piu' le multilib.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3263
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Teamviewer su Slackware-14.2_64bit

Messaggio da joe »

Lenny, sinceramente non ho più avuto bisogno di quel programma, però il problema che rilevi come spiegato da Ponce non dipende più da multilib siccome Teamviewer adesso è nativo su linux, quindi non c'entra più con wine e tutto l'ambaradan annesso e connesso.

L'intoppo che riscontri sembra banalmente un problema di dipendenze mancanti.
Se lo slackbuild è presente su SBo, il mio approccio usuale è:

- leggere il README di teamviewer su SBo (o anche "sbopkg -s teamviewer")
- creare la coda di dipendenze con "sqg", in questo caso per teamviewer
- verificare che non abbia già qualcuno di quei pacchetti installati e se si confrontare le versioni di quelli proposti con quelli installati
- infine usare il tool sbopkg per processare la coda di dipendenze+teamviewer e installare il tutto automaticamente

Saluti e buona fortuna! :)

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 618
Iscritto il: lun 3 mag 2004, 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

[Risolto] Teamviewer su Slackware-14.2_64bit

Messaggio da lennynero »

ponce ha scritto:rispetto all'anno scorso (il topic e' di un anno fa), quando teamviewer usava wine per funzionare (e quindi aveva bisogno delle multilib), ora il client e' nativo e non funziona senza qt5-webkit (che a sua volta ha bisogno di qt5, e cosi' via) ma non servono piu' le multilib.
Grazie ponce,
in effetti il vecchio zio (Alien) Bob ha pacchettizzato sia qt5 che qt5-webkit, solo che ci sono altre deps che nel frattempo ho risolto. Speravo che qualcuno avesse già fatto la trafila.(pensavo peggio). Santo Alien aveva già pensato a tutto, aggiungendo anche libinput, libxkbcommon e libwacom sul suo personale ~alien(http://www.slackware.com/~alien/slackbuilds/)

N.B. TeamViewer parte ma non è in grado di generare un ID proprio e neanche di connettersi ad un ID UP.(still wait).

EDIT:
è necessario avviare /etc/rc.d/rc.teamviewerd per usarne il client.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2768
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: [Risolto] Teamviewer su Slackware-14.2_64bit

Messaggio da ponce »

lennynero ha scritto:è necessario avviare /etc/rc.d/rc.teamviewerd per usarne il client.
se, invece di installare teamviewer come pacchetto, scarichi il *.tar.xz dal sito di teamviewer, lo scompatti, entri nella directory scompattata e lo lanci con

Codice: Seleziona tutto

./teamviewer
non dovresti aver bisogno di avviare il demone (io lo uso cosi').

Avatar utente
lennynero
Linux 3.x
Linux 3.x
Messaggi: 618
Iscritto il: lun 3 mag 2004, 0:00
Nome Cognome: Luigi Picaro
Slackware: 14.2-x64
Kernel: 4.4.14
Desktop: xfce-4.12
Località: Salerno
Contatta:

Re: [Risolto] Teamviewer su Slackware-14.2_64bit

Messaggio da lennynero »

ponce ha scritto:non dovresti aver bisogno di avviare il demone (io lo uso cosi').
il client lo lancio con

Codice: Seleziona tutto

/opt/teamviewer/tv_bin/TeamViewer
ma se non avvio il demone non genera il mio ID (ed è corretto), ma non mi fa neanche collegare all'host, adducendo problemi di connessione... Tu sei sicuro di non avviare il demone?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2768
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.7.10
Desktop: lxde
Località: Pisa
Contatta:

Re: Teamviewer su Slackware-14.2_64bit

Messaggio da ponce »

mi sono spiegato male: se uso teamviewer dal tarball scompattato (invece che dal pacchetto che lo installa in /opt) il demone teamviewerd viene avviato solo quando lancio ./teamviewer dalla directory scompattata e muore quando chiudo l'interfaccia, non c'e' bisogno di tenerlo sempre attivo avviandolo con uno script in /etc/rc.d.
secondo me questo e' ideale se uno vuole usare il client per connettersi ad altri teamviewer remoti (magari macchine windows di persone che hanno bisogno di una mano), mentre e' piu' comodo avere il demone attivo sempre se ci si deve collegare alla macchina stessa (ma preferisco non usarlo cosi', mi da l'impressione di avere abilitato volontariamente una backdoor ;-) ).

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3263
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Teamviewer su Slackware-14.2_64bit

Messaggio da joe »

Ho dovuto reinstallare teamviewer...

Nella versione compilata da SBo, rilevo il problema di non riuscire a "scrivere" nei campi del login: non riesco ad inserire email e password per fare l'accesso.

A cosa potrebbe essere dovuto?
Capisco che non sia facile capire dove sta il problema ma non ho errori da mostrarvi...

Non è che qualcuno potrebbe confermare di usare il pacchetto di SBo senza problemi o magari potrebbe testarlo?

Ho installato anche la versione "portabile" nella mia home e quella invece va normalmente.
Però preferivo metter il pacchetto di SBo, non mi piace avere la home dell'utente con files sparsi (sì la versione portabile in realtà si può anche installare, ma mi piace ancora meno che sparga files suoi nel sistema, allora meglio usare una subdir della mia home semplice).

Grazie in anticipo! :)

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3263
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: Teamviewer su Slackware-14.2_64bit

Messaggio da joe »

Ho riprovato l'installazione del pacchetto prodotto con lo script disponibile su slackbuilds.org:
https://slackbuilds.org/repository/14.2 ... eamviewer/

Ecco dove sbagliavo l'altra volta:
You must give execute permission on /etc/rc.d/rc.teamviewerd and run
/etc/rc.d/rc.teamviewerd start prior launching TeamViewer application

Lanciando il demone (come root ovviamente, non credo si possa avviare da utente semplice), quando poi si avvia il client da utente semplice, ecco che si riesce a scrivere normalmente in tutti i campi per fare il login.
Quindi problema risolto.


Altro problema!
Ma dove è finita l'icona che si piazzava nell'area di notifica ed era così comoda per minimizzare la finestra di teamviewer?
Sto usando dwm come ambiente grafico. Ma con la vecchia versione l'icona c'era quindi il problema non dovrebbe essere il desktop minimalista...
Nella configurazione di teamviewer non ho trovato la possibilità di attivare opzioni inerenti.
Avete idee?

Rispondi