Doppio problema K3b... [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
murdock
Linux 2.x
Linux 2.x
Messaggi: 477
Iscritto il: ven 25 mag 2007, 12:58
Slackware: 64 14.1
Kernel: 3.18.3
Desktop: KDE 4.14.3
Contatta:

Doppio problema K3b... [RISOLTO]

Messaggio da murdock »

Essendo sicuro che ci fosse una soluzione al mio problema all'interno del forum slacky, vado baldanzoso
per cercare qualche cosa ma, incredibilmente (beh mica tanto, dato che l'argomento è piuttosto trattato),
il termine "k3b" viene riconosciuto troppo comune e quindi lo esclude dalla ricerca, risultato, non ho trovato
niente, colgo l'occasione anche per chiedere delucidazioni sul mio problema :D

Quando apro k3b, mi appare una dialog che mi avverte che non trova il masterizzatore (No CD/DVD writer found.).
Infatti, invocato da shell mi da:

Codice: Seleziona tutto

(K3bDevice::Device) could not open device /dev/hda for reading
                    (Permission denied)
could not open device /dev/hda (Permission denied)
/dev/hdb resolved to /dev/hdb
(K3bDevice::Device) could not open device /dev/hdb for reading
                    (Permission denied)
could not open device /dev/hdb (Permission denied)
Reimpostando i permessi, tutto torna normale, però al riavvio successivo torna tutto come prima...
Le ultime modifiche fatte a questa macchina sono:
Kernel-2.6.24
udev+hal (sospetto di loro fortemente)

Immagino che il problema sia stato ultra-discusso ma, ho colto anche l'occasione per comunicare
allo staff Slacky il problema sulla ricerca del forum :)

Saluti,
MuRdOcK
Ultima modifica di murdock il mer 27 feb 2008, 1:43, modificato 1 volta in totale.

Avatar utente
FireEater
Linux 3.x
Linux 3.x
Messaggi: 508
Iscritto il: sab 5 feb 2005, 0:00
Nome Cognome: Giuseppe M.
Slackware: Current
Kernel: 2.6.32.7-smp
Desktop: kde 4.3.4
Località: Cagliari <---> Torino

Re: Doppio problema K3b...

Messaggio da FireEater »

Ciao, io avevo lo stesso problema. Ho risolto in maniera forse non proprio pulita ma sicuramente funzionante.

Ho editato il file /etc/udev/rules.d/50-udev.rules

Ho modificato i permessi in questa parte del codice(nel mio file attorno alla riga 100).

Codice: Seleziona tutto

LABEL="persistent_storage_end"
# import optical drive properties and set CD partitions
KERNEL=="scd[a-z]|sr[0-9]*|hd[a-z]|pcd[0-9]*", IMPORT{program}="cdrom_id --export $tempnode"
ENV{ID_CDROM}=="?*", NAME="%k", GROUP="cdrom", MODE="0666", RUN+="cdrom-symlinks.sh %k"
Come noti nell'ultima riga c'è MODE="0666" mentre da te sarà sicuramente MODE="0660"

Spero di esser stato chiaro.
Fire.

Avatar utente
murdock
Linux 2.x
Linux 2.x
Messaggi: 477
Iscritto il: ven 25 mag 2007, 12:58
Slackware: 64 14.1
Kernel: 3.18.3
Desktop: KDE 4.14.3
Contatta:

Re: Doppio problema K3b...

Messaggio da murdock »

Fire_eater ha scritto:Ciao, io avevo lo stesso problema. Ho risolto in maniera forse non proprio pulita ma sicuramente funzionante.

Ho editato il file /etc/udev/rules.d/50-udev.rules

Ho modificato i permessi in questa parte del codice(nel mio file attorno alla riga 100).

Codice: Seleziona tutto

LABEL="persistent_storage_end"
# import optical drive properties and set CD partitions
KERNEL=="scd[a-z]|sr[0-9]*|hd[a-z]|pcd[0-9]*", IMPORT{program}="cdrom_id --export $tempnode"
ENV{ID_CDROM}=="?*", NAME="%k", GROUP="cdrom", MODE="0666", RUN+="cdrom-symlinks.sh %k"
Come noti nell'ultima riga c'è MODE="0666" mentre da te sarà sicuramente MODE="0660"

Spero di esser stato chiaro.
Fire.
Chiarissimo, grazie mille, tra le altre cose non avevo aggiornato udev, infatti avevo provato nel mio /etc/udev/rules.d/udev.rules a
modificare il parametro in "0666" (attorno alle prime righe), ma non funzionava (probabilmente i lettori ottici per il vecchio udev rientrano
tra le impostazioni degli hard-disk)...

p.s. io avevo risolto in una maniera ancor più sporca, cambiavo di nuovo i permessi ad hda ed a hdb dall'rc.local :D
questo mi pare un sistema parecchio più pulito...

Grazie ancora,
MuRdOcK

cyme
Linux 0.x
Linux 0.x
Messaggi: 70
Iscritto il: mar 8 nov 2005, 22:33
Slackware: 64current
Kernel: 2.6.32.7
Desktop: Kde

Re: Doppio problema K3b...

Messaggio da cyme »

Scusate se mi intrometto...
Ma è un problema che hai sempre avuto o è comparso solo dopo gli aggiornamenti di kernel e/o udev+hal?
Nel primo caso penso sia risolvibile anche aggiungendo il tuo utente al gruppo CDROM. Nel secondo caso... come non detto! :oops:
Ciao

Avatar utente
murdock
Linux 2.x
Linux 2.x
Messaggi: 477
Iscritto il: ven 25 mag 2007, 12:58
Slackware: 64 14.1
Kernel: 3.18.3
Desktop: KDE 4.14.3
Contatta:

Re: Doppio problema K3b...

Messaggio da murdock »

cyme ha scritto:Scusate se mi intrometto...
Ma è un problema che hai sempre avuto o è comparso solo dopo gli aggiornamenti di kernel e/o udev+hal?
Nel primo caso penso sia risolvibile anche aggiungendo il tuo utente al gruppo CDROM. Nel secondo caso... come non detto! :oops:
Ciao
Beh, dopo parecchio tempo ho deciso di usare udev+hal (esasperato dal dovermi montare a manina i devices come root (regola mantenuta per mia paranoia), considerato il fatto che siamo nel 2008). Il problema è sorto da questa nuova implementazione, dato che, udev creando i devices all'avvio, imposta per questi i permessi da lui stabiliti (nel file /etc/udev/rules.d/50-udev.rules).
Avevo inoltre una versione non aggiornata di udev che stabiliva i permessi per i devices in un altro modo (nel file /etc/udev/rules.d/udev.rules),
probabilmente trattando le unità ottiche al pari degli hard-disks.

Saluti,
MuRdOcK

Rispondi