driver scheda di rete

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rjo
Linux 0.x
Linux 0.x
Messaggi: 13
Iscritto il: mar 19 lug 2005, 0:00

driver scheda di rete

Messaggio da Rjo »

innanzitutto ciao a tutti.
ho un problema sulla scheda di rete ,praticamente quando pingo il router non mi da risposta.
ho guardato la configurazione fatta con netconfig ed è ok ..ho guardato con dmesg|grep eth e su eth0 mi viene solo la riga davicom......,irq5
(se è importante posto l'intera riga).
pero' ad esempio nella guida che ho qua dovrebbero apparirmi altre due righe dove dice:
eth0 identified..
et0: link up ....
a sto punto penso che i driver non siano caricati della mia davicom....se è cosi' sapete dirmi nel kernel quali sono quelli relativi a questa scheda di rete ?
grazie mille

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

googlando mi sembra che tu debba fare:

#modprobe tulip
oppure (se ifconfig non ti rileva la scheda)

#modprobe dmfe

DarkNeo
Linux 4.x
Linux 4.x
Messaggi: 1071
Iscritto il: sab 4 giu 2005, 0:00
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE
Località: Matrix

Messaggio da DarkNeo »

Scusa se dai un ifconfig e ti riconosce la scheda di rete come eth0 e per di più tui fa usare il netconfig vuol dire che non cè bisogno di driver comunque se non fosse così i moduli per le schede di rete le trovi compilando il kernel in questa sezione:
Device Drivers --> Networking support --> Ethernet (10 or 100Mbit) / Ethernet (1000Mbit) se hai una gigabit

Avatar utente
l1q1d
Master
Master
Messaggi: 1862
Iscritto il: lun 21 feb 2005, 0:00
Località: In uno spazio n-dimesionale
Contatta:

Messaggio da l1q1d »

cosa ti da "ifconfig -a"?

Rjo
Linux 0.x
Linux 0.x
Messaggi: 13
Iscritto il: mar 19 lug 2005, 0:00

Messaggio da Rjo »

grazie per le risposte..comunque:
ho provato a caricare tulip e non funziona uguale cosi come dmfeCmq posto l'output

#dmesg|grep eth

eth0: Davicom DM9102/DM9102A rev 64 at 0xc400, 00:60:6E:77:4A:D9, IRQ 5.

# ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:60:6E:77:4A:D9
inet addr:10.0.0.7 Bcast:10.255.255.255 Mask:255.0.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:252 (252.0 b)
Interrupt:5 Base address:0xc400

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:772 (772.0 b) TX bytes:772 (772.0 b)

su suse non mi dava problemi ,quindi escludevo problemi lato router..ma anche qua non saprei. Adesso guardo un po' sul kernel o al limite lo porto al 2.6 (se è utile)
[/i]

Rjo
Linux 0.x
Linux 0.x
Messaggi: 13
Iscritto il: mar 19 lug 2005, 0:00

Messaggio da Rjo »

anzi scusate con
# modprobe dmfe

/lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz: init_module: No such device
/lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz: insmod /lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz failed
/lib/modules/2.4.29/kernel/drivers/net/dmfe.o.gz: insmod dmfe failed

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

# ifconfig -a

eth0 Link encap:Ethernet HWaddr 00:60:6E:77:4A:D9
inet addr:10.0.0.7 Bcast:10.255.255.255 Mask:255.0.0.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:252 (252.0 b)
Interrupt:5 Base address:0xc400

questo vuol dire che il kernel riconosce la tua scheda di rete, le viene pure assegnato un indirizzo ip dal tuo router:10.0.0.7;
quindi il kernel carica il modulo per la tua scheda di rete;

che ti dice:

route -n

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

oltre all'output di

route -n

posta anche il contenuto di /etc/resolv.conf

Rjo
Linux 0.x
Linux 0.x
Messaggi: 13
Iscritto il: mar 19 lug 2005, 0:00

Messaggio da Rjo »

Kernel IP routing table
Destination- Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0- 0.0.0.0- 255.255.255.0- U 0 0 0 eth0
127.0.0.0- 0.0.0.0- 255.0.0.0- U 0 0 0 lo
0.0.0.0- 10.0.0.2- 0.0.0.0- UG 1 0 0 eth0



search rjo
nameserver 10.0.0.2 (ho provato pure il dns primario di libero)

DarkNeo
Linux 4.x
Linux 4.x
Messaggi: 1071
Iscritto il: sab 4 giu 2005, 0:00
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE
Località: Matrix

Messaggio da DarkNeo »

Rjo ha scritto:anzi scusate con
# modprobe dmfe
Ma dopo sei andato in /etc/rc.d/rc.modules ad aggiungere /sbin/modprobe dmfe?

Rjo
Linux 0.x
Linux 0.x
Messaggi: 13
Iscritto il: mar 19 lug 2005, 0:00

Messaggio da Rjo »

c'erano di gia e sono quelli delle davicom 9xxxx
#/sbin/modprobe dmfe
tu intendi decommentarlo? comunque ho provato ma solito output

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

in teoria tutti i parametri son giusti e non c' è bisogno di altri driver...
non è che per caso è impostato qualche fw (se non sulla tua macchina magari sul router)?

posta l'output di:

# iptables -L

P.S. già che ci sei, posta anche l'output di

$ lsmod

DarkNeo
Linux 4.x
Linux 4.x
Messaggi: 1071
Iscritto il: sab 4 giu 2005, 0:00
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE
Località: Matrix

Messaggio da DarkNeo »

Rjo ha scritto:c'erano di gia e sono quelli delle davicom 9xxxx
#/sbin/modprobe dmfe
tu intendi decommentarlo? comunque ho provato ma solito output
Si

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

ma cosa pinghi
ma sto router che indirizzo ha ...
10.0.0.2 per caso ... forse

se dai un named così tanto per provare riesci a risolvere?

Avatar utente
Paoletta
Staff
Staff
Messaggi: 3975
Iscritto il: lun 25 apr 2005, 0:00
Slackware: 14.2 - 64 bit
Desktop: fluxbox
Località: Varese

Messaggio da Paoletta »

io tanto per provare metterei la metric del default gw della routing table a 0 anzichè a 1...

#route del default
#route add default gw 10.0.0.2 metric 0

Rispondi