Installazione mysql Errore

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
tylyo
Linux 0.x
Linux 0.x
Messaggi: 84
Iscritto il: ven 4 nov 2005, 18:40

Installazione mysql Errore

Messaggio da tylyo »

ho scaricato i paccheti da slacky con swaret
apache pare funzionare
cosi come php
ma durante la prcedura di configurazione del mysql ho riscontrato il seguente problema:

>mysql_install_db..... ok
>chown -R mysql:mysql /usr/share/mysql
>chown -R mysql:mysql /usr/share/mysql/data .... (non esiste)
>mysqld_safe & ... (il demone parte)

>mysqladmin -u root password 'asd'
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

dove sbaglio ?

Avatar utente
GuRpS
Linux 2.x
Linux 2.x
Messaggi: 326
Iscritto il: ven 14 mag 2004, 0:00
Località: Varese
Contatta:

Messaggio da GuRpS »

>chown -R mysql:mysql /usr/share/mysql/data .... (non esiste)

Bhe' questo imho e' superfluo...tanto hai dato il -R prima quindi tutto cio' che c'e' in /usr/share/mysql e' gia' chown-nato

per il resto....io sulla guida LAMP che c'e' su slacky avevo trovato che si dovesse fare:

Codice: Seleziona tutto

cp /etc/my-medium.cnf /etc/my.cnf
mysql_install_db
chown -R mysql:mysql /var/lib/mysql
mysql_safe &

mysqladmin -u root password "tuapassword"

killi tutto mysqld

fai ripartire con

mysql_safe --user=mysql &
E personalmente a me va tutto...

tylyo
Linux 0.x
Linux 0.x
Messaggi: 84
Iscritto il: ven 4 nov 2005, 18:40

Messaggio da tylyo »

si ma a me da errore in:

>mysqladmin -u root password 'asd'
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'

Avatar utente
GuRpS
Linux 2.x
Linux 2.x
Messaggi: 326
Iscritto il: ven 14 mag 2004, 0:00
Località: Varese
Contatta:

Messaggio da GuRpS »

ehhh ma tu salit il chown a /var/lib/mysql ...

Forse e' per quello...

tylyo
Linux 0.x
Linux 0.x
Messaggi: 84
Iscritto il: ven 4 nov 2005, 18:40

Messaggio da tylyo »

Stesso errore anche se eseguo
chown -R mysql:mysql /var/lib/mysql

tylyo
Linux 0.x
Linux 0.x
Messaggi: 84
Iscritto il: ven 4 nov 2005, 18:40

Messaggio da tylyo »

Anche reinstallando incontro gli stessi problemi, qualcuno mi può spiegare dove sbaglio o cosa devo fare per far funzionare mysql?

tylyo
Linux 0.x
Linux 0.x
Messaggi: 84
Iscritto il: ven 4 nov 2005, 18:40

Messaggio da tylyo »

[RISOLTO]

ho controllato l'owner della directory di root e, non so per quale motivo risultava l'user

Codice: Seleziona tutto

-rwxr-xr-x  1 tylyo root 72229632 2005-12-25 12:21
quindi correggendolo

Codice: Seleziona tutto

> chown -R root:root /root
tutto ha funzionato come si deve
:wink: :wink: :wink: :wink: :wink: :wink: :wink:

Rispondi