Installazione mysql Errore
Moderatore: Staff
Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Installazione mysql Errore
ho scaricato i paccheti da slacky con swaret
apache pare funzionare
cosi come php
ma durante la prcedura di configurazione del mysql ho riscontrato il seguente problema:
>mysql_install_db..... ok
>chown -R mysql:mysql /usr/share/mysql
>chown -R mysql:mysql /usr/share/mysql/data .... (non esiste)
>mysqld_safe & ... (il demone parte)
>mysqladmin -u root password 'asd'
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
dove sbaglio ?
apache pare funzionare
cosi come php
ma durante la prcedura di configurazione del mysql ho riscontrato il seguente problema:
>mysql_install_db..... ok
>chown -R mysql:mysql /usr/share/mysql
>chown -R mysql:mysql /usr/share/mysql/data .... (non esiste)
>mysqld_safe & ... (il demone parte)
>mysqladmin -u root password 'asd'
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
dove sbaglio ?
>chown -R mysql:mysql /usr/share/mysql/data .... (non esiste)
Bhe' questo imho e' superfluo...tanto hai dato il -R prima quindi tutto cio' che c'e' in /usr/share/mysql e' gia' chown-nato
per il resto....io sulla guida LAMP che c'e' su slacky avevo trovato che si dovesse fare:
E personalmente a me va tutto...
Bhe' questo imho e' superfluo...tanto hai dato il -R prima quindi tutto cio' che c'e' in /usr/share/mysql e' gia' chown-nato
per il resto....io sulla guida LAMP che c'e' su slacky avevo trovato che si dovesse fare:
Codice: Seleziona tutto
cp /etc/my-medium.cnf /etc/my.cnf
mysql_install_db
chown -R mysql:mysql /var/lib/mysql
mysql_safe &
mysqladmin -u root password "tuapassword"
killi tutto mysqld
fai ripartire con
mysql_safe --user=mysql &
[RISOLTO]
ho controllato l'owner della directory di root e, non so per quale motivo risultava l'user
quindi correggendolo
tutto ha funzionato come si deve

ho controllato l'owner della directory di root e, non so per quale motivo risultava l'user
Codice: Seleziona tutto
-rwxr-xr-x 1 tylyo root 72229632 2005-12-25 12:21Codice: Seleziona tutto
> chown -R root:root /root
