aggiornare php [risolto]

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
bbg5ne
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer 10 mag 2006, 22:56

aggiornare php [risolto]

Messaggio da bbg5ne »

cosa devo fare per aggiornare php oltre all'upgradepkg del pacchetto?
ho correntemente istallato la versione 4.0 di php!
grazie :roll:
Ultima modifica di bbg5ne il mar 12 set 2006, 0:46, modificato 1 volta in totale.

Avatar utente
dapuzz
Linux 4.x
Linux 4.x
Messaggi: 1137
Iscritto il: mar 16 mag 2006, 11:09
Contatta:

Messaggio da dapuzz »

credo niente più, perchè mi sembra che apache carichi il modulo giusto a seconda di cosa trova. Anzi, ora che ricordo c'era una libreria da aggiornare, libmm mi sembra ma non mi ricordo bene.
Dopo aver upgradato comunque fai un restart ad apache e se dà qualche errore all'avvio ce lo incolli qui e vediamo che fare :)

Avatar utente
bbg5ne
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer 10 mag 2006, 22:56

Messaggio da bbg5ne »

eccolo:

Codice: Seleziona tutto

syntax error on line 277 of /etc/apache/httpd.conf:
Cannot add module via name 'mod_php5.c': not in list of loaded modules
/usr/sbin/apachectl start: httpd could not be started

Avatar utente
bbg5ne
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer 10 mag 2006, 22:56

Messaggio da bbg5ne »

ho modificato una cosa ed ecco l'errore su libmm ma che roba è?

Codice: Seleziona tutto

Cannot load /usr/libexec/apache/libphp5.so into server: libmm.so.14: cannot open shared object file: No such file or directory
/usr/sbin/apachectl start: httpd could not be started
:roll:

Avatar utente
bbg5ne
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer 10 mag 2006, 22:56

risoltoooooooooooooooooooooooooooooooooooooooooooooooooooo

Messaggio da bbg5ne »

per la serie "me la canto e me la suono" :lol:
:idea:
in pratica ho aggiornato sia su httpd.conf, sia su mod_php.conf tutte le diciture di php4 in php5 e poi ho istallato l'ulttima versone di mm, scaricabile anche da qui:
http://www.ossp.org/pkg/lib/mm/
;)

Avatar utente
bbg5ne
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer 10 mag 2006, 22:56

Messaggio da bbg5ne »

mi ero dimenticato un altra cosa... prima di aggiornare mm ho anche copiato il file php.ini-dist presa dal package in

Codice: Seleziona tutto

/usr/local/lib/php.ini
, mi pare ora di non essermi dimenticato nulla.... :roll:

Avatar utente
bbg5ne
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer 10 mag 2006, 22:56

Messaggio da bbg5ne »

mi sa comunque che l'ultimo procedimento p inutile...anche se l'ho letto sul readme di php, comunque durante l'aggiornamento il php.ini viene messo in /etc/apache e apache fa riferimento a quello per la configurazione!!! ;)

Avatar utente
dapuzz
Linux 4.x
Linux 4.x
Messaggi: 1137
Iscritto il: mar 16 mag 2006, 11:09
Contatta:

Messaggio da dapuzz »

ieri me ne sono andato a dormire presto e ti ho lasciato tutto solo a risolvere i problemi :D Credo di capire però che non hai scaricato i pacchetti ufficiali! per questo hai avuto quel problema con in mod_php.conf
C'è php-5.1.6 in extra/php5 e mm, in slackware/l

Avatar utente
bbg5ne
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: mer 10 mag 2006, 22:56

Messaggio da bbg5ne »

strano perchè php l'avevo preso da slackware.it cercando sul motote di ricerca dei package php, ma mm non me lo trovava, l'ho dovuto compilare...ma l'importante è che ora funziona! :)

Avatar utente
dapuzz
Linux 4.x
Linux 4.x
Messaggi: 1137
Iscritto il: mar 16 mag 2006, 11:09
Contatta:

Messaggio da dapuzz »

I paccheti ufficiali non installano in usr/local
http://www.slackware.it/pb/search.php?v ... q=libmm.so
Usa sempre questo sito e andrai una bomba. ;)

Rispondi