ho un piccolo problama con udev: non riesco a fargli capire come deve chiamare i miei dischi e penne usb... premetto che sto usando dbus,hal e tutto l'ocorrente per usare l'automount...
ho creato il file /etc/udev/rules.d/00-myrules.rules e dentro ci ho messo
le informazioni inserite le ho prese tramite il comando##*** Configuration fyle for my devices
SUBSYSTEM=="block", GROUP="disk"
##usb disk driver
BUS=="scsi", SYSFS{vendor}=="SAMSUNG ", SYSFS{model}=="SP1203N ", NAME="usbdisk"
##usb penn driver
SUBSYSTEM=="block", SYSFS{model}=="Store _n_ Go ", NAME="usbpenn"
Codice: Seleziona tutto
udevinfo -a -p /sys/block/sda/ ecco l'output di /var/log/message
Codice: Seleziona tutto
Oct 25 11:58:07 kafka kernel: usb 1-1: new high speed USB device using ehci_hcd and address 11
Oct 25 11:58:07 kafka kernel: usb 1-1: configuration #1 chosen from 1 choice
Oct 25 11:58:07 kafka kernel: scsi7 : SCSI emulation for USB Mass Storage devices
Oct 25 11:58:07 kafka udevsend[16424]: starting udevd daemon
Oct 25 11:58:07 kafka udevsend[16429]: starting udevd daemon
Oct 25 11:58:07 kafka udevsend[16450]: starting udevd daemon
Oct 25 11:58:08 kafka udevsend[16469]: starting udevd daemon
Oct 25 11:58:09 kafka udevsend[16424]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:09 kafka udevsend[16429]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:09 kafka udevsend[16450]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:10 kafka udevsend[16469]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:12 kafka kernel: Vendor: VBTM Model: Store 'n' Go Rev: 1.02
Oct 25 11:58:12 kafka kernel: Type: Direct-Access ANSI SCSI revision: 00
Oct 25 11:58:12 kafka kernel: SCSI device sda: 2013184 512-byte hdwr sectors (1031 MB)
Oct 25 11:58:12 kafka kernel: sda: Write Protect is off
Oct 25 11:58:12 kafka kernel: SCSI device sda: 2013184 512-byte hdwr sectors (1031 MB)
Oct 25 11:58:12 kafka kernel: sda: Write Protect is off
Oct 25 11:58:12 kafka kernel: sda:<7>usb-storage: queuecommand called
Oct 25 11:58:12 kafka kernel: sd 7:0:0:0: Attached scsi removable disk sda
Oct 25 11:58:12 kafka kernel: sd 7:0:0:0: Attached scsi generic sg0 type 0
Oct 25 11:58:12 kafka udevsend[16502]: starting udevd daemon
Oct 25 11:58:12 kafka udevsend[16506]: starting udevd daemon
Oct 25 11:58:12 kafka udevsend[16514]: starting udevd daemon
Oct 25 11:58:12 kafka udevsend[16517]: starting udevd daemon
Oct 25 11:58:14 kafka udevsend[16541]: starting udevd daemon
Oct 25 11:58:15 kafka udevsend[16502]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:15 kafka udevsend[16506]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:15 kafka udevsend[16514]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:15 kafka udevsend[16517]: unable to connect to event daemon, try to call udev directly
Oct 25 11:58:15 kafka udevsend[16541]: unable to connect to event daemon, try to call udev directly
qualche idea ???

