[RISOLTO] Problemi con Hylafax 5.1.7

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
DanBadJar
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 28 lug 2006, 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

[RISOLTO] Problemi con Hylafax 5.1.7

Messaggio da DanBadJar »

Premetto che è la prima volta che approccio a una configurazione di un server fax.

Ho installato Hylafax scaricandolo qui da Slacky, l'ho configurato (spero) con tutti i parametri necessari tramite faxsetup e il pc è in grado di dialogare correttamente col modem.

Ma se dò un:

Codice: Seleziona tutto

sendfax -d <numero> fax.tif
ottengo uno spiazzante

Codice: Seleziona tutto

Can not reach server at host "localhost", port 4559
Non ho trovato problemi analoghi sul forum. Qualche idea?
Grazie
Ultima modifica di DanBadJar il mar 8 apr 2008, 15:22, modificato 2 volte in totale.

galvy
Linux 0.x
Linux 0.x
Messaggi: 87
Iscritto il: mer 25 gen 2006, 20:40
Slackware: 12
Località: Parma
Contatta:

Messaggio da galvy »

sembrerebbe che il demone del faxserver non sia attivo.... se fai nmap 127.0.0.1 che risultato ottieni?????

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

Devi rendendere eseguibile lo script di controllo /etc/rc.d/rc.hylafax e lo fai partire con...

Codice: Seleziona tutto

/etc/rc.d/rc.hylafax start
Inoltre conviene modificare gli script
/etc/rc.d/rc.M per l'avvio
e
/etc/rc.d/rc.0
per lo spegnimento
buon lavoro ....

Avatar utente
DanBadJar
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 28 lug 2006, 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Messaggio da DanBadJar »

Lo script /etc/rc.hylafax era già reso avviabile, però non partiva.
Sono stato costretto ad avviarlo "a mano" inserendolo in /etc/rc.local
Così finalmente ho la 4559 aperta e hylafax è in ascolto.

Proverò ad inviare e ricevere, poi posto se ho difficoltà.
Grazie mille per ora, rapidissimi come sempre.
:oops:

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

Come dicevo conviene modificare ... rc.M e rc.0 piuttosto che rc.local ecco come potresti fare ... in rc.M

Codice: Seleziona tutto

..................
# Start Samba (a file/print server for Win95/NT machines).
# Samba can be started in /etc/inetd.conf instead.
if [ -x /etc/rc.d/rc.samba ]; then
  . /etc/rc.d/rc.samba start
fi
# Start the Hylafax server 
if [ -x /etc/rc.d/rc.hylafax ]; then
  . /etc/rc.d/rc.hylafax start
fi

# Start the GPM mouse server:
if [ -x /etc/rc.d/rc.gpm ]; then
  . /etc/rc.d/rc.gpm start
fi
..........
e in modo analogo in rc.0 ... ovviamente usando lo stop ...

:-)

Avatar utente
DanBadJar
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 28 lug 2006, 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Messaggio da DanBadJar »

Ok, sto andando avanti in questa avventura disperata.
Ho fatto l'upgrade alla versione 5.1.7 , usando il pacchetto di slacky.
Attualmente sembra che io abbia degli errori di autenticazione.

Se provo a dare un:

Codice: Seleziona tutto

sendfax -d numero file.txt
ottengo un errore:

Codice: Seleziona tutto

Login failed: 530 Login incorrect
Ho notato inoltre che il comando faxadduser non funziona, o almeno non come dovrebbe. Mi aspetto infatti che mi modifichi il file /var/spool/hylafax/hosts.hfaxd aggiungendo utenti e invece niente.
Il file contiene:

Codice: Seleziona tutto

localhost
127.0.0.1
172.30
La cosa strana è che il comando:

Codice: Seleziona tutto

faxadduser -u utente -p password
non restituisce nessun errore!

Ho inoltre provato ad accedere al server da diversi clients per windows, ma niente, l'errore è sempre il medesimo: Login failed: 530 Login incorrect

Idee?
Grazie

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

Prova da root a vedere cosa esce ...

Avatar utente
DanBadJar
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 28 lug 2006, 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Messaggio da DanBadJar »

Stessa cosa. Stesso risultato sia da user che da root. :?

Avatar utente
DanBadJar
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 28 lug 2006, 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Messaggio da DanBadJar »

Procedendo con l'odissea ho scoperto che il comando faxadduser non era in grado di aggiungere utenti perchè non avevo i permessi di scrivere sul file /var/spool/hylafax/etc/hosts.hfaxd
ma non mi postava neanche qualche errore in output...mah...

Cambiati i permessi ho rilanciato il comando e aggiunto tutti i miei utenti del caso, ora ho il file di questo tipo:

Codice: Seleziona tutto

localhost
127.0.0.1
172.30
^daniele@::QLZkuBLhGJqoE
^luca@::5FbkT8s0RRlUU
^root@::0GOXw7ZvJhbhA
Ebbene signori, il risultato non cambia! Riavviato il demone e l'errore è sempre quello, sia dai server che dai clients.

Codice: Seleziona tutto

Login failed: 530 Login incorrect.
Che altro devo settare? In che direzione posso andare? Si vedesse almeno qualche sirena...

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

Mi ricordo di aver trovato gli stessi problemi e di averli risolti ,
studiando quello che fa ksendfax , a causa della mancanza di documentazione su sendfax, .... devi aggiungere alcuni switch ... ma ovviamente non ricordo quali e devi leggere le man page ma ricordo che non erano aggiornate ... come non é aggiornata documentazione per la procedura di configurazione degli utenti..
Ricordo di aver installato KsendFax in locale e studiando le opzioni che imposta (... che tra l' altro non funzionano) e provandole su sendfax son riuscito a farlo funzionare ...
Ho usato un centralino e un fax per fare i test ...
... per ora il mio supporto si limita a queste dritte perché il tempo a disposizione é sempre poco ... spero di poterti aiutare .. anche perché ho hylafax installato su questo PC che attivo per la ricezione e appena posso faccio dei test ....
... Ciao :-)

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

Il comando da dare é ...
sendfax -f utente_hylafax -d numero file_da_inviare
e comunque a me non restituisce l' errore che ti esce a te ...

Codice: Seleziona tutto

livia@gablin:/home/gabriele$ sendfax -d 123457 /etc/printcap
Malformed (null) sender name or mail address
Comunque io ho installato Hylafax+ 5.1.3 dai sorgenti .... é probabile che ci sia qualche problema nel pacchetto ...

Avatar utente
DanBadJar
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 28 lug 2006, 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Messaggio da DanBadJar »

Ok, almeno so un po' dove documentarmi.
Appena faccio altri test li posto qui in topic.
Grazie Luci0, sei gentilissimo.

Avatar utente
Luci0
Staff
Staff
Messaggi: 3591
Iscritto il: lun 27 giu 2005, 0:00
Nome Cognome: Gabriele Santanché
Slackware: 12.2 14.0
Kernel: 2.6.27.46- gen 3.2.29
Desktop: KDE 3.5.10 Xfce
Località: Forte dei Marmi
Contatta:

Messaggio da Luci0 »

Ho installato su una 12.0 fresca il pacchetto Hylafax 5.1.7, ho configurato il server e il modem seriale con faxsetup ... ho seguito le istruzioni che trovi in /usr/doc/hylafax/README.Slackware e ho provato ad inviare un fax ... e sono riuscito ad ottenere che il modem tenta di comporre il numero ... forse stai sbagliando qualcosa ... altri test non ne ho fatti ma credo che all' ingrosso l' installazione sia corretta..
... :-)

Avatar utente
DanBadJar
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 28 lug 2006, 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Messaggio da DanBadJar »

Nel file README.Slackware ho trovato solo alcune cose da cambiare in /etc/inittab, ovvero ho dovuto inserire la riga:

Codice: Seleziona tutto

d1:12345:respawn:/usr/sbin/faxgetty /dev/modem
Mentre googlando un po' avevo trovato da impostare:

Codice: Seleziona tutto

s0:2345:respawn:/usr/sbin/faxgetty ttyS0
Il risultato è sempre lo stesso. Continua a restituirmi:

Codice: Seleziona tutto

Login failed: 530 Login incorrect.
Meglio se vado in ferie! Evviva le sirene...

Avatar utente
DanBadJar
Linux 4.x
Linux 4.x
Messaggi: 1027
Iscritto il: ven 28 lug 2006, 19:27
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome
Località: Bologna
Contatta:

Re: Problemi con Hylafax 5.1.7

Messaggio da DanBadJar »

Torno sull'argomento qualche mese dopo il post iniziale per dirvi che ho risolto, col pacchetto di slacky e versione 5.2.3.
Unico problema è che all'esecuzione di faxsetup si hanno alcuni errori relativi a files non trovati. E' necessario crearli a mano.
Per il resto tutto funziona.
Grazie a tutti!

Rispondi