NTFS-3g
Moderatore: Staff
Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
-
homer84
- Linux 2.x

- Messaggi: 297
- Iscritto il: gio 9 giu 2005, 0:00
- Slackware: Current
- Località: Torino
NTFS-3g
Come posso settare in modo che il mio utente possa leggere e scrivere su una partizione NTFS di windows?
se faccio da root tutto ok, ma se provo a montare da user:
Error opening partition device: Permission denied
Failed to startup volume: Permission denied
Failed to mount '/dev/hda2': Permission denied
eppure nel mio fstab..
/dev/hda2 /mnt/shareWin ntfs-3g noauto,users,rw,uid=1000 0 0
dove uid=1000 l'ho messo proprio per fare in modo che io possare fare tali operazioni da user!!
Secondo voi?
se faccio da root tutto ok, ma se provo a montare da user:
Error opening partition device: Permission denied
Failed to startup volume: Permission denied
Failed to mount '/dev/hda2': Permission denied
eppure nel mio fstab..
/dev/hda2 /mnt/shareWin ntfs-3g noauto,users,rw,uid=1000 0 0
dove uid=1000 l'ho messo proprio per fare in modo che io possare fare tali operazioni da user!!
Secondo voi?
- murdock
- Linux 2.x

- Messaggi: 477
- Iscritto il: ven 25 mag 2007, 12:58
- Slackware: 64 14.1
- Kernel: 3.18.3
- Desktop: KDE 4.14.3
- Contatta:
Re: NTFS-3g
Mah, così a spanne c'è una "s" di troppo in "users", nel tuo fstab.homer84 ha scritto: [CUT]
/dev/hda2 /mnt/shareWin ntfs-3g noauto,users,rw,uid=1000 0 0
[CUT]
Prova con "user".
Saluti,
MuRdOcK
- phobos3576
- Staff

- Messaggi: 2980
- Iscritto il: dom 17 apr 2005, 0:00
- Slackware: 13.1
- Kernel: 2.6.37-smp
- Desktop: KDE 4.5.3
Re: NTFS-3g
Esempio pratico dal mio /etc/fstab
Nel mio caso, Windows XP è nella partizione /dev/sda1 (hard disk SATA) montata su /mnt/WindowsXP.
Codice: Seleziona tutto
/dev/sda1 /mnt/WindowsXP ntfs-3g silent,umask=0,no_def_opts,allow_other,locale=it_IT@euro 0 0- sya54M
- Master

- Messaggi: 1665
- Iscritto il: mer 6 giu 2007, 14:44
- Nome Cognome: Andrea Peluso
- Slackware: 64-current
- Kernel: ultimo
- Desktop: KDE
- Località: (Salerno)
- Contatta:
Re: NTFS-3g
l'opzione users è giusta, serve a dare il permesso di montaggio ma non di accesso, per potervi accedere serve anche l'opzione umask=000
nel caso di phobos3576 ad esempio (che non ha messo l'opzione users) ha accesso come utente ma solo se la partizione è gia stata montata da root e infatti non avendo specificato noauto viene montata all'avvio
se non vuoi avere problemi di codifica con lettere accentate nei nomi metti anche l'opzione locale=it_IT oppure locale=it_IT@euro come ha fatto phobos3576
nel caso di phobos3576 ad esempio (che non ha messo l'opzione users) ha accesso come utente ma solo se la partizione è gia stata montata da root e infatti non avendo specificato noauto viene montata all'avvio
se non vuoi avere problemi di codifica con lettere accentate nei nomi metti anche l'opzione locale=it_IT oppure locale=it_IT@euro come ha fatto phobos3576
- murdock
- Linux 2.x

- Messaggi: 477
- Iscritto il: ven 25 mag 2007, 12:58
- Slackware: 64 14.1
- Kernel: 3.18.3
- Desktop: KDE 4.14.3
- Contatta:
Re: NTFS-3g
Non si finisce mai di imparare...
Saluti,
MuRdOcK
Saluti,
MuRdOcK
-
homer84
- Linux 2.x

- Messaggi: 297
- Iscritto il: gio 9 giu 2005, 0:00
- Slackware: Current
- Località: Torino
Re: NTFS-3g
Non avete risposto alla mia domanda.. Il problema non e di accenti o altre cose, il problema e di PERMESSI perche se monto da root TUTTO( ) funziona perfettamente!
Posso anche accederci da utente, il mio problema e'
COME POSSO FARE IN MODO DA POTER FAR MONTARE ANCHE A USER LA PARTIZIONE??
e possibile che i driver ntfs-3g e fuse non diano il permesso al mio utente???
E se fosse cosi, come posso cambiarli questi permessi??
Vi posto un altro errore sempre al montaggio di uset della partizione
Failed to create /dev/fuse: Permission denied
Error opening partition device: Permission denied
Failed to startup volume: Permission denied
Failed to mount '/dev/hda2': Permission denied
Posso anche accederci da utente, il mio problema e'
COME POSSO FARE IN MODO DA POTER FAR MONTARE ANCHE A USER LA PARTIZIONE??
e possibile che i driver ntfs-3g e fuse non diano il permesso al mio utente???
E se fosse cosi, come posso cambiarli questi permessi??
Vi posto un altro errore sempre al montaggio di uset della partizione
Failed to create /dev/fuse: Permission denied
Error opening partition device: Permission denied
Failed to startup volume: Permission denied
Failed to mount '/dev/hda2': Permission denied
- sya54M
- Master

- Messaggi: 1665
- Iscritto il: mer 6 giu 2007, 14:44
- Nome Cognome: Andrea Peluso
- Slackware: 64-current
- Kernel: ultimo
- Desktop: KDE
- Località: (Salerno)
- Contatta:
Re: NTFS-3g
secondo me ti sei espesso male tu allora
comunque io ti ho gia detto
non te la prendere con chi ti vuole aiutareCome posso settare in modo che il mio utente possa leggere e scrivere su una partizione NTFS di windows?
comunque io ti ho gia detto
quindi se non va prova ad aggiungere il tuo utente ad altri gruppi tipo il gruppo disk o altri, non so di preciso qualel'opzione users è giusta, serve a dare il permesso di montaggio
- phobos3576
- Staff

- Messaggi: 2980
- Iscritto il: dom 17 apr 2005, 0:00
- Slackware: 13.1
- Kernel: 2.6.37-smp
- Desktop: KDE 4.5.3
Re: NTFS-3g
Beh, ma allora i problemi sono altri!homer84 ha scritto:Vi posto un altro errore sempre al montaggio di uset della partizione
Failed to create /dev/fuse: Permission denied
Error opening partition device: Permission denied
Failed to startup volume: Permission denied
Failed to mount '/dev/hda2': Permission denied
Da root apri una console e digita:
Codice: Seleziona tutto
modprobe fuseNTFS-3G richiede il modulo fuse; la libreria libfuse, invece, non è più necessaria con le versioni più recenti di NTFS-3G.
Pensandoci bene, però, il problema che ottieni è del tutto normale; tu stai cercando di eseguire il comando mount da utente normale e ciò non è possibile a meno di non cambiare i permessi a quel comando (che è riservato solo a root). Cambiare i permessi ai comandi riservati a root non è mai una buona idea!
Io non capisco che problema ci sia a mettere tutto il necessario in /etc/fstab e a riavviare il computer; dopo, accedi come utente normale, apri KDE, clicchi con il tasto destro sul Desktop e selezioni "Crea" - "Collegamento a dispositivo" - "Disco rigido".
A quel dispositivo dai il nome "Windows" e lo associ al device dove è montato lo stesso Windows; a questo punto, ti basta cliccare sull'icona creata sul desktop per accedere alla partizione Windows.
-
homer84
- Linux 2.x

- Messaggi: 297
- Iscritto il: gio 9 giu 2005, 0:00
- Slackware: Current
- Località: Torino
Re: NTFS-3g
Il comando mount e' a disposizione del mio utente, trant'e che se avessi una partizione FAT32 windows potrei montarla e smontarla a mio piacimento, anche una normale partizione ntfs potrei montare mettendo come opzione del file system ntfs, pero questo non mi permette di scriverci su (e di queste cose sono sicuro, dato che fino a ieri lo usavo cosi)!!
Solo che ora mi interessa anche scriverci su, eventualmente anche file grossi! In un precedente post mi era stato detto di installare fuse + ntfs-3g cosa che ho fatto, e infatti ora funziona tutto DA ROOT, l'unica cosa e' che volevo fare in modo di poter fare il mount anche da user, tutto li!!
Non mi interessa come fare con KDE perche vorrei capire anche il perche non me lo fa fare da user (in teoria dovrebbe perche ho messo users nel mio fstab) e poi non mi piace come soluzione appoggiarmi a KDE, preferisco gestirmi questi problemi da konsole!
Solo che ora mi interessa anche scriverci su, eventualmente anche file grossi! In un precedente post mi era stato detto di installare fuse + ntfs-3g cosa che ho fatto, e infatti ora funziona tutto DA ROOT, l'unica cosa e' che volevo fare in modo di poter fare il mount anche da user, tutto li!!
Non mi interessa come fare con KDE perche vorrei capire anche il perche non me lo fa fare da user (in teoria dovrebbe perche ho messo users nel mio fstab) e poi non mi piace come soluzione appoggiarmi a KDE, preferisco gestirmi questi problemi da konsole!
- conraid
- Staff

- Messaggi: 13631
- Iscritto il: gio 14 lug 2005, 0:00
- Nome Cognome: Corrado Franco
- Slackware: current64
- Desktop: kde
- Località: Livorno
- Contatta:
Re: NTFS-3g
Leggi qui, devi cambiare i permessi di ntfs-3ghomer84 ha scritto: Non mi interessa come fare con KDE perche vorrei capire anche il perche non me lo fa fare da user (in teoria dovrebbe perche ho messo users nel mio fstab) e poi non mi piace come soluzione appoggiarmi a KDE, preferisco gestirmi questi problemi da konsole!
http://ntfs-3g.org/support.html#useroption
Anche se io preferisco lavorare con sudo a dire il vero, infatti in /etc/sudoers ho queste righe
Codice: Seleziona tutto
Cmnd_Alias MOUNT = /sbin/mount, /sbin/umount
%users LO=(ALL) NOPASSWD: MOUNT