Errore al boot su dbus + madwifi e 2.6.25.4
Moderatore: Staff
Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
- corrado
- Linux 2.x

- Messaggi: 218
- Iscritto il: dom 13 feb 2005, 0:00
- Nome Cognome: corrado
- Slackware: current
- Kernel: 2.6.29.6-smp
- Desktop: kde-4
- Località: isola del liri
- Contatta:
Errore al boot su dbus + madwifi e 2.6.25.4
Ciao a tutti, ho appena terminato l'aggiornamento dalla 12.0 alla 12.1.
Sembra essere andato tutto bene, ma alla fine del boot mi si presenta una scritta rossa che mi dice:
"error: Unable to connect to dbus session bus (running as root?)"
Sapete darmi qualche notizia sul motivo di tale messaggio?
Saluti
corrado
Sembra essere andato tutto bene, ma alla fine del boot mi si presenta una scritta rossa che mi dice:
"error: Unable to connect to dbus session bus (running as root?)"
Sapete darmi qualche notizia sul motivo di tale messaggio?
Saluti
corrado
Ultima modifica di corrado il dom 25 mag 2008, 2:24, modificato 2 volte in totale.
- conraid
- Staff

- Messaggi: 13631
- Iscritto il: gio 14 lug 2005, 0:00
- Nome Cognome: Corrado Franco
- Slackware: current64
- Desktop: kde
- Località: Livorno
- Contatta:
Re: Errore al boot su dbus
Non sai che programma ti da quell'errore?corrado ha scritto:Ciao a tutti, ho appena terminato l'aggiornamento dalla 12.0 alla 12.1.
Sembra essere andato tutto bene, ma alla fine del boot mi si presenta una scritta rossa che mi dice:
"error: Unable to connect to dbus session bus (running as root?)"
Sapete darmi qualche notizia sul motivo di tale messaggio?
DBus è avviato?
- corrado
- Linux 2.x

- Messaggi: 218
- Iscritto il: dom 13 feb 2005, 0:00
- Nome Cognome: corrado
- Slackware: current
- Kernel: 2.6.29.6-smp
- Desktop: kde-4
- Località: isola del liri
- Contatta:
Re: Errore al boot su dbus
Non so a cosa sia dovuto. L'errore compare al boot dopo l'avvio del driver hpssd (mi sembra si chiami così) e poco prima del prompt per il login.
Ho ricompilato anche il kernel (2.6.25.4) ed è sorto un problema ancora più grave:
il boot si ferma dopo il "Triggering udev events: ..." subito dopo il "Going multiuser..." con qualsiasi kernel provi a farlo.
Soluzione drastica?
Saluti
corrado
Ho ricompilato anche il kernel (2.6.25.4) ed è sorto un problema ancora più grave:
il boot si ferma dopo il "Triggering udev events: ..." subito dopo il "Going multiuser..." con qualsiasi kernel provi a farlo.
Soluzione drastica?
Saluti
corrado
- d4z_c0nf
- Packager

- Messaggi: 1296
- Iscritto il: mar 14 mar 2006, 18:07
- Nome Cognome: Rocco Aliberti
- Slackware: 14.2-current64
- Kernel: 4.14.73
- Desktop: awesomeWM
- Località: Pinerolo
Re: Errore al boot su dbus
Magari ricompila il kernel con il config del generic o dell'huge di Pat, poi se funziona scremi.corrado ha scritto:Non so a cosa sia dovuto. L'errore compare al boot dopo l'avvio del driver hpssd (mi sembra si chiami così) e poco prima del prompt per il login.
Ho ricompilato anche il kernel (2.6.25.4) ed è sorto un problema ancora più grave:
il boot si ferma dopo il "Triggering udev events: ..." subito dopo il "Going multiuser..." con qualsiasi kernel provi a farlo.
Soluzione drastica?
Saluti
corrado
Per quanto riguarda dbus non so che dirti, però una cosa sullo script di hp, nella 12.1 è segnalato che non deve essere più lanciato all'avvio, il pacchetto hplip è proprio cambiato. Quindi ti consiglio ti togliere lo script rc.hplip (una cosa del genere) dal path /etc/rc.d/
rock
- corrado
- Linux 2.x

- Messaggi: 218
- Iscritto il: dom 13 feb 2005, 0:00
- Nome Cognome: corrado
- Slackware: current
- Kernel: 2.6.29.6-smp
- Desktop: kde-4
- Località: isola del liri
- Contatta:
Re: Errore al boot su dbus
Il problema è che ora non parte più!d4z_c0nf ha scritto: Magari ricompila il kernel con il config del generic o dell'huge di Pat, poi se funziona scremi.
Per quanto riguarda dbus non so che dirti, però una cosa sullo script di hp, nella 12.1 è segnalato che non deve essere più lanciato all'avvio, il pacchetto hplip è proprio cambiato. Quindi ti consiglio ti togliere lo script rc.hplip (una cosa del genere) dal path /etc/rc.d/
rock
Il boot si blocca dopo il triggering udev events.
Saluti
corrado
- d4z_c0nf
- Packager

- Messaggi: 1296
- Iscritto il: mar 14 mar 2006, 18:07
- Nome Cognome: Rocco Aliberti
- Slackware: 14.2-current64
- Kernel: 4.14.73
- Desktop: awesomeWM
- Località: Pinerolo
Re: Errore al boot su dbus
Puoi sempre avviare dal cd di installazione della 12 o 12.1.corrado ha scritto:Il problema è che ora non parte più!d4z_c0nf ha scritto: Magari ricompila il kernel con il config del generic o dell'huge di Pat, poi se funziona scremi.
Per quanto riguarda dbus non so che dirti, però una cosa sullo script di hp, nella 12.1 è segnalato che non deve essere più lanciato all'avvio, il pacchetto hplip è proprio cambiato. Quindi ti consiglio ti togliere lo script rc.hplip (una cosa del genere) dal path /etc/rc.d/
rock
Il boot si blocca dopo il triggering udev events.
Saluti
corrado
Montare la partizione dove hai la slackware installata
mkdir slack
mount /dev/hdaN(o sdaN) /slack
chroot /slack
ti prendi i pacchetti dell'huge di pat (non dimenticare anche i modules) e li installi
dai
lilo -v
riavvii
e dovresti stare al punto di partenza.
rock
- corrado
- Linux 2.x

- Messaggi: 218
- Iscritto il: dom 13 feb 2005, 0:00
- Nome Cognome: corrado
- Slackware: current
- Kernel: 2.6.29.6-smp
- Desktop: kde-4
- Località: isola del liri
- Contatta:
Re: Errore al boot su dbus
Grazie per i consigli.d4z_c0nf ha scritto: Puoi sempre avviare dal cd di installazione della 12 o 12.1.
Montare la partizione dove hai la slackware installata
mkdir slack
mount /dev/hdaN(o sdaN) /slack
chroot /slack
ti prendi i pacchetti dell'huge di pat (non dimenticare anche i modules) e li installi
dai
lilo -v
riavvii
e dovresti stare al punto di partenza.
rock
Stavo provando, bootando con il dvd della 12.0, a rifare l'update di tutta la distro (la 12.1 ce l'ho in una dir della home...). Durante il boot ho notato che il passo successivo al "Triggering udev etc etc" è il lancio di inet1.
Non ho fatto il chroot, possono esserci problemi?
Saluti
corrado
- d4z_c0nf
- Packager

- Messaggi: 1296
- Iscritto il: mar 14 mar 2006, 18:07
- Nome Cognome: Rocco Aliberti
- Slackware: 14.2-current64
- Kernel: 4.14.73
- Desktop: awesomeWM
- Località: Pinerolo
Re: Errore al boot su dbus
Beh, il problema è che tu hai lanciato lilo del disco di installazione, se non fai il chroot lilo si prende di default il lilo.conf che sta in /etc, quindi senza il chroot quel lilo.conf non è il "tuo", visto che il tuo sta in /slack/etc/lilo.conf.corrado ha scritto:Grazie per i consigli.d4z_c0nf ha scritto: Puoi sempre avviare dal cd di installazione della 12 o 12.1.
Montare la partizione dove hai la slackware installata
mkdir slack
mount /dev/hdaN(o sdaN) /slack
chroot /slack
ti prendi i pacchetti dell'huge di pat (non dimenticare anche i modules) e li installi
dai
lilo -v
riavvii
e dovresti stare al punto di partenza.
rock
Stavo provando, bootando con il dvd della 12.0, a rifare l'update di tutta la distro (la 12.1 ce l'ho in una dir della home...). Durante il boot ho notato che il passo successivo al "Triggering udev etc etc" è il lancio di inet1.
Non ho fatto il chroot, possono esserci problemi?
Saluti
corrado
Scusami ma poi senza fare il chroot dove hai installato il kernel?
Riavvia col cd e fai il chroot.
rock
di default
- corrado
- Linux 2.x

- Messaggi: 218
- Iscritto il: dom 13 feb 2005, 0:00
- Nome Cognome: corrado
- Slackware: current
- Kernel: 2.6.29.6-smp
- Desktop: kde-4
- Località: isola del liri
- Contatta:
Re: Errore al boot su dbus + Non parte più
Ho rifatto la procedura di upgrade dalla 12.0 alla 12.1 partendo dal dvd della 12.0.
In questo modo il pc riparte. Ho ricompilato il kernel 2.6.25.4 ed è ripartito anche con questo.
Ho iniziato allora a ricompilare il driver nvidia (tutto ok) e madwifi... ed è qui che nascono i problemi.
Installo il tgz e quando provo a caricare il modulo (modprobe ath_pci) ottengo dei messaggi incomprensibili da syslogd (si nota un kernel Oops...). Da questo punto in poi non funziona nemmeno il comando ifconfig (nel senso che se do il comando in konsole non accade nulla, non vedo più eth0 ed lo).
Il kernel l'ho ricompilato con il config che ho usato, con successo, anche sul 2.6.25.
Per creare il tgz di madwifi ho usato lo slackbuild di alien http://www.slackware.com/~alien/slackbuilds/madwifi/pkg
La versione del driver è la 0.9.3.3.
Non so se mi sono perso qualcosa, ma con la 12.0 ed il 2.6.25.4 i driver madwifi non mi avevano dato problemi.
Qualcuno ha qualche dritta?
Saluti
corrado
P.S. L'errore al boot su dbus rimane sempre.
In questo modo il pc riparte. Ho ricompilato il kernel 2.6.25.4 ed è ripartito anche con questo.
Ho iniziato allora a ricompilare il driver nvidia (tutto ok) e madwifi... ed è qui che nascono i problemi.
Installo il tgz e quando provo a caricare il modulo (modprobe ath_pci) ottengo dei messaggi incomprensibili da syslogd (si nota un kernel Oops...). Da questo punto in poi non funziona nemmeno il comando ifconfig (nel senso che se do il comando in konsole non accade nulla, non vedo più eth0 ed lo).
Il kernel l'ho ricompilato con il config che ho usato, con successo, anche sul 2.6.25.
Per creare il tgz di madwifi ho usato lo slackbuild di alien http://www.slackware.com/~alien/slackbuilds/madwifi/pkg
La versione del driver è la 0.9.3.3.
Non so se mi sono perso qualcosa, ma con la 12.0 ed il 2.6.25.4 i driver madwifi non mi avevano dato problemi.
Qualcuno ha qualche dritta?
Saluti
corrado
P.S. L'errore al boot su dbus rimane sempre.
- conraid
- Staff

- Messaggi: 13631
- Iscritto il: gio 14 lug 2005, 0:00
- Nome Cognome: Corrado Franco
- Slackware: current64
- Desktop: kde
- Località: Livorno
- Contatta:
Re: Errore al boot su dbus + Non parte più
Ma che chipset hai?corrado ha scritto: Qualcuno ha qualche dritta?
Con i 2.6.25 i driver atheros sono compresi nel kernel. Se non hai bisogno di qualcosa di specifico, non c'è più necessità di usare madwifi
Ed i pacchetti che vedo da Alien Bob sono per il kernel 2.6.24.5 e vedo sono 0.9.4
Stai attento, se prendi un pacchetto di driver, deve essere compilato per lo stesso kernel e possibilmente quelli per slackware 12.1
Ma se usi il kernel 2.6.25.X o non usi madwifi o disabiliti il supporto nel kernel e ti ricompili "da solo" i driver
- corrado
- Linux 2.x

- Messaggi: 218
- Iscritto il: dom 13 feb 2005, 0:00
- Nome Cognome: corrado
- Slackware: current
- Kernel: 2.6.29.6-smp
- Desktop: kde-4
- Località: isola del liri
- Contatta:
Re: Errore al boot su dbus + Non parte più
Ho compilato il kernel con il modulo atheros.conraid ha scritto:Ma che chipset hai?corrado ha scritto: Qualcuno ha qualche dritta?
Con i 2.6.25 i driver atheros sono compresi nel kernel. Se non hai bisogno di qualcosa di specifico, non c'è più necessità di usare madwifi
Ed i pacchetti che vedo da Alien Bob sono per il kernel 2.6.24.5 e vedo sono 0.9.4
Stai attento, se prendi un pacchetto di driver, deve essere compilato per lo stesso kernel e possibilmente quelli per slackware 12.1
Ma se usi il kernel 2.6.25.X o non usi madwifi o disabiliti il supporto nel kernel e ti ricompili "da solo" i driver
Il modulo non è più ath_pci.
Ora l'interfaccia di rete mi viene vista come wlan0 e non più come ath0.
Ho provato ad adattare i comandi che prima usavo sostituendo wlan0 ad ath0 ma senza successo; i comandi sono questi:
Codice: Seleziona tutto
ifconfig eth0 down
ifconfig wlan0 a.b.c.d. netmask 255.255.255.0 up
iwconfid wlan0 essid "essid-mia-rete"
iwpriv authmode 2
iwconfig wlan0 key MIA-CHIAVE
route add default gw ip-mio-routerSaluti
corrado
- conraid
- Staff

- Messaggi: 13631
- Iscritto il: gio 14 lug 2005, 0:00
- Nome Cognome: Corrado Franco
- Slackware: current64
- Desktop: kde
- Località: Livorno
- Contatta:
Re: Errore al boot su dbus + madwifi e 2.6.25.4
Il fatto che sia ath0 o wlan0 puoi modificarlo con udev
guarda il file
/etc/udev/rules.d/70-persistent-net.rules
e modificalo secondo le tue necessità
guarda il file
/etc/udev/rules.d/70-persistent-net.rules
e modificalo secondo le tue necessità
- corrado
- Linux 2.x

- Messaggi: 218
- Iscritto il: dom 13 feb 2005, 0:00
- Nome Cognome: corrado
- Slackware: current
- Kernel: 2.6.29.6-smp
- Desktop: kde-4
- Località: isola del liri
- Contatta:
Re: Errore al boot su dbus + madwifi e 2.6.25.4
Non è un problema...ero solo abituato a vedere ath0 e non wlan0.conraid ha scritto:Il fatto che sia ath0 o wlan0 puoi modificarlo con udev
guarda il file
/etc/udev/rules.d/70-persistent-net.rules
e modificalo secondo le tue necessità
L'interfaccia la tiro su, il router me la trova come "dispositivo collegato" ma se metto down la eth0 e provo a navigare con la wlan0 non ci riesco. Ho postato i miei file di configurazione su un thread già aperto nella sezione hardware.
Non riesco a capire dove sia l'errore.
Saluti
corrado
EDIT: nei "dispositivi collegati" che posso vedere sul router, ci sono 2 host con ip diverso ma il MAC address è lo stesso, ed è quello della scheda eth0