hplip non parte

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Zav0k
Linux 0.x
Linux 0.x
Messaggi: 63
Iscritto il: dom 6 mag 2007, 9:41
Slackware: current
Kernel: 2.6.37.3-smp
Desktop: Kde 4.4.5
Località: Fucecchio

hplip non parte

Messaggio da Zav0k »

Salve a tutti, ho aggiornato la mia slack alla versione current e sto trovando qualche difficoltà :? .
Vi spiego le prove che ho fatto:
- ho lanciato il comando

Codice: Seleziona tutto

root@krasus:/home/theZeus# hp-setup

HP Linux Imaging and Printing System (ver. 3.9.4b)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unable to load Qt4 support. Is it installed?
Perchè mi chiede se ho le qt4? :-k
Le qt4 le ho alla versione 4.5.1, ho provato ha reinstallarle ed anche a fare il downgrade alla versione 4.5.0.....ma niente.

- ho provato con:

Codice: Seleziona tutto

root@krasus:/home/theZeus# hp-check

HP Linux Imaging and Printing System (ver. 3.9.4b)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper
dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux krasus 2.6.29.1-smp #2 SMP Fri Apr 3 01:59:53 CDT 2009 i686 Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz GenuineIntel GNU/Linux

Distribution:
unknown 0.0

HPOJ running?
No, HPOJ is not running (OK).

Checking Python version...
OK, version 2.6.2 installed

Checking PyQt 4.x version...
Traceback (most recent call last):
  File "/usr/bin/hp-check", line 297, in <module>
    from PyQt4 import QtCore
ImportError: No module named sip
root@krasus:/home/theZeus#
Ma anche sip ce l'ho installato alla versione 4.7.9 e Pyqt4 alla 4.4.4. :cry:
Non riesco a capire dove sto sbagliando, a qualcuno di voi è mai capitato???

Avatar utente
tigerwalk
Linux 3.x
Linux 3.x
Messaggi: 890
Iscritto il: lun 25 feb 2008, 22:08
Nome Cognome: Giuliano della Vecchia
Slackware: 13.37-14.2
Kernel: 3.10.17-tiger / 4.4.88-smp
Desktop: kde4/xfce4
Località: Napoli

Re: hplip non parte

Messaggio da tigerwalk »

Zav0k ha scritto:Salve a tutti, ho aggiornato la mia slack alla versione current e sto trovando qualche difficoltà :? .
Vi spiego le prove che ho fatto:
- ho lanciato il comando

Codice: Seleziona tutto

root@krasus:/home/theZeus# hp-setup

HP Linux Imaging and Printing System (ver. 3.9.4b)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unable to load Qt4 support. Is it installed?
Perchè mi chiede se ho le qt4? :-k
Le qt4 le ho alla versione 4.5.1, ho provato ha reinstallarle ed anche a fare il downgrade alla versione 4.5.0.....ma niente.

- ho provato con:

Codice: Seleziona tutto

root@krasus:/home/theZeus# hp-check

HP Linux Imaging and Printing System (ver. 3.9.4b)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper
dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux krasus 2.6.29.1-smp #2 SMP Fri Apr 3 01:59:53 CDT 2009 i686 Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz GenuineIntel GNU/Linux

Distribution:
unknown 0.0

HPOJ running?
No, HPOJ is not running (OK).

Checking Python version...
OK, version 2.6.2 installed

Checking PyQt 4.x version...
Traceback (most recent call last):
  File "/usr/bin/hp-check", line 297, in <module>
    from PyQt4 import QtCore
ImportError: No module named sip
root@krasus:/home/theZeus#
Ma anche sip ce l'ho installato alla versione 4.7.9 e Pyqt4 alla 4.4.4. :cry:
Non riesco a capire dove sto sbagliando, a qualcuno di voi è mai capitato???
guarda il post seguente:
viewtopic.php?f=2&t=27359&p=241296#p241296
vedi se hai installato i pacchetti per la compatibilità con applicazioni kde/qt

Zav0k
Linux 0.x
Linux 0.x
Messaggi: 63
Iscritto il: dom 6 mag 2007, 9:41
Slackware: current
Kernel: 2.6.37.3-smp
Desktop: Kde 4.4.5
Località: Fucecchio

Re: hplip non parte

Messaggio da Zav0k »

tigerwalk ha scritto: guarda il post seguente:
viewtopic.php?f=2&t=27359&p=241296#p241296
vedi se hai installato i pacchetti per la compatibilità con applicazioni kde/qt
Ho controllato i pacchetti sono tutti aggiornati. :(

Rispondi