Configurazione audio

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Alexander
Linux 0.x
Linux 0.x
Messaggi: 27
Iscritto il: dom 19 dic 2010, 11:24
Desktop: xfce

Configurazione audio

Messaggio da Alexander »

Ho provato a cercare sul forum, mentre sulla guida non riesco a capire come fate.
Come posso fare per configurare la scheda audio?

p.s: Non riesco a installare openarena! uff!

Xunyl
Linux 1.x
Linux 1.x
Messaggi: 159
Iscritto il: gio 28 gen 2010, 15:57
Slackware: 14 - 64 bit
Kernel: 3.6.2
Desktop: openbox

Re: Configurazione audio

Messaggio da Xunyl »

Per la gestione del mixer apri un terminale e scrivi:

Codice: Seleziona tutto

$ alsamixer
Verifica che i controlli audio siano abilitati (non deve esserci MM sotto ma 00, per cambiare premi M) e regola i volumi.
Quando hai finito premi Esc, diventa root

Codice: Seleziona tutto

# su
e dai un bel

Codice: Seleziona tutto

# alsactl store
# alsactl restore
per quanto riguarda openarena scarica e installa questo
http://repository.slacky.eu/slackware-1 ... h-1srd.tgz

Ciao, Xunyl

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar 30 nov 2004, 0:00

Re: Configurazione audio

Messaggio da gohanz »

Proma di tutto, per configurare la scheda audio, ti conviene anche lanciare da terminale.

Codice: Seleziona tutto

alsaconf

Avatar utente
nyquist
Linux 2.x
Linux 2.x
Messaggi: 268
Iscritto il: sab 2 ago 2008, 16:02
Nome Cognome: Cristiano Urban
Slackware: 14.2 multilib
Kernel: 4.4.208
Desktop: KDE
Località: Gonars (UD)
Contatta:

Re: Configurazione audio

Messaggio da nyquist »

Se non ricordo male, dopo aver utilizzato alsaconf, devi anche aggiungere il tuo utente al gruppo audio presente nel file /etc/group

Xunyl
Linux 1.x
Linux 1.x
Messaggi: 159
Iscritto il: gio 28 gen 2010, 15:57
Slackware: 14 - 64 bit
Kernel: 3.6.2
Desktop: openbox

Re: Configurazione audio

Messaggio da Xunyl »

nyquist ha scritto:Se non ricordo male, dopo aver utilizzato alsaconf, devi anche aggiungere il tuo utente al gruppo audio presente nel file /etc/group
Non è necessario se è stato già fatto durante l'installazione.

dexter
Linux 2.x
Linux 2.x
Messaggi: 396
Iscritto il: mer 2 giu 2004, 0:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3
Contatta:

Re: Configurazione audio

Messaggio da dexter »

salve a tutti,
ho una slack 13.1 su un portatile hp. Questo ha una scheda audio intel HDA e ho dei problemi con il microfono.
Con skype il microfono, impostato su default, mi funziona abbastanza bene (anche se ho dovuto provare varie volte a modificare i valori nel mixer).
con gli altri programmi tipo vlc non funziona. ho provato ache ad inserire il dispositivo default per il microfono ma niente.

Poi quando accendo il pc mi escono dei WARNING e mi dice che mancano dei .conf e /etc/modprobe.d/sound potrebbe essere ignorato.

Qualcuno ha avuto lo stesso problema?

Avatar utente
lablinux
Linux 4.x
Linux 4.x
Messaggi: 1136
Iscritto il: gio 27 nov 2008, 12:23
Desktop: Gnome
Distribuzione: Debian testing
Località: Rho

Re: Configurazione audio

Messaggio da lablinux »

La mia scheda audio funziona cosi:
in "/etc/modprobe.d/sound"

Codice: Seleziona tutto

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-m4 enable_msi=1
Il mio portatile è un dv7.

P.S. il microfono non so se funziona, non l'ho mai usato.
P.S1 il settaggio l'ho tratto da http://forum.ubuntu-it.org/index.php/to ... 777.0.html


Ciao Michele.

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Configurazione audio

Messaggio da phobos3576 »

lablinux ha scritto:La mia scheda audio funziona cosi:
in "/etc/modprobe.d/sound"
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=hp-m4 enable_msi=1

Il mio portatile è un dv7.

P.S. il microfono non so se funziona, non l'ho mai usato.
P.S1 il settaggio l'ho tratto da http://forum.ubuntu-it.org/index.php/to ... 777.0.html


Ciao Michele.
Pure io ho un DV7 e mi stavo chiedendo se l'opzione "hp-m4" fosse adatta per questo modello di portatile (visto che si riferisce ad una sorta di netbook "HP Mini"); in effetti, se metto "hp-m4" mi compaiono nuovi controlli in KMix.
Il LED del tasto "mute" rimane sempre acceso (anche se il mute funziona); con la Kubuntu 10.10 (che usa PulseAudio), sullo stesso portatile, il LED si accende e si spegne correttamente .

Ho avuto pure io lo stesso problema di Dexter.

Su Skype il microfono integrato viene visto come alsa://default
Su MEncoder il microfono integrato viene visto come alsa://default o alsa://hw:0,0
Su VLC il microfono integrato viene visto come oss://dev/audio

Di default, VLC usa ALSA; per obbligarlo ad usare OSS, nella finestra "Apri periferica di acquisizione" bisogna mettere /dev/audio come periferica audio e poi selezionare "Show more options" (in basso) e sostituire "alsa" con "oss".

Purtroppo, l'acquisizione audio con OSS è pesantissima e, infatti, certi formati video vanno a scatti; con ALSA questo problema non si presenta.

dexter
Linux 2.x
Linux 2.x
Messaggi: 396
Iscritto il: mer 2 giu 2004, 0:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3
Contatta:

Re: Configurazione audio

Messaggio da dexter »

ho provato ad inserire vari moduli in /etc/modprobe.d/sound ma non riesco a beccare quello giusto.
io ho un HP Pavillion dv6
sapete qual è quello corretto?

Grazie

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Configurazione audio

Messaggio da phobos3576 »

Con il comando:

Codice: Seleziona tutto

cat /proc/asound/card0/codec#0 | grep Codec
puoi individuare il codec della tua scheda audio.

Poi apri /usr/src/nome-kernel/Documentation/sound/alsa/HD-Audio-Models.txt e guardi se è presente quel codec; ad ogni codec è associata una serie di modelli di scheda audio.

dexter
Linux 2.x
Linux 2.x
Messaggi: 396
Iscritto il: mer 2 giu 2004, 0:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3
Contatta:

Re: Configurazione audio

Messaggio da dexter »

il comando mi da questo output:

Codice: Seleziona tutto

Codec: IDT 92HD81B1X5
Ma nella lista non mi sembra che ci sia

odiusseus
Linux 2.x
Linux 2.x
Messaggi: 352
Iscritto il: sab 30 giu 2007, 14:09
Slackware: 13.0
Kernel: 2.6.32.2
Desktop: kde
Località: roma/vibo valentia
Contatta:

Re: Configurazione audio

Messaggio da odiusseus »

ciao prova a fare questa modifica

Codice: Seleziona tutto

mv /etc/modprobe.d/sound /etc/modprobe.d/sound.conf

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Configurazione audio

Messaggio da phobos3576 »

Segui il consiglio di Odisseus; il file deve chiamarsi sound.conf.

Anche il mio HP Pavilion ha quella identica scheda audio (Codec IDT 92HD81B1X5); non essendo elencata nella documentazione, ho messo model=auto (che usa la configurazione impostata dal BIOS).
Il mio sound.conf è questo:

Codice: Seleziona tutto

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
# module options should go here
options snd-hda-intel model=auto

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
        
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
Come ho scritto in precedenza, ho avuto anche io problemi nel far riconoscere a VLC il microfono integrato; ho risolto installando il package VLC statico di AlienBob e impostando /dev/audio come device audio (gestito però attraverso OSS).

Avatar utente
ildiama
Linux 3.x
Linux 3.x
Messaggi: 536
Iscritto il: mar 27 dic 2005, 16:49
Slackware: mine
Kernel: 2.6.alto..
Desktop: KDE4
Località: Senigallia
Contatta:

Re: Configurazione audio

Messaggio da ildiama »

dexter ha scritto:salve a tutti,
ho una slack 13.1 su un portatile hp. Questo ha una scheda audio intel HDA e ho dei problemi con il microfono.
Con skype il microfono, impostato su default, mi funziona abbastanza bene (anche se ho dovuto provare varie volte a modificare i valori nel mixer).
con gli altri programmi tipo vlc non funziona. ho provato ache ad inserire il dispositivo default per il microfono ma niente.

Poi quando accendo il pc mi escono dei WARNING e mi dice che mancano dei .conf e /etc/modprobe.d/sound potrebbe essere ignorato.

Qualcuno ha avuto lo stesso problema?
Sì, io. Su un portatile DELL.
Da me tutto si è risolto aggiornando il kernel e reinstallando la scheda grafica (alsaconf). Gli WARNING che dici se leggi bene possono essere sistemati. Praticamente ti dicono solo che la posizione attuale dei file di configurazione è deprecata e questi dovrebbero essere spostati e/o rinominati

dexter
Linux 2.x
Linux 2.x
Messaggi: 396
Iscritto il: mer 2 giu 2004, 0:00
Slackware: 12.2
Kernel: 2.6.33.1-smp
Desktop: GnomeSlacky 2.26.3
Contatta:

Re: Configurazione audio

Messaggio da dexter »

phobos3576 ha scritto:Segui il consiglio di Odisseus; il file deve chiamarsi sound.conf.

Anche il mio HP Pavilion ha quella identica scheda audio (Codec IDT 92HD81B1X5); non essendo elencata nella documentazione, ho messo model=auto (che usa la configurazione impostata dal BIOS).
Il mio sound.conf è questo:

Codice: Seleziona tutto

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-hda-intel
# module options should go here
options snd-hda-intel model=auto

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
        
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
Come ho scritto in precedenza, ho avuto anche io problemi nel far riconoscere a VLC il microfono integrato; ho risolto installando il package VLC statico di AlienBob e impostando /dev/audio come device audio (gestito però attraverso OSS).
ho configurato il file come hai detto. ho fatto un mv su sound e l'ho fatto diventare sound.conf poi ho copiato le tue righe nel file.
L'unica cosa che vedo in più è mic e front mic
I warning non sono usciti.
Capita anche a voi che quando fate una chiamata su skype non si sente l'audio di un video? ho provato con vlc e xine ma niente

grazie di tutto

Rispondi