Vmware problema.....

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
Heidegger
Linux 2.x
Linux 2.x
Messaggi: 246
Iscritto il: lun 28 mar 2005, 0:00
Località: Roma
Contatta:

Vmware problema.....

Messaggio da Heidegger »

Salve ho installato correttamente Vmware, ho un Slack 10.0 con kernel di base 2.4.26
Ora......dentro vmware ho installato windows xp professional giusto perchè così quando mi serve necessariamente di usarlo non devo arrestare slack :-D
Sembrava andare tutto a gonfie vele ma al riavvio successivo se tento di far partire l'emulazione di xp mi da 4 errori:
1 Could not open /dev/vmmon: No such device.
Please make sure that the kernel module `vmmon' is loaded.

2 Failed to initialize monitor device.

3 Unable to change virtual machine power state: Cannot find a valid peer process to connect to.

4 Failed to reply to the dialog: Pipe: Read failed

Ora quello che non capisco è questo: se io disinstallalo Vmware e lo reinstallo funziona tutto quanto....posso installarci dentro qualsiasi sistema. Se poi riavvio una o due volte quando tento di riaccedere alla macchina virtuale mi da questi errori.....perchè? Se ci fosse qualche problema non dovrebbe funzionare da subito.....perchè dopo il "riavvio" non funziona più?
AIUTO :-D
Thanks mitici come al solito.
Bye
Heidegger :-D

Avatar utente
Heidegger
Linux 2.x
Linux 2.x
Messaggi: 246
Iscritto il: lun 28 mar 2005, 0:00
Località: Roma
Contatta:

Messaggio da Heidegger »

Ah comunque vi faccio presente che nel primo errore lui segnale che non trova il dispositivo vmmon sotto /dev
Invece io ho controllato con :
ls /dev/vmmon
ed ovviamente viene rilevato......
spero vi possa essere d'aiuto questo. Ciao e grazie

Avatar utente
DaNiMoTh
Linux 3.x
Linux 3.x
Messaggi: 941
Iscritto il: mar 30 nov 2004, 0:00
Località: irc.syrolnet.org /// #slackware
Contatta:

Messaggio da DaNiMoTh »

per il problema n°1, usa lo script che è stato creato in /etc/init.d chiamato vmware.

Io l'ho spostato in /etc/rc.d/ e l'ho chiamato rc.vmware. Fai così:

# /etc/rc.d/rc.vmware start
#vmware

Avatar utente
Heidegger
Linux 2.x
Linux 2.x
Messaggi: 246
Iscritto il: lun 28 mar 2005, 0:00
Località: Roma
Contatta:

Messaggio da Heidegger »

Grazie sei stato grandioso....dopo aver fatto questo praticamente rifunziona tutto.....ossia tutti gli altri 3 problemi non ci sono più.....unico dubbio ogni volta che avvio il sistema prima di lanciare vmware devo lanciare questo script?
E se lo metto direttamente come comando in /etc/rc.d/rc.local per fare in modo che si lanci da solo all'avvio? Può essere una soluzione? Ciao ti ringrazio tantissimo! :-D

Avatar utente
Heidegger
Linux 2.x
Linux 2.x
Messaggi: 246
Iscritto il: lun 28 mar 2005, 0:00
Località: Roma
Contatta:

Messaggio da Heidegger »

Ok facendo partire lo script in rc.local va tutto benissimo! Ti ringrazio tanto. Bye :-D

pennega
Linux 3.x
Linux 3.x
Messaggi: 607
Iscritto il: dom 4 lug 2004, 0:00
Contatta:

Messaggio da pennega »

ti dovrebbe bastare anche caricare semplicemente il modulo vmmon...
io faccio così e non ho avuto problemi...

Rispondi