problemi vari con mysql
Moderatore: Staff
Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
problemi vari con mysql
salve ragazzi un saluto a tutti quanti Voi, e faccio i mniei complimenti per questo sito sempre di ottimo aiuto!
Sono nuovo di queste parti ho gia letto la parte inerene a mysql di for dummies ed ho dato una sbirciatina nei vari post ma ancora non ho risolto!
I problemi sono i seguenti!
Premetto ho una slackware 10.2 con kernel 2.4.31
da shell
mysql -uroot
la procedura per settare la password
tutto ok, poi passo alla procedura per creare il database e qui arrivano i problemi!
decido a sto punto di ricominciare tutto da capo poichè sono inesperto.
Quindi
mysql -uroot
la risposta è la seguente
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
ci saranno ancora un sacco di problemi ma incominciamo a risolvere uno alla volta, quindi se riesco ad andare avanti vi posto il resto!
Sono nuovo di queste parti ho gia letto la parte inerene a mysql di for dummies ed ho dato una sbirciatina nei vari post ma ancora non ho risolto!
I problemi sono i seguenti!
Premetto ho una slackware 10.2 con kernel 2.4.31
da shell
mysql -uroot
la procedura per settare la password
tutto ok, poi passo alla procedura per creare il database e qui arrivano i problemi!
decido a sto punto di ricominciare tutto da capo poichè sono inesperto.
Quindi
mysql -uroot
la risposta è la seguente
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
ci saranno ancora un sacco di problemi ma incominciamo a risolvere uno alla volta, quindi se riesco ad andare avanti vi posto il resto!
mi scuso
Ragazzi mi scuso per aver tardato a rispondere quanti di voi sono stati così gentili e cortesi nel darmi una mano ed insieme il benvenuto.
A Bart si ho dato un occhiatina sebbene fugace ma mi riprpongo di farlo con + cura!
A DaNiMoTh ho provato con la tu sintassi ovvero
mysql -h localhost -uroot -p[password]
scrivendo quanto dici e mettendo dopo il -pla mia password senza spazi e senza parentesi, (mi scuso per questi piccoli dettagli per te insignificanti, ma tante volte cado im errore) ed il risultato è il seguente:
root@gastone:/home/nicola# mysql -h localhost -uroot -pmia password
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 1 to server version: 4.1.14-log
Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
mysql> create database
-> maximus
-> ;
Query OK, 1 row affected (0.21 sec)
mysql>
penso che sia andato a buon fine e che ho risolto.
A questo punto le domande sono 2.
La prima perchè con l'altra sintassi mi dava quell'errore?
La 2 è perchè dopo
Query OK, 1 row affected (0.21 sec)
mi ridà ancora
mysql> ?
A questo punto esco semplicemente con un ctrl c!!!
A Bart si ho dato un occhiatina sebbene fugace ma mi riprpongo di farlo con + cura!
A DaNiMoTh ho provato con la tu sintassi ovvero
mysql -h localhost -uroot -p[password]
scrivendo quanto dici e mettendo dopo il -pla mia password senza spazi e senza parentesi, (mi scuso per questi piccoli dettagli per te insignificanti, ma tante volte cado im errore) ed il risultato è il seguente:
root@gastone:/home/nicola# mysql -h localhost -uroot -pmia password
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 1 to server version: 4.1.14-log
Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
mysql> create database
-> maximus
-> ;
Query OK, 1 row affected (0.21 sec)
mysql>
penso che sia andato a buon fine e che ho risolto.
A questo punto le domande sono 2.
La prima perchè con l'altra sintassi mi dava quell'errore?
La 2 è perchè dopo
Query OK, 1 row affected (0.21 sec)
mi ridà ancora
mysql> ?
A questo punto esco semplicemente con un ctrl c!!!
Ultima modifica di gastone il sab 3 dic 2005, 23:35, modificato 1 volta in totale.
Re: mi scuso
Infine ringrazio gastone 80, e pazienza se ci scambieranno!
Un saluto
Un saluto


