st - compilazione con messggi

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3190
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

st - compilazione con messggi

Messaggio da joe »

Siccome mi sono accorto di qualche stranezza nel comportamento dell'emulatore di terminale st, ho provato varie "manovre" e alla fine ho deciso di controllare se la sua compilazione non ha errori.
In effetti qualcosa è saltato fuori:

Codice: Seleziona tutto

# LANG=en_US.UTF8 make
st build options:
CFLAGS  = -I/usr/X11R6/include  -I/usr/include/uuid -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include  -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -DVERSION="0.8.2" -D_XOPEN_SOURCE=600  -O
LDFLAGS = -L/usr/X11R6/lib -lm -lrt -lX11 -lutil -lXft  -lfontconfig -lfreetype  -lfreetype 
CC      = c99
c99 -I/usr/X11R6/include  `pkg-config --cflags fontconfig`  `pkg-config --cflags freetype2` -DVERSION=\"0.8.2\" -D_XOPEN_SOURCE=600  -O -c st.c
c99 -I/usr/X11R6/include  `pkg-config --cflags fontconfig`  `pkg-config --cflags freetype2` -DVERSION=\"0.8.2\" -D_XOPEN_SOURCE=600  -O -c x.c
c99 -o st st.o x.o -L/usr/X11R6/lib -lm -lrt -lX11 -lutil -lXft  `pkg-config --libs fontconfig`  `pkg-config --libs freetype2` 
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libm.so when searching for -lm
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libm.a when searching for -lm
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/librt.so when searching for -lrt
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/librt.a when searching for -lrt
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libX11.so when searching for -lX11
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libutil.so when searching for -lutil
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libutil.a when searching for -lutil
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libXft.so when searching for -lXft
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libfontconfig.so when searching for -lfontconfig
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libfreetype.so when searching for -lfreetype
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libfreetype.so when searching for -lfreetype
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libgcc_s.so.1 when searching for libgcc_s.so.1
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libc.so when searching for -lc
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libc.a when searching for -lc
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libgcc_s.so.1 when searching for libgcc_s.so.1
Domanda 1
Quegli errori sono tali da compromettere il corretto funzionamento dell'eseguibile finale "st" (chiedo perché avviarsi si avvia e funziona quasi come sempre, dico quasi perché ho notato qualche problema in combinata con screen e uno strano comportamento con vim del tipo che devo mettere syntax off altrimenti alcune scritte vengono proprio coperte.

Domanda 2
Da cosa possono essere causati?

Dettagli sul sistema:
Slackware current, aggiornata l'altro giorno.
Sistema multilib: tanti pacchetti sono sovrascritti dalle versioni multilib di AlienBob, tranne gcc, che ho tenuto quello del repo ufficiale slackware64-current (quindi per 64bit).

Se volete fare un test anche voi è molto semplice:

Codice: Seleziona tutto

wget  https://dl.suckless.org/st/st-0.8.2.tar.gz
tar xvf st-0.8.2.tar.gz
cd st-0.8.2
make clean
make
Grazie in anticipo! :)

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2738
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.5.3-ck1
Desktop: lxde
Località: Pisa
Contatta:

Re: st - compilazione con messggi

Messaggio da ponce »

e' il linker (ld) che quando va linkare le librerie, girando su un sistema multilib, e cercando quelle a 64bit trova nei percorsi anche quelle a 32bit e passa oltre non potendole utilizzare.
questo dipende dal fatto che il sistema di build di st utilizza un file config.mk in cui e' specificato come percorso delle librerie di X /usr/X11R6/lib, che in un sistema Slackware con multilib contiene librerie a 32bit: poi comunque trova lo stesso quelle giuste perche' sono raggiungibili anche nell'altra posizione (/usr/X11R6/lib64 e/o /usr/lib64).
joe ha scritto:
ven 14 feb 2020, 15:09
Quegli errori sono tali da compromettere il corretto funzionamento dell'eseguibile finale "st"
sono messaggi innocui, ma se vuoi eliminarli basta inserire questa riga prima del blocco del "make" nello SlackBuild (che mette il percorso "giusto" nella linea in cui viene specificato dove trovare le librerie di X)

Codice: Seleziona tutto

sed -i "s|lib$|lib$LIBDIRSUFFIX|" config.mk
non e' qualcosa di cui si deve preoccupare il maintainer di st perche' i sistemi multilib non sono supportati da SBo.
joe ha scritto:
ven 14 feb 2020, 15:09
chiedo perché avviarsi si avvia e funziona quasi come sempre, dico quasi perché ho notato qualche problema in combinata con screen e uno strano comportamento con vim del tipo che devo mettere syntax off altrimenti alcune scritte vengono proprio coperte.
per risolvere questi problemi credo che il metodo piu' semplice sia aggiungere questa linea al tuo file ~/.bashrc

Codice: Seleziona tutto

export TERM=screen-256color

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3190
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: st - compilazione con messggi

Messaggio da joe »

In realtà st ha il suo TERM: st-256color.
E da quello che ho letto (perché è un po' che cerco di trovare una soluzione... e alla fine mi sono deciso a chiedere anche qui) andrebbe mantenuto, perché teoricamente è abbinato alle "specifiche" di st descritte in /usr/share/terminfo/s/st-256color.
In ogni caso a

Sinceramente non ci ho capito tanto, avevo chiesto anche su LQ, anche lì mi hanno consigliato di provare a settare TERM, lì dicevano di metterlo ad xterm, ed effettivamente ha funzionato:

Codice: Seleziona tutto

$ echo $TERM
st-256color

$ export TERM=xterm-256color

$ screen
screen partiva normalmente e ricevevo una nuova shell in cui automaticamente TERM era "screen-256color".
Poi una volta uscito da screen terminava con un pacifico

Codice: Seleziona tutto

[screen is terminating]
Ma poi mi sono accorto che pur riavviando, e quindi resettando TERM, il problema non si presentava più. E non è che abbia fatto nulla di ché.
Avevo editato Xresources, ma tra l'altro era roba che riguardava xterm e non st (proprio perché mi ero detto: se st non funge mi sistemo xterm e nel frattempo finche non risolvo ho un terminale funzionante).
Odio quando questi rompicapi sembrano andare apposto da soli senza capire perché e dove stava il problema...

Comunque qualche cosa che continua a non funzionare bene persiste. Vediamo se risco a spiegare chiaramente la cosa, metto il mio xinitrc così ci capiamo meglio:

Codice: Seleziona tutto

$ cat .xinitrc
#!/bin/sh

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
sysresources=/etc/X11/xinit/.Xresources
sysmodmap=/etc/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
    xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
    xmodmap $usermodmap
fi

# Start some programs
slstatus &
#st -e screen &
xterm -e screen &

# Start the window manager:
if [ -z "$DESKTOP_SESSION" -a -x /usr/bin/ck-launch-session ]; then
  exec ck-launch-session /usr/bin/dwm
else
  exec /usr/bin/dwm
fi
A parte il primo pezzo in cui vengono letti i files Xresources Xmodmap e simili, alla fine perima di lanciare il window manager, lanciavo appunto una finestra col terminale st, nel quale si vuole trovare già avviata una sessione "screen".
In pratica parte la sessione grafica e mi ritrovo davanti al naso il terminale st aperto e con dentro già screen che gira, non devo quindi far nulla manualmente (altrimenti dovrei premere la combinazione impostata in "dwm" Alt+shift+Enter per aprire il terminale st, poi digitare screen, così fa già tutto da solo).
E fin qui funziona tutto.
Ora se provo a fare il detach della sessione screen "Ctrl+A D" questa va normalmente in detach e si chiude anche il terminale st (credo sia giusto così, per come era stato lanciato).
Ma l'inghippo si ha uando tento di riportarla in uso facendo l'"attach" lanciando:

Codice: Seleziona tutto

screen -r
A quel punto la sessione screen (che magari aveva aperte N shell con robe anche potenzialmente non salvate o similari)...
a quel punto muore.
Nel senso che mi viene ridato il prompt del terminale "st", e se vado a vedere con "screen -list" la sessione risulta "Dead ?" con tanto di punto interrogativo, come se non sapesse neanche screen cosa sia successo e come.

Ok, la manovra invece non causa alcun problema se il terminale iniziale che lancio da xinitrc è il classico "xterm". In quel caso, parte X con dwm e la finestra xterm aperta con dentro la sua brava sessione screen. A questo punto se mando in detach screen, la finestra xterm si chiude. Ne apro un'altra e digito "screen -r", et voilà: rientro nella sessione screen senza problemi.

Cioè stesse operazioni: il discrimine pare proprio il terminale "st".

Se avete qualche idea di qualche prova che posso fare per cercare di capire dove sta il problema e risolvere.
Comunque in ogni caso graize per la dritta sulla compilazione di st! Allora vado tranquillo... e comunque provo anche a ricompilarlo senza patches, vediamo se cambia il coomportamento :)

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2738
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.5.3-ck1
Desktop: lxde
Località: Pisa
Contatta:

Re: st - compilazione con messggi

Messaggio da ponce »

joe ha scritto:
ven 14 feb 2020, 18:34
Se avete qualche idea di qualche prova che posso fare per cercare di capire dove sta il problema e risolvere.
io proverei a fare come ti ho indicato sopra, senza sovrascrivere la variabile di ambiente TERM in altri file di configurazione (puoi verificare come e' impostata con "set | grep ^TERM"), e metterei anche questo blocco in ~/.bash_profile

Codice: Seleziona tutto

# include .bashrc if it exists
if [ -f ~/.bashrc ]; then
  source ~/.bashrc
fi
o anche solo, ripetendolo

Codice: Seleziona tutto

export TERM=screen-256color
ovviamente, per testare la cosa in modo corretto, dovresti anche uscire da X e rifare login dalla console.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3190
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: st - compilazione con messggi

Messaggio da joe »

Ok, in bash_profile ho già quel blocco:

Codice: Seleziona tutto

$ cat .bash_profile
if [ -f ~/.profile ]; then
        . ~/.profile
fi

if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi

if [ -z "$DISPLAY" ] && [ "$(tty)" = /dev/tty1 ]; then
        exec startx
fi
Qua c'è la variabile TERM se do il comando da terminale st

Codice: Seleziona tutto

$ set|grep ^TERM
TERM=st-256color
E qua dando lo stesso comando da dentro screen:

Codice: Seleziona tutto

$ set|grep ^TERM
TERM=screen-256color
TERMCAP='SC|screen-256color|VT 100/ANSI X3.64 virtual terminal:DO=\E[%dB:LE=\E[%dD:RI=\E[%dC:UP=\E[%dA:bs:bt=\E[Z:cd=\E[J:ce=\E[K:cl=\E[H\E[J:cm=\E[%i%d;%dH:ct=\E[3g:do=^J:nd=\E[C:pt:rc=\E8:rs=\Ec:sc=\E7:st=\EH:up=\EM:le=^H:bl=^G:cr=^M:it#8:ho=\E[H:nw=\EE:ta=^I:is=\E)0:li#47:co#58:am:xn:xv:LP:sr=\EM:al=\E[L:AL=\E[%dL:cs=\E[%i%d;%dr:dl=\E[M:DL=\E[%dM:dc=\E[P:DC=\E[%dP:im=\E[4h:ei=\E[4l:mi:IC=\E[%d@:ks=\E[?1h\E=:che=\E[?1l\E>:vi=\E[?25l:ve=\E[34h\E[?25h:vs=\E[34l:ti=\E[?1049h:te=\E[?1049l:us=\E[4m:ue=\E[24m:so=\E[3m:se=\E[23m:mb=\E[5m:md=\E[1m:mh=\E[2m:mr=\E[7m:me=\E[m:ms:Co#8:pa#64:AF=\E[3%dm:AB=\E[4%dm:op=\E[39;49m:AX:vb=\Eg:G0:as=\E(0:ae=\E(B:ac=\140\140aaffggjjkkllmmnnooppqqrrssttuuvvwwxxyyzz{{||}}~~..--++,,hhII00:po=\E[5i:pf=\E[4i:Km=\E[M:k0=\E[10~:k1=\EOP:k2=\EOQ:k3=\EOR:k4=\EOS:k5=\E[15~:k6=\E[17~:k7=\E[18~:k8=\E[19~:k9=\E[20~:k;=\E[21~:F1=\E[23~:F2=\E[24~:kB=\E[Z:kh=\E[1~:@1=\E[1~:kH=\E[4~:@7=\E[4~:kN=\E[6~:kP=\E[5~:kI=\E[2~:kD=\E[3~:ku=\EOA:kd=\EOB:kr=\EOC:kl=\EOD:'
Provo allora a mettere export TERM=screen-256color in ~/.bashrc e rifaccio login...

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3190
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: st - compilazione con messggi

Messaggio da joe »

Ok, ho modificato anche .xinitrc in modo da far partire st come terminale e non xterm, per fare la prova.

Come già descritto: parte X, parte dwm e viene automaticamente aperto un treminale st che al suo interno lancia screen.
Poi manualmente faccio "ctrl-a d" e mando screen in detach, il terminale st si chiude.
Ne apro un altro sempre di terminale st.
E lì dentro do i seguenti comandi:

Codice: Seleziona tutto

$ set|grep ^TERM
TERM=screen-256color

$ screen -list
There is a screen on:
        16175.pts-0.master      (Detached)
1 Socket in /home/joe/.screen.

$ screen -r

[screen caught signal 11. (core dumped)]

$ screen -r
There is a screen on:
        16175.pts-0.master      (Dead ???)
Remove dead screens with 'screen -wipe'.
There is no screen to be resumed.
Il primo comando mostra che TERM è impostata forzatamente (attraverso ~/.bashrc) al valore che hai suggerito.
Faccio notare che manca la variabile TERMCAP, viene definita solamente se sono dentro screen. Vedi messaggio precedente.

Ok, a questo punto, il secondo comando mostra che c'è la nostra sessione screen dietro le quinte, in detach, tranquilla e funzionante.

Terzo comando tento di rientrare in screen ma la manovra non va a buon fine con l'errore che ho riportato.
Quarto comando dimostra che la sessione screen è data per probabilmente morta. E si è invitati a ripulire con wipe.

In soldoni forzare la variabile TERM a screen-256color non sembra risolvere questo strano comportamento.
Faccio notare, ripeto, che se al posto di avviare automaticamente st, in xinitrc mettessi "xterm -e screen", filerebbe tutto liscio (reattach con screen -r va a buon fine).

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3190
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: st - compilazione con messggi

Messaggio da joe »

Ho tentato diverse strade. Ma il problema persiste.
Tra i vari punti poco chiari che sono saltati fuori ho notato che il database delle funzionalità di ciascun terminale che viene installato in /usr/share/terminfo principalmente attraverso l'installazione di ncurses, verrebbe in parte sovrascritto dall'installazione di "st": nel Makefile lancia proprio la compilazione con "tic" che va ad installare il nuovo file in terminfo/s/st* andando a sovrascrivere 4 files che erano stati messi lì durante l'installazione di "ncurse".
Questo comportamento può essere corretto, o lasciato anche così, alla fine i nuovi files dovrebbero essere meglio perché relativi alla specifica versione di st che abbiamo installato.

Ho fatto qualche prova:
rimosso .Xdefault .screenrc
installato st compilando la versione stabile

Ma il problema di screen che non parte si è nuovamente presentato.
Allora ho tentato la compilazione ed installazione della versione git di st. Prova al buio senza aver capito dove sta il problema.
Risultato, con st-git screen si avvia.
Misteri!

Persiste invece comunque il problema descritto circa il resume di una sessione screen avviata da ~/.xinitrc (st -e screen) e mandata poi in detach.
Quando provo a riesumarla con "screen -r", questo si pianta lì e come già spiegato l'unica è dare ctrl-z e "pkill -9 screen".

Vorrei chiedervi un consiglio visto che non sono così pratico di sviluppo software.
In un caso come questo dove si può provare a far presente la cosa?
In una eventuale mailing list di "suckless st"?
In una mailing di screen?
O dove?

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3190
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: st - compilazione con messggi

Messaggio da joe »

Ho tentato diverse strade. Ma il problema persiste.
Tra i vari punti poco chiari che sono saltati fuori ho notato che il database delle funzionalità di ciascun terminale che viene installato in /usr/share/terminfo principalmente attraverso l'installazione di ncurses, verrebbe in parte sovrascritto dall'installazione di "st": nel Makefile lancia proprio la compilazione con "tic" che va ad installare il nuovo file in terminfo/s/st* andando a sovrascrivere 4 files che erano stati messi lì durante l'installazione di "ncurse".
Questo comportamento può essere corretto, o lasciato anche così, alla fine i nuovi files dovrebbero essere meglio perché relativi alla specifica versione di st che abbiamo installato.
Credo di aver "isolato" il problema.
Dalla prova che ho fatto l'inghippo sta da qualche parte nel file in formato "terminfo" che descrive le funzionalità di "st" a livello di terminale.
A quanto pare c'è qualcosa lì dentro che non va d'accordo con "screen".

Il sorgente di quel file viene installato dallo slackbuild in

/usr/share/st/st.info

In realtà è solo lì per conoscenza, quello che conta è il suo "compilato", anzi "compilati" perché da quello vengono generati 4 binari in formato appunto terminfo. E vengono installati in

Codice: Seleziona tutto

/usr/share/terminfo/s/
st  st-256color  st-meta  st-meta-256color
Di default (si vede nel config.h dai sorgenti del programma) viene impostato "st-256color".
Ecco perché aprendo st e lanciando echo $TERM, risponde proprio st-256color.
Ed effettivamente va pescare quelle informazioni nel file omonimo installato nella dir di sistema sopra indicata /usr/share/terminfo/eccecc.

Ma.... Come dicevo ieri in quella dir si trovano altri files installati lì dal pacchetto ncurse.
Allora ho modificato lo slackbuild in modo da non installare i 4 files terminfo nella dir di sistema.
Li ho comunque compilati ed installati nella mia home nel file "~/.terminfo/s/st*".
E ho fatto la prova di funzionamento di screen prima col file fornito dai sorgenti di st (~/.terminfo/s/st-256color).
Screen, se lanciato a mano da un terminale parte, si riesce a mandare in detach, ma quando si tenta di riesumarlo con "screen -r" va in errore. Inoltre lanciato in automatico con "st -e screen" da ".xinitrc" proprio non parte il cursore resta lì senza neanche il prompt...
Se invece si rinomina quel file tipo in st-256colorbk, st va trovare il file di sistema /usr/share/terminfo/s/st-256color, che è quello di ncurse. Con questo funziona tutto senza problemi:
TERM risulta ovviamente impostata a st-256color.
screen lanciato manualmente parte, lo mando in detach e se do "screen -r" si riesuma.
screen avviato da xinitrc con "st -e screen &", parte, si può mandare in detach e si può riesumare senza errori con "screen -r".

Quindi forse è il caso di farlo presente al team di sviluppo di st. Se vogliono fare qualche test anche loro ed eventualmente risolvere questa incompatibilità tra screen e st (quando quest'ultimo si usa in accoppiata al file delle funzionalità terminfo originale fornito dal progetto st stesso).

Nota:
Per vedere da quale file terminfo sta pescando le informazioni il nostro terminale oltre controllare la variabile $TERM, basta usare "infocmp |less". In cima è riportato.

Codice: Seleziona tutto

$ infocmp |head -n1
#       Reconstructed via infocmp from file: /usr/share/terminfo/s/screen-256color

Codice: Seleziona tutto

$ TERM=st-256colorbk
$ infocmp |head -n1
#       Reconstructed via infocmp from file: /home/joe/.terminfo/s/st-256colorbk
Ultima modifica di joe il mer 19 feb 2020, 22:02, modificato 1 volta in totale.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2738
Iscritto il: mer 5 mar 2008, 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 5.5.3-ck1
Desktop: lxde
Località: Pisa
Contatta:

Re: st - compilazione con messggi

Messaggio da ponce »

prova a scrivere a uno dei due indirizzi in cima al file LICENSE.

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 3190
Iscritto il: ven 27 apr 2007, 11:21
Slackware: 14.2
Kernel: 4.4.38
Desktop: KDE-4.14.21

Re: st - compilazione con messggi

Messaggio da joe »

:thumbright:

Ok, faccio sapere.
Strano che la cosa non avvenga anche sulla stabile.
Se qualcuno di voi "currentisti" vuole fare qualche prova.
st (sia versione stabile che versione git)
screen versione precompilata da repo slackware64

Window Manager dwm (per l'avvio da .xinitrc, non si sa mai, potrebbe anche essere colpa di quest'ultimo in qualche modo ma no saprei).

Rispondi