[RISOLTO]Repository slacky in swaret

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
shock
Linux 2.x
Linux 2.x
Messaggi: 359
Iscritto il: mer 28 ott 2009, 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

[RISOLTO]Repository slacky in swaret

Messaggio da shock »

Salve, vorrei chiedere un'informazione...vorrei aggiungere i repository di slacky al file di configurazione di swaret...come devo fare?

Alla voce VERSION ho settato CURRENT...qualche domanda:

1 c'è differenza tra maiuscole e minuscole?

2 ho fatto bene a mettere current ? (se metto 13 swaret --update fallisce

Grazie.

Ciao.
Ultima modifica di shock il mer 25 nov 2009, 15:26, modificato 1 volta in totale.

Avatar utente
JohnnyMnemonic
Staff
Staff
Messaggi: 2733
Iscritto il: dom 5 set 2004, 0:00
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos
Località: Bologna
Contatta:

Re: Repository slacky in swaret

Messaggio da JohnnyMnemonic »

Per aggiornamenti dai repo ufficiali ti consiglio slackpkg, il tool ufficiale che trovi nei dischi di installazione.
Per i pacchetti di slacky.eu o di altri siti invece meglio slackyd (sviluppato da un utente del forum) o slapt-get, swaret se non sbaglio non è più aggiornato

albatrosla
Packager
Packager
Messaggi: 1336
Iscritto il: sab 27 mar 2004, 0:00
Slackware: current
Desktop: fluxbox.git
Località: Collegno, but made in Friûl
Contatta:

Re: Repository slacky in swaret

Messaggio da albatrosla »

Swaret non è compatibile con i package txz, pertanto non è più possibile utilizzarlo per la versione 13 e successive. Soluzioni:
- sei abbastanza tosto da modificare il sorgente di swaret
- sei abbatanza pigro da cambiare tool (slackyd o slapt-get)
Personalmente, sono abbastanza pigro e ho trovato in slackyd un valido sostituto, che aggiunge rispetto a swaret la sola operazione di dover installare i package a mano una volta scaricati (poco male).

Avatar utente
shock
Linux 2.x
Linux 2.x
Messaggi: 359
Iscritto il: mer 28 ott 2009, 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Repository slacky in swaret

Messaggio da shock »

Ho scaricato e installato con successo slackyd...potete insegnarmi ad usarlo?

Avatar utente
Kerd
Linux 0.x
Linux 0.x
Messaggi: 35
Iscritto il: mar 2 set 2008, 21:47
Slackware: 13.0
Kernel: 2.6.32.6
Desktop: Fluxbox
Distribuzione: OpenBSD
Contatta:

Re: Repository slacky in swaret

Messaggio da Kerd »

Prova a vedere cosa ti dice slackyd -h ;)

Avatar utente
Cenni
Linux 1.x
Linux 1.x
Messaggi: 104
Iscritto il: mar 27 feb 2007, 15:12
Nome Cognome: Cenni
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: XFCE
Distribuzione: salix e puppeee
Località: Torino

Re: Repository slacky in swaret

Messaggio da Cenni »

i comandi che ti dovrebbero servire di più:
-u scarica i filelist
-U controlla i pacchetti da aggiornare nei filelist e li scarica chiedendoti
-s cerca
-w ti da informazioni su
-g scarica
-p per ripulire /var/slackyd

i pacchetti li mette in /var/slackyd
quindi di lì vai e te li installi da root per esempio con

Codice: Seleziona tutto

bash-3.1# upgradepkg --install-new /var/slackyd/*txz  
ciao

Avatar utente
shock
Linux 2.x
Linux 2.x
Messaggi: 359
Iscritto il: mer 28 ott 2009, 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Repository slacky in swaret

Messaggio da shock »

Perche mi da questo errore?

Codice: Seleziona tutto

root@shock:~# slackyd h
bash: /usr/bin/slackyd: No such file or directory
root@shock:~#

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Repository slacky in swaret

Messaggio da phobos3576 »

shock ha scritto:Perche mi da questo errore?

Codice: Seleziona tutto

root@shock:~# slackyd h
bash: /usr/bin/slackyd: No such file or directory
root@shock:~#
Devi usare l'opzione -h e non h

Avatar utente
Cenni
Linux 1.x
Linux 1.x
Messaggi: 104
Iscritto il: mar 27 feb 2007, 15:12
Nome Cognome: Cenni
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: XFCE
Distribuzione: salix e puppeee
Località: Torino

Re: Repository slacky in swaret

Messaggio da Cenni »


Avatar utente
shock
Linux 2.x
Linux 2.x
Messaggi: 359
Iscritto il: mer 28 ott 2009, 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Repository slacky in swaret

Messaggio da shock »

Ecco ho provato anche con -h ma non va lo stesso...io ho solo messo in terminale installpkg nomepacchetto.txz e non ho fatto alcuna modifica.

Codice: Seleziona tutto

root@shock:~# slackyd -h
bash: /usr/bin/slackyd: No such file or directory
root@shock:~#

Dani
Linux 4.x
Linux 4.x
Messaggi: 1447
Iscritto il: mer 26 apr 2006, 1:52
Desktop: gnome
Distribuzione: arch

Re: Repository slacky in swaret

Messaggio da Dani »

shock ha scritto:Ecco ho provato anche con -h ma non va lo stesso...io ho solo messo in terminale installpkg nomepacchetto.txz e non ho fatto alcuna modifica.

Codice: Seleziona tutto

root@shock:~# slackyd -h
bash: /usr/bin/slackyd: No such file or directory
root@shock:~#
Forse hai scaricato il pacchetto da slacky e lo hai installato su una slackware a 64 bit ?

Avatar utente
shock
Linux 2.x
Linux 2.x
Messaggi: 359
Iscritto il: mer 28 ott 2009, 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Repository slacky in swaret

Messaggio da shock »

Si ,esatto lo ho installato su una slackware a 64 bit.

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Repository slacky in swaret

Messaggio da conraid »

shock ha scritto:Si ,esatto lo ho installato su una slackware a 64 bit.
i pacchetti di slacky sono a 32 bit
se hai problemi con la 64bit scrivi nella sezione apposita, altrimenti facciamo fatica a capire e darti consigli giusti

Avatar utente
shock
Linux 2.x
Linux 2.x
Messaggi: 359
Iscritto il: mer 28 ott 2009, 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Repository slacky in swaret

Messaggio da shock »

ops! scusate non mi ero proprio reso conto di aver sbagliato sezione.
Scrivo sempre in quella a 64...mi sono imbrogliato :lol:

Comunque come devo fare se è a 64 bit? il programma è diverso?

Avatar utente
conraid
Staff
Staff
Messaggi: 13459
Iscritto il: gio 14 lug 2005, 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Desktop: kde
Località: Livorno
Contatta:

Re: Repository slacky in swaret

Messaggio da conraid »

shock ha scritto:ops! scusate non mi ero proprio reso conto di aver sbagliato sezione.
Scrivo sempre in quella a 64...mi sono imbrogliato :lol:

Comunque come devo fare se è a 64 bit? il programma è diverso?
semplicemente non ci sono pacchetti su slacky a 64bit, quindi devi prenderli da altri repository
se slackyd funzioni o no con altri repository o a 64bit, non lo so, ma nella sezione trovi tutte le informazioni

Rispondi