[RISOLTO] Dell Studio 15 - problema velocità ventole

Scrivete su questo forum se avete problemi o volete dare buoni consigli sui computer portatili (Laptop).

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Citare il modello preciso del laptop in questione.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
zxzxasas
Linux 2.x
Linux 2.x
Messaggi: 397
Iscritto il: sab 15 nov 2008, 2:28
Nome Cognome: Pasquale
Slackware: current
Kernel: 2.6.35.7
Desktop: KDE 4.5.2

[RISOLTO] Dell Studio 15 - problema velocità ventole

Messaggio da zxzxasas »

Salve ragazzi!

Ho ricevuto qualche giorno un Dell Studio 15 (Versione 1558).
Ho provveduto alla rimozione di Windows 7 e ho messo Linux. Ho diversi problemi, ma quello che più mi sta facendo dannare è la velocità delle ventole della CPU.
Finchè il controllo è affidato all' hardware la gestione delle ventole è corretta, appena il controllo passa al sistema operativo, le ventole cominciano a girare a velocità massima anche se la CPU è in powersave a temperature di 20°.
Ho visto che non era presente il modulo i8k, di conseguenza ho provato a caricarlo.
Nulla da fare...impossibile inserire il modulo. Allora l' ho caricato forzato "modprobe i8k force=1" al che è stato caricato, ma le ventole comunque non vengono controllate, neppure manualmente con i8kutils, i8kctl ecc...
Aggiungo che l' output di i8kfan mi restituisce

Codice: Seleziona tutto

i8kfan 1 1
-1 -1
quasiasi siano i valori che passo...
INFO
Kernel 2.6.34
core i5-450M
MB Dell
Ultima modifica di zxzxasas il sab 31 lug 2010, 2:07, modificato 1 volta in totale.

zxzxasas
Linux 2.x
Linux 2.x
Messaggi: 397
Iscritto il: sab 15 nov 2008, 2:28
Nome Cognome: Pasquale
Slackware: current
Kernel: 2.6.35.7
Desktop: KDE 4.5.2

Re: Dell Studio 15 - problemi di configurazione!

Messaggio da zxzxasas »

Ragazzi cose strane...

Codice: Seleziona tutto

[root@darkstar pasquale]# dmesg | grep cooling
acpi device:02: registered as cooling_device3

Codice: Seleziona tutto

[root@darkstar pasquale]# cat /sys/devices/virtual/thermal/cooling_device3/cur_state 
0
al che:

Codice: Seleziona tutto

[root@darkstar pasquale]# echo 6 > /sys/devices/virtual/thermal/cooling_device3/cur_state 
mi si è abbassata la luminosità dello schermo... :| :| :?: :?:

zxzxasas
Linux 2.x
Linux 2.x
Messaggi: 397
Iscritto il: sab 15 nov 2008, 2:28
Nome Cognome: Pasquale
Slackware: current
Kernel: 2.6.35.7
Desktop: KDE 4.5.2

Re: Dell Studio 15 - problemi di configurazione!

Messaggio da zxzxasas »

Il mondo è di nuovo normale...più o meno :P
La ventola girava velocemente per qualche problema dovuto alla scheda video. Probabilmente il driver ati open creava qualche surriscaldamento da qualche parte, infatti installando il driver proprietario pare che tutto funzioni normalmente!

Avatar utente
Roland
Linux 1.x
Linux 1.x
Messaggi: 175
Iscritto il: mer 20 ago 2008, 1:32
Slackware: current x86_64
Kernel: 3.2.13
Desktop: KDE 4.8.2
Località: Catanzaro Lido

Re: [RISOLTO] Dell Studio 15 - problema velocità ventole

Messaggio da Roland »

la stessa identica cosa era successa a me col mio vaio...coi driver proprietari la ventola si è rilassata un bel po' ;)

zxzxasas
Linux 2.x
Linux 2.x
Messaggi: 397
Iscritto il: sab 15 nov 2008, 2:28
Nome Cognome: Pasquale
Slackware: current
Kernel: 2.6.35.7
Desktop: KDE 4.5.2

Re: [RISOLTO] Dell Studio 15 - problema velocità ventole

Messaggio da zxzxasas »

Attualmente (kernel 2.6.35), coi driver open il PM funziona...anche se non ho trovata alcuna interfaccia per gestirlo e va fatta direttamente la modifica in sysfs...

La riga da passare è

echo low|high|dynpm > /sys/class/drm/card0/device/power_profile

Avatar utente
Vito
Staff
Staff
Messaggi: 4180
Iscritto il: mar 5 dic 2006, 17:28
Nome Cognome: Vito
Desktop: MacOS
Località: Monaco (DE)
Contatta:

Re: [RISOLTO] Dell Studio 15 - problema velocità ventole

Messaggio da Vito »

Scusate se riesumo questo post,sapreste dirmi dove posso procurarmi i8kutils,i8kctl ecc ecc..?
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]

Rispondi