Errori nel caricamento di moduli in generic [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
gian_d
Linux 2.x
Linux 2.x
Messaggi: 327
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

Errori nel caricamento di moduli in generic [RISOLTO]

Messaggio da gian_d »

Sempre sul computer di mia moglie salta fuori un altro problema, credo dopo l'aggiornamento al kernel 5.10.5. Col precedente kernel questi messaggi non apparivano, così come non mi appaiono nella mia macchina con lo stesso kernel.

Codice: Seleziona tutto

/boot/initrd-generic-5.10.5.gz: Loading kernel modules from initrd image:
insmod /lib/modules/5.10.5/kernel/fs/jbd2/jbd2.ko
jbd2: exports duplicate symbol jbd2__journal_restart (owned by kernel)
modprobe: ERROR: coult not insert 'jbd2': Exec format error
insmod /lib/modules/5.10.5/kernl/fs/mbcache.ko
mbcache: exports duplicate symbol __mb_cache_entry_free 
modprobe: ERROR: coult not insert 'mbcache': Exec format error
insmod /lib/modules/5.10.5/kernel/fs/jbd2/jbd2.ko
jbd2: exports duplicate symbol jbd2__journal_restart (owned by kernel)
modprobe: ERROR: coult not insert 'ext4': Exec format error
/boot/initrd-generic-5.10.5.gz: Loading 'it' keyboard mapping:
EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null)
/boot/initrd-generic-5.10.5.gz: exiting
Qualcuno ci capisce qualcosa?

Può anche darsi che abbia sbagliato qualcosa nell'aggiornamento. L'ho automatizzato con uno script, ma è la prima volta che lo applico in quella macchina, apparentemente non mi aveva segnalato alcun intoppo
Ultima modifica di gian_d il dom 10 gen 2021, 13:39, modificato 1 volta in totale.

rik70
Iper Master
Iper Master
Messaggi: 2225
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 5.4.x
Desktop: Xfce 4.14
Distribuzione: Arch Linux

Re: Errori nel caricamento di moduli in generic

Messaggio da rik70 »

Provato a rigenerare l'initramfs?

F4B1CK
Linux 2.x
Linux 2.x
Messaggi: 278
Iscritto il: dom 11 gen 2004, 0:00
Slackware: current 64 bit
Kernel: 4.4.x
Desktop: KDE 5
Località: Cosenza
Contatta:

Re: Errori nel caricamento di moduli in generic

Messaggio da F4B1CK »

Ciao,
immagino utilizzi initrd: hai fatto rigenerare l'immagine con i moduli necessari, dopo l'aggiornamento?

Dato che parli di uno script che esegue l'update, magari è saltato quel passaggio. Se hai un log delle operazioni magari verificalo.

rik70
Iper Master
Iper Master
Messaggi: 2225
Iscritto il: gio 10 mar 2011, 9:21
Slackware: 64-current
Kernel: 5.4.x
Desktop: Xfce 4.14
Distribuzione: Arch Linux

Re: Errori nel caricamento di moduli in generic

Messaggio da rik70 »

Sembra una discrepanza tra l'immagine del kernel e l'initrrd(aggiornamento non andato completamente a buon fine?).

Prova anche a reinstallare il pacchetto kernel-generic prima di rigenerare l'initrd.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 327
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

Re: Errori nel caricamento di moduli in generic

Messaggio da gian_d »

Ho trovato l'errore!

Il grub è gestito da una ubuntu, con la configurazione delle entry impostata in grub.d. Ho fatto questa scelta dal momento che gli aggiornamenti di ubuntu riscrivono grub.cfg ogni volta, mentre con gli aggiornamenti della slackware non è necessario riconfigurare grub perché il bootloader punta a dei collegamenti simbolici che vengono reimpostati dallo script che ho fatto.

per la precisione, per caricare il kernel generic grub punta al symlink vmlinuz-generic e per caricare i moduli punta al symlink initrd-generic. Questi symlink vengono reimpostati ad ogni aggiornamento del kernel dallo script che ho fatto in modo che punti alle correnti denominazioni (vmlinuz-generic-5.10.5 e initrd-generic-5.10.5.gz)

L'errore che ho fatto è che provvisoriamente avevo impostato il grub in modo da caricare il kernel huge, quindi punta a vmlinuz, che a sua volta punta al kernel huge. Probabilmente questo va in conflitto nel momento in cui viene caricata l'immagine.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 327
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

Re: Errori nel caricamento di moduli in generic

Messaggio da gian_d »

insomma, lo script funziona regolarmente e alla sua prima esperienza è andato tutto ok, ma c'era quella svista nell'entry di grub.

gian_d
Linux 2.x
Linux 2.x
Messaggi: 327
Iscritto il: mer 16 lug 2014, 17:35
Nome Cognome: Giancarlo Dessì
Slackware: 64 current
Kernel: 5.10.xx
Desktop: KDE 5.20
Località: Sardinia
Contatta:

Re: Errori nel caricamento di moduli in generic [RISOLTO]

Messaggio da gian_d »

A posto, adesso gli errori non compaiono più.

Mi sono accorto dell'errore mentre rispondevo ai vostri post mettendo tutti i codici, dello script, del risultato di ls -l (in /boot) e della entry di grub. Solo allora ho visto che grub.cfg puntava al kernel huge invece del kernel generic.

Ecco cosa succede a modificare al volo grub.cfg senza rigenerarlo dalle impostazioni di grub.d, maledetta fretta. Nella prima installazione l'avevo fatto puntare al kernel huge commentando la riga che richiama l'immagine di generic. L'errore si verificava sicuramente anche con il kernel 5.10.4 ma mi era probabilmente sfuggito nei vari boot :-\

Rispondi