Salve a tutti,
<BR>ho installato JoLinux (basata su Slack con kernerl 2.6.5)
<BR>Ho dei problemi con apache e php.
<BR>Il server funziona ma php non viene interpretato.
<BR>Ho controllato il php.ini e il http.conf, mi sembrano corretti solo che in http.conf mancano le famose righe LoadModuel, AddModule e AddType.
<BR>Potrebbe essere quello il problema?
<BR>Risolvo reinstallando i pacchetti della Slack-current di Apache e php?
<BR>
<BR>Grazie <br>
apache e php su Jolinux
Moderatore: Staff
Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.
La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
- Loris
- Admin

- Messaggi: 7731
- Iscritto il: lun 31 mar 2003, 0:00
- Nome Cognome: Loris Vincenzi
- Località: Gradisca D'Isonzo
- Contatta:
apache e php su Jolinux
Per attivare il supporto php, devi decommentare la riga Include /etc/apache/mod_php.conf che trovi in fondo al file /etc/apache/httpd.conf, fai ripartire apachectl e riprovi con il file info.php
<BR><br>
<BR><br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
apache e php su Jolinux
Grazie,
<BR>infatti ho notato che bisognava decommentare la riga ma quando avvio apache ottengo questo errore:
<BR>
<BR>Syntax error on line 6 of /etc/apache/mod_php.conf:
<BR>Cannot load /usr/libexec/apache/libphp4.so into server: libmhash.so.2: cannot open shared object file: No such file or directory
<BR>/usr/sbin/apachectl start: httpd could not be started
<BR>
<BR>Come posso risolvere?
<BR>
<BR>
<BR>Grazie
<BR><br>
<BR>infatti ho notato che bisognava decommentare la riga ma quando avvio apache ottengo questo errore:
<BR>
<BR>Syntax error on line 6 of /etc/apache/mod_php.conf:
<BR>Cannot load /usr/libexec/apache/libphp4.so into server: libmhash.so.2: cannot open shared object file: No such file or directory
<BR>/usr/sbin/apachectl start: httpd could not be started
<BR>
<BR>Come posso risolvere?
<BR>
<BR>
<BR>Grazie
<BR><br>
apache e php su Jolinux
Installando <!-- BBCode Start --><A HREF="http://www.linuxpackages.net/search_vie ... sh&ver=9.1" TARGET="_blank">questo</A><!-- BBCode End --><br>
apache e php su Jolinux
Grazie 1000
<br>

