Il server X mi ha sbattuto fuori...

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Rispondi
Avatar utente
danix
Staff
Staff
Messaggi: 3289
Iscritto il: ven 27 ott 2006, 19:32
Nome Cognome: Danilo M.
Slackware: 64 current
Kernel: 6.12.13 x86_64
Desktop: i3
Località: Verona (VR)
Contatta:

Il server X mi ha sbattuto fuori...

Messaggio da danix »

Ciau a tutti...
il titolo non credo sia dei più chiari, comunque proverò a spiegarmi...
ero indaffarato a scrivere (in effetti avevo quasi una decina di finestre aperte per un totale di 4 applicazioni + adesklets, conky ed Eterm...
ad un certo punto mi ritrovo nella tty2 da cui ho fatto il login come se nulla fosse... :shock: quì accanto potete vedere una diapositiva della mia faccia sul momento...
ho controllato il log di X e c'è una sfilza interminabile di questi:

Codice: Seleziona tutto

AUDIT: Sat Jan 19 20:21:37 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:21:42 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:21:42 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:21:44 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:21:45 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:21:45 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:21:47 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:22:55 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:22:58 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:23:00 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:23:02 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:23:36 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:23:38 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:11 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:12 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:12 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:13 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:15 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:19 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:19 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:19 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:21 2008: 3104 X: client 30 rejected from local host (uid 0)
AUDIT: Sat Jan 19 20:25:23 2008: 3104 X: client 31 rejected from local host (uid 0)
Avete idea di cosa mi sia successo?? Devo esorcizzare la mia Ati??

Grazie dell'aiuto...
Ciau...
danix
danix ha scritto:non sono molto presente sul forum, e di ciò mi scuso con tutti

Mario Vanoni
Iper Master
Iper Master
Messaggi: 3174
Iscritto il: lun 3 set 2007, 21:20
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey
Località: Cuasso al Monte (VA)

Re: Il server X mi ha sbattuto fuori...

Messaggio da Mario Vanoni »

danix85 ha scritto:Ciau a tutti...
il titolo non credo sia dei più chiari, comunque proverò a spiegarmi...
ero indaffarato a scrivere (in effetti avevo quasi una decina di finestre aperte per un totale di 4 applicazioni + adesklets, conky ed Eterm...
ad un certo punto mi ritrovo nella tty2 da cui ho fatto il login come se nulla fosse... :shock: quì accanto potete vedere una diapositiva della mia faccia sul momento...

Avete idea di cosa mi sia successo?? Devo esorcizzare la mia Ati??

Grazie dell'aiuto...
Ciau...
La tua firma non e` la risposta?
CPU + men reggono?

Mario Vanoni

Avatar utente
danix
Staff
Staff
Messaggi: 3289
Iscritto il: ven 27 ott 2006, 19:32
Nome Cognome: Danilo M.
Slackware: 64 current
Kernel: 6.12.13 x86_64
Desktop: i3
Località: Verona (VR)
Contatta:

Re: Il server X mi ha sbattuto fuori...

Messaggio da danix »

la ram aveva ancora un centinaio di mega liberi al momento del fattaccio :)
la cpu forse era un po' sotto sforzo, ma ha fatto di peggio, altre volte ci ho compilato openoffice e non mi ha dato problemi...
e poi se avessi problemi di hardware adesso mi dovrebbe dare ancora problemi, no??
Invece ora è tutto normale...

mah...

Grazie dell'aiuto... :)
danix
danix ha scritto:non sono molto presente sul forum, e di ciò mi scuso con tutti

Mario Vanoni
Iper Master
Iper Master
Messaggi: 3174
Iscritto il: lun 3 set 2007, 21:20
Nome Cognome: Mario Vanoni
Slackware: 12.2
Kernel: 3.0.4 statico
Desktop: fluxbox/seamonkey
Località: Cuasso al Monte (VA)

Re: Il server X mi ha sbattuto fuori...

Messaggio da Mario Vanoni »

danix85 ha scritto:la ram aveva ancora un centinaio di mega liberi al momento del fattaccio :)
la cpu forse era un po' sotto sforzo, ma ha fatto di peggio, altre volte ci ho compilato openoffice e non mi ha dato problemi...
e poi se avessi problemi di hardware adesso mi dovrebbe dare ancora problemi, no??
Invece ora è tutto normale...

mah...

Grazie dell'aiuto... :)
ATTENTO: il kernel diventa cattivo se arriva vicino all'OOM!

Mario Vanoni

Avatar utente
phobos3576
Staff
Staff
Messaggi: 2980
Iscritto il: dom 17 apr 2005, 0:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Il server X mi ha sbattuto fuori...

Messaggio da phobos3576 »

Generalmente, questo tipo di problema si presenta a causa di installazioni difettose, sia di Xorg, sia dei driver video (soprattutto, nel caso in cui si utilizzino i driver proprietari ATI e nVidia).
Se stai usando i driver proprietari ATI, prova a rimuoverli completamente e poi a reinstallarli; molti utenti hanno risolto così quel problema.

Avatar utente
danix
Staff
Staff
Messaggi: 3289
Iscritto il: ven 27 ott 2006, 19:32
Nome Cognome: Danilo M.
Slackware: 64 current
Kernel: 6.12.13 x86_64
Desktop: i3
Località: Verona (VR)
Contatta:

Re: Il server X mi ha sbattuto fuori...

Messaggio da danix »

sto usando i driver radeon del kernel... comunque ho notato un rallentamento generale quando è successo il problema... immagino di avere esagerato... :)

Grazie delle risposte...
danix
danix ha scritto:non sono molto presente sul forum, e di ciò mi scuso con tutti

Avatar utente
maxmo
Linux 2.x
Linux 2.x
Messaggi: 336
Iscritto il: lun 28 feb 2005, 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: Il server X mi ha sbattuto fuori...

Messaggio da maxmo »

E' successo anche a me, + volte.
Credo che sia dovuto a firefox con applicazioni multimediali in streaming.

Avatar utente
danix
Staff
Staff
Messaggi: 3289
Iscritto il: ven 27 ott 2006, 19:32
Nome Cognome: Danilo M.
Slackware: 64 current
Kernel: 6.12.13 x86_64
Desktop: i3
Località: Verona (VR)
Contatta:

Re: Il server X mi ha sbattuto fuori...

Messaggio da danix »

in base a cosa sei arrivato a questa conclusione??
Io avevo effettivamente firefox + amarok in streaming... (+ kwrite + konqueror + un paio di finestre di terminal + 4 adesklets + conky + Eterm)

Immagino fosse davvero troppo... :roll:

Ciau...
danix
danix ha scritto:non sono molto presente sul forum, e di ciò mi scuso con tutti

Avatar utente
maxmo
Linux 2.x
Linux 2.x
Messaggi: 336
Iscritto il: lun 28 feb 2005, 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: Il server X mi ha sbattuto fuori...

Messaggio da maxmo »

Io solo firefox.
Il brutto è che non è possibile attribuire il problema ad un determinato sito od a dei determinati plugin perchè questo non si ripete. Io sono giunto ad un'ipotesi: il crash avviene per un sovraccarico d'informazione che non viene gestito, come una coda di stampa che non viene smaltita ed impegna il processore oppure la ram; il sistema rallenta e non si riesce ad inviare ulteriori comandi. Io risolvo con il tasto dx del mouse - chiudi-sull'applet che è aperta nella barra dell'applicazione, dopo qualche decina di secondi il sistema risponde che firefox non risponde e mi chiede se voglio chiuderlo.

Rispondi